Netgate Discussion Forum
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Search
    • Register
    • Login
    Introducing Netgate Nexus: Multi-Instance Management at Your Fingertips.

    Netgate 8300 ice0 -vlanhwfilter , vlancommunication not work after upgrade pfsense+ 26.3.1

    Scheduled Pinned Locked Moved Official Netgate® Hardware
    12 Posts 3 Posters 1.3k Views 4 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • D Offline
      dinohrnd
      last edited by

      [26.03.1-RELEASE][root@pfsense]/root: reboot
      Netgate pfSense Plus is now shutting down ...
      net.inet.carp.allow: 0 -> 0
      pflog0: promiscuous mode disabled
      ovpns1: link state changed to DOWN
      Waiting (max 60 seconds) for system process vnlru' to stop... done Waiting (max 60 seconds) for system process syncer' to stop...
      Syncing disks, vnodes remaining... 0 0 done

      Configuring VLAN interfaces...ice0: Failed to add VLAN filters:
      ice0: - vlan 255, status -14
      ice0: Failure adding VLAN 255 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 10, status -14
      ice0: Failure adding VLAN 10 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 20, status -14
      ice0: Failure adding VLAN 20 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 21, status -14
      ice0: Failure adding VLAN 21 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 30, status -14
      ice0: Failure adding VLAN 30 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 40, status -14
      ice0: Failure adding VLAN 40 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 31, status -14
      ice0: Failure adding VLAN 31 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 50, status -14
      ice0: Failure adding VLAN 50 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 60, status -14
      ice0: Failure adding VLAN 60 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 61, status -14
      ice0: Failure adding VLAN 61 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 70, status -14
      ice0: Failure adding VLAN 70 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 80, status -14
      ice0: Failure adding VLAN 80 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 90, status -14
      ice0: Failure adding VLAN 90 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 100, status -14
      ice0: Failure adding VLAN 100 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 101, status -14
      ice0: Failure adding VLAN 101 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 102, status -14
      ice0: Failure adding VLAN 102 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      ice0: Failed to add VLAN filters:
      ice0: - vlan 103, status -14
      ice0: Failure adding VLAN 103 to main VSI, err ICE_ERR_ALREADY_EXISTS aq_err OK
      done.

      1 Reply Last reply Reply Quote 0
      • stephenw10S Offline
        stephenw10 Netgate Administrator
        last edited by

        So what's actually not working? How are you testing?

        What version did you upgrade from?

        1 Reply Last reply Reply Quote 0
        • D Offline
          dinohrnd
          last edited by

          The initial version was 26.03-RELEASE, and even with this version, VLANs connected to the ICE0 interface did not work. The following options had to be checked for it to function dans :

          • Hardware Checksum Offloading
          • Hardware TCP Segmentation Offloading
          • Hardware Large Receive Offloading
          • Disable vlanhwfilter
            After upgrading to version 26.03.1, the problem returned, even with all the above options disabled and checked.
          1 Reply Last reply Reply Quote 0
          • stephenw10S Offline
            stephenw10 Netgate Administrator
            last edited by

            What does the output of ifconfg -vm ice0 show?

            Also check sysctl hw.ice.

            1 Reply Last reply Reply Quote 0
            • stephenw10S stephenw10 moved this topic from Hardware on
            • D Offline
              dinohrnd
              last edited by

              [26.03-RELEASE][root@pfsense]/root: ifconfg -vm ice0
              ifconfg: Command not found.
              [26.03-RELEASE][root@pfsense.valueit.mg]/root: sysctl hw.ice
              hw.ice.rdma_max_msix: 64
              hw.ice.irdma: 1
              hw.ice.enable_health_events: 1
              [26.03-RELEASE][root@pfsense.]/root:

              For now, I've had to cancel the update via "bectl" because it's blocking production for long time, but I'd like to know if anyone else has encountered the same problem and found a solution. I can no longer update the equipment without any news on how the problem was resolved.

              patient0P 1 Reply Last reply Reply Quote 0
              • patient0P Offline
                patient0 @dinohrnd
                last edited by

                @dinohrnd there was a typo, an 'i' missing. It should have been ifconfig -vm ice0

                D 1 Reply Last reply Reply Quote 1
                • D Offline
                  dinohrnd @patient0
                  last edited by

                  @patient0
                  [26.03-RELEASE][root@pfsense]/root: ifconfig -vm ice0
                  ice0: flags=1008843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST,LOWER_UP> metric 0 mtu 1500
                  options=4800028<VLAN_MTU,JUMBO_MTU,HWSTATS,MEXTPG>
                  capabilities=4f507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,NETMAP,RXCSUM_IPV6,TXCSUM_IPV6,HWSTATS,MEXTPG>
                  ether 90:ec:77:99:5a:11
                  inet6 fe80::92ec:77ff:fe99:5a11%ice0 prefixlen 64 scopeid 0x4
                  media: Ethernet autoselect (1000baseT <full-duplex>)
                  status: active
                  supported media:
                  media autoselect
                  media 1000baseT
                  nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
                  drivername: ice0
                  plugged: SFP/SFP+/SFP28 1000BASE-T (Unknown)
                  vendor: Methode Elec. PN: SP7041-M1-JN SN: G377170 DATE: 2016-09-08
                  [26.03-RELEASE][root@pfsense]/root:

                  1 Reply Last reply Reply Quote 0
                  • stephenw10S Offline
                    stephenw10 Netgate Administrator
                    last edited by

                    Hmm, so that's 26.03 and I assume VLANs are working there? But vlan hardware filtering is still enabled on the device?

                    1 Reply Last reply Reply Quote 0
                    • D Offline
                      dinohrnd
                      last edited by

                      That's right, it's version 26.03 and all the VLANs are working. Hardware VLAN filtering is still enabled, but Hardware Checksum Offloading, Hardware TCP Segmentation Offloading, and Hardware Large Receive Offloading are disabled.

                      1 Reply Last reply Reply Quote 0
                      • stephenw10S Offline
                        stephenw10 Netgate Administrator
                        last edited by

                        Hmm, so you disabled vlan hardware filtering as a test in 26.03.1 and it didn't work?

                        The ice(4) driver is identical in 26.03 and 26.03.1.

                        Do you see vlan tagged traffic on the parent NIC in a pcap.

                        1 Reply Last reply Reply Quote 0
                        • D Offline
                          dinohrnd
                          last edited by

                          Actually, I found the culprit. I configured an IPsec tunnel, and in the partner configuration file, there's 0.0.0.0/0 for the local subnet and 0.0.0.0/0 for the remote subnet. Pefsense doesn't accept 0.0.0.0/0 for the local subnet in the configuration, but it does accept 0.0.0.0/0 for the remote subnet. However, when I apply the change, all the VLANs fail.

                          But I'm still afraid to upgrade. :P

                          1 Reply Last reply Reply Quote 0
                          • stephenw10S Offline
                            stephenw10 Netgate Administrator
                            last edited by

                            Well if you set 0/0 as a remote side P2 then the IPSec daemon will grab traffic for all destinations as long as the local side of the P2 matches.

                            1 Reply Last reply Reply Quote 0
                            • First post
                              Last post
                            Copyright 2026 Rubicon Communications LLC (Netgate). All rights reserved.
                            Privacy Policy · Cookie Policy