Netgate Discussion Forum
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Search
    • Register
    • Login
    Introducing Netgate Nexus: Multi-Instance Management at Your Fingertips.

    No repos after updating to 26.07.b.20260731.1233

    Scheduled Pinned Locked Moved Plus 26.07 Snapshots (Retired)
    9 Posts 3 Posters 319 Views 2 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • JeGrJ Offline
      JeGr LAYER 8 Moderator
      last edited by JeGr

      When trying to update from 0702 snapshot of the Beta I already had problems with the repository files being deleted after a check for repos. The /usr/local/etc/pfSense/pkg/repos/ dir is simply empty, the only repo files left are in the ./pfSense-old/pkg/repos/ directory branch.
      I thought there was a problem with updating from beta to beta so used the BEs to roll back to 26.03.1 then updated to 26.07b-latest (0731) and that went through, but after rebooting I'm not again left with no repository files as they are instantly deleted when trying to access either System/Update or the Package Manager GUI.

      I vaguely had some things about a certificates not being right scrolling by (so related to the ACME YR1 cert?) but afterwards there simply is no repo info anymore and most tools fail to run with no source to install from.

      What's up with that? I thought we were short of entering RC territory? :)

      Edit: correction: even the pfsense-old/pkg/repos/ path is not empty and no repository files are there anymore.

      Don't forget to upvote ๐Ÿ‘ those who kindly offered their time and brainpower to help you!

      If you're interested, I'm available to discuss details of German-speaking paid support (for companies) if needed.

      patient0P 1 Reply Last reply Reply Quote 0
      • patient0P Offline
        patient0 @JeGr
        last edited by

        @JeGr I can't say anything about the internals of it. But if I delete the files in /usr/local/etc/pfSense/pkg/repos/ and go to 'System / Update / Update Settings' and back to 'System / Update / System Update' or reboot the files (and I think the whole /usr/local/etc/pfSense directory) are recreated.

        Is that not the case for you?

        JeGrJ 1 Reply Last reply Reply Quote 0
        • JeGrJ Offline
          JeGr LAYER 8 Moderator @patient0
          last edited by

          @patient0 No it isn't. They are simply gone and neither the package manager (no packages to install in list) nor the update handler dropdown is populated anymore.

          af94b2ff-10cc-4c92-ad25-452484e708a3-image.png

          The selection is simply empty.
          If I manually copy over or recreate the pkg files, I can run pkg on the shell again but have the otherwise mentioned LE certificate errors all over. As soon as I select either System Update or the Package Manager where a check of repositories is performed, the files are deleted and the problem begin anew.

          [26.07-BETA][admin@pfs-plus-devel]/usr/local/etc/pfSense/pkg/repos: ls -la
          total 1
          drwxr-xr-x  2 root wheel 2 Aug  4 15:11 .
          drwxr-xr-x  3 root wheel 3 Aug  4 15:11 ..
          

          Don't forget to upvote ๐Ÿ‘ those who kindly offered their time and brainpower to help you!

          If you're interested, I'm available to discuss details of German-speaking paid support (for companies) if needed.

          patient0P 1 Reply Last reply Reply Quote 0
          • patient0P Offline
            patient0 @JeGr
            last edited by patient0

            @JeGr said in No repos after updating to 26.07.b.20260731.1233:

            The selection is simply empty

            That is difference of course, I couldn't replicate that.

            Does running pfSense-repoc -N help (pfSense-repoc -p to list the repos)? Command from a different issue, https://forum.netgate.com/post/1243818.

            JeGrJ 1 Reply Last reply Reply Quote 0
            • JeGrJ Offline
              JeGr LAYER 8 Moderator @patient0
              last edited by JeGr

              @patient0 Yeah, as I tried describing, the -repoc binary fetches the repo just fine, you can run pkg afterwards but it shows cert errors galore:

              # pkg-static -d update
              
              Updating pfSense-core repository catalogue...
              DBG(1)[69766]> PkgRepo: verifying update for pfSense-core
              DBG(1)[69766]> PkgRepo: need forced update of pfSense-core
              DBG(1)[69766]> Pkgrepo, begin update of '/var/db/pkg/repos/pfSense-core/db'
              DBG(1)[69766]> (fetch) Request to fetch pkg+https://pfsense-plus-pkg-beta.netgate.com/pfSense_plus-v26_07_amd64-core/meta.conf
              DBG(1)[69766]> (fetch) libfetch> connecting
              DBG(1)[69766]> (fetch) libfetch> fetching from: https://pfsense-plus-pkg-beta01.atx.netgate.com/pfSense_plus-v26_07_amd64-core/meta.conf with opts "i"
              Certificate verification failed for /C=US/ST=Texas/L=Austin/O=Rubicon Communications, LLC (Netgate)/OU=pfSense Plus/CN=pfsense-plus-pkg-beta01.atx.netgate.com
              1000E0F6F8350000:error:0A000086:SSL routines:tls_post_process_server_certificate:certificate verify failed:/usr/local/poudriere/jails/main-amd64/usr/src/crypto/openssl/ssl/statem/statem_clnt.c:2125:
              DBG(1)[69766]> (fetch) libfetch> fetching from: https://pfsense-plus-pkg-beta01.atx.netgate.com/pfSense_plus-v26_07_amd64-core/meta.conf with opts "i"
              Certificate verification failed for /C=US/ST=Texas/L=Austin/O=Rubicon Communications, LLC (Netgate)/OU=pfSense Plus/CN=pfsense-plus-pkg-beta01.atx.netgate.com
              1000E0F6F8350000:error:0A000086:SSL routines:tls_post_process_server_certificate:certificate verify failed:/usr/local/poudriere/jails/main-amd64/usr/src/crypto/openssl/ssl/statem/statem_clnt.c:2125:
              DBG(1)[69766]> (fetch) libfetch> fetching from: https://pfsense-plus-pkg-beta01.atx.netgate.com/pfSense_plus-v26_07_amd64-core/meta.conf with opts "i"
              Certificate verification failed for /C=US/ST=Texas/L=Austin/O=Rubicon Communications, LLC (Netgate)/OU=pfSense Plus/CN=pfsense-plus-pkg-beta01.atx.netgate.com
              1000E0F6F8350000:error:0A000086:SSL routines:tls_post_process_server_certificate:certificate verify failed:/usr/local/poudriere/jails/main-amd64/usr/src/crypto/openssl/ssl/statem/statem_clnt.c:2125:
              DBG(1)[69766]> (fetch) Request to fetch pkg+https://pfsense-plus-pkg-beta.netgate.com/pfSense_plus-v26_07_amd64-core/meta.txz
              

              But as soon as you go to the Update settings, the whole directory tree under /usr/local/etc/pfSense gets purged and is empty. repoc can repopulate it, but the Update handler deletes it (I guess because of the certificate errors).

              Sorry if that was described a bit all over the place :)

              Don't forget to upvote ๐Ÿ‘ those who kindly offered their time and brainpower to help you!

              If you're interested, I'm available to discuss details of German-speaking paid support (for companies) if needed.

              patient0P 1 Reply Last reply Reply Quote 0
              • patient0P Offline
                patient0 @JeGr
                last edited by

                @JeGr but you did run pkg-static -d update, not pfSense-repoc -N. Does pkg-static -d update run pfSense-repoc?

                But if that doesn't help we gotta wait for Netgate to chime in.

                1 Reply Last reply Reply Quote 0
                • M Offline
                  marcosm Netgate
                  last edited by

                  Check ls -lah /usr/local/share/pfSense/ssl/ and make sure none of the files there are empty.

                  JeGrJ 2 Replies Last reply Reply Quote 0
                  • JeGrJ Offline
                    JeGr LAYER 8 Moderator @marcosm
                    last edited by

                    @marcosm said in No repos after updating to 26.07.b.20260731.1233:

                    ls -lah /usr/local/share/pfSense/ssl/

                    [26.07-BETA][admin@pfs-plus-devel.lab.test]/usr/local/etc: ls -lah /usr/local/share/pfSense/ssl/
                    total 51 KB
                    drwxr-xr-x  2 root wheel    6B Aug  4 11:49 .
                    drwxr-xr-x  8 root wheel   16B Aug  4 11:48 ..
                    -rw-r--r--  1 root wheel  8.9K Jul 30 18:30 netgate-ca.pem
                    -rw-r--r--  1 root wheel  1.3K Aug  4 11:49 netgate-zuul-ca.pem
                    -rw-r--r--  1 root wheel   12K Jul 30 18:30 openssl.cnf
                    -rw-r--r--  1 root wheel   12K Nov 21  2024 openssl.cnf.orig
                    

                    No, not empty.

                    Don't forget to upvote ๐Ÿ‘ those who kindly offered their time and brainpower to help you!

                    If you're interested, I'm available to discuss details of German-speaking paid support (for companies) if needed.

                    1 Reply Last reply Reply Quote 0
                    • JeGrJ Offline
                      JeGr LAYER 8 Moderator @marcosm
                      last edited by

                      @marcosm sent you the output

                      Don't forget to upvote ๐Ÿ‘ those who kindly offered their time and brainpower to help you!

                      If you're interested, I'm available to discuss details of German-speaking paid support (for companies) if needed.

                      1 Reply Last reply Reply Quote 0
                      • First post
                        Last post
                      Copyright 2026 Rubicon Communications LLC (Netgate). All rights reserved.
                      Privacy Policy · Cookie Policy