Netgate Discussion Forum
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Search
    • Register
    • Login
    Introducing Netgate Nexus: Multi-Instance Management at Your Fingertips.

    Auto Config Backup fails with unknown error

    Scheduled Pinned Locked Moved General pfSense Questions
    11 Posts 3 Posters 405 Views 3 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • K Offline
      Kenni
      last edited by

      I've noticed over the past couple of months that when I log into pfSense CE v2.8.1, there's often a notification with the following error:

      cc4d5daa-c417-46ea-8fb8-d51c6fcfd109-image.png

      At the same time I see that the size of many recent backups are listed to be 0 B in size:

      f4da4246-1ae8-4d50-a1e3-ae0eeb18d6a3-image.png

      The "Current" backup is listed to be 134 KiB, but if I manually trigger a "Backup Now" or do some other changes which causes a new backup to be initiated, the backup that was previously "Current" changes its displayed size to 0 B, while the new "Current" is now listed to be 134 KiB.

      However, if I click on download on any of the 0 B configuration backups, it downloads a file with a ~134KiB file size - mostly pointing towards this just being a display issue - but that doesn't explain the unknown error in the notification.

      Any idea of what is going on, or what I can do to help debug the issue - or at least just reset all the ACB configuration and start from scratch?

      Thanks.

      1 Reply Last reply Reply Quote 0
      • stephenw10S Offline
        stephenw10 Netgate Administrator
        last edited by

        I assume it doesn't fail with errors every time? Like you don't see new errors if you run a manual backup?

        K 1 Reply Last reply Reply Quote 0
        • K Offline
          Kenni @stephenw10
          last edited by

          @stephenw10 Yes, that seems to be the case. I just tested with a manual backup and it did not trigger any error notification.

          1 Reply Last reply Reply Quote 0
          • stephenw10S Offline
            stephenw10 Netgate Administrator
            last edited by

            Hmm, OK. Do you see anything else logged at the time of the failure? A DNS issue perhaps?

            K 1 Reply Last reply Reply Quote 0
            • K Offline
              Kenni @stephenw10
              last edited by

              @stephenw10 So it happened again today, it seems to be related to pfSense stopping to resolve DNS for its internal queries. I've experienced this a couple of times during the past 6 months. So while all LAN clients continue to be able to resolve DNS by querying the LAN IP of pfSense, pfSense itself cannot resolve any DNS names:

              IMG_0281.jpeg

              IMG_0282.jpeg

              IMG_0284.jpeg

              I've looked at all of the logs in the System Logs section, but I do not see any errors beside the failing filterdns logs shown above. Rebooting pfSense "fixes" the issue.

              1 Reply Last reply Reply Quote 0
              • stephenw10S Offline
                stephenw10 Netgate Administrator
                last edited by

                How do you have the DNS behaviour configured in System > General setup?

                Are LAN clients using Unbound in pfSense for DNS?

                K 1 Reply Last reply Reply Quote 0
                • K Offline
                  Kenni @stephenw10
                  last edited by

                  @stephenw10 The configuration looks like this:

                  6f5e3f6f-3009-490d-ac56-79e348e5fd10-image.png

                  Regarding Unbound, then yes, I would assume so (?). DNS Forwarder is not enabled, while DNS resolver is enabled. Clients are served with the IP address of one DNS server through DHCP, which is the LAN IP of pfSense.

                  97c88850-f122-4257-af5c-a86c29b08c38-image.png

                  1 Reply Last reply Reply Quote 0
                  • stephenw10S Offline
                    stephenw10 Netgate Administrator
                    last edited by

                    Hmm, one of those should always respond if it can be reached.

                    Next time it fails I would try to dig@ it directly from the CLI like:

                    [26.07-RELEASE][root@4100-3.stevew.lan]/root: dig @1.1.1.2 acb.netgate.com
                    
                    ; <<>> DiG 9.20.23 <<>> @1.1.1.2 acb.netgate.com
                    ; (1 server found)
                    ;; global options: +cmd
                    ;; Got answer:
                    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19781
                    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
                    
                    ;; OPT PSEUDOSECTION:
                    ; EDNS: version: 0, flags:; udp: 1232
                    ;; QUESTION SECTION:
                    ;acb.netgate.com.               IN      A
                    
                    ;; ANSWER SECTION:
                    acb.netgate.com.        300     IN      A       208.123.73.69
                    
                    ;; Query time: 236 msec
                    ;; SERVER: 1.1.1.2#53(1.1.1.2) (UDP)
                    ;; WHEN: Thu Aug 27 12:55:06 BST 2026
                    ;; MSG SIZE  rcvd: 60
                    

                    Either DNS traffic is being blocked somehow or you have some general connectivity issue I'd guess.

                    1 Reply Last reply Reply Quote 0
                    • N Offline
                      NOCling
                      last edited by

                      My 2100 works, but I have the same problem with my 6100, even if i try to run a manual backup.

                      DNS works, if i try to resolve from the pf itself.
                      I renew all keys, push in the encryption key again, nothing works.

                      An error occurred while uploading the encrypted Netgate pfSense Plus configuration backup to https://acb.netgate.com (60) @ 2026-08-28 02:03:07
                      An error occurred while uploading the encrypted Netgate pfSense Plus configuration backup to https://acb.netgate.com (60) @ 2026-08-28 18:26:00
                      

                      Netgate 6100 & Netgate 2100

                      K 1 Reply Last reply Reply Quote 0
                      • K Offline
                        Kenni @NOCling
                        last edited by

                        @NOCling Sounds like a different issue when you also experience it on manual backups + your DNS is working + you get a different error message (“60” instead of “Unknown error”). Probably better with a new thread instead of mixing two different issues together.

                        1 Reply Last reply Reply Quote 0
                        • stephenw10S Offline
                          stephenw10 Netgate Administrator
                          last edited by

                          Yup that looks more like a cert problem. Better to open a new thread.

                          1 Reply Last reply Reply Quote 0
                          • First post
                            Last post
                          Copyright 2026 Rubicon Communications LLC (Netgate). All rights reserved.
                          Privacy Policy · Cookie Policy