Netgate Discussion Forum
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Search
    • Register
    • Login
    Introducing Netgate Nexus: Multi-Instance Management at Your Fingertips.

    26.07 upgrade fails, pfSense.conf file missing

    Scheduled Pinned Locked Moved Problems Installing or Upgrading pfSense Software
    21 Posts 6 Posters 1.2k Views 9 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • beerguzzleB Offline
      beerguzzle
      last edited by

      Netgate 1100, attempting to go from 26.03.1 to 26.07.

      I am at the point of, from console update attempt:

      Enter an option: 13

      cp: /usr/local/etc/pkg/repos/pfSense.conf: No such file or directory
      ERROR: It was not possible to determine pkg remote version
      ERROR: It was not possible to determine pfSense-u-boot-1100 remote version
      ERROR: It was not possible to determine pkg remote version

      Updating repositories metadata...
      pkg-static: Unable to open '/usr/local/etc/pkg/repos//pfSense.conf':No such file or directory
      No repositories are enabled.
      ERROR: It was not possible to determine pfSense-upgrade remote version
      Upgrading pfSense-upgrade...failed.

      I had done the
      pkg-static clean -ay;
      pkg-static install -fy pkg;
      pkg-static install -xfy pfSense-repo pfSense-upgrade

      per the page https://docs.netgate.com/pfsense/en/latest/troubleshooting/upgrades.html

      That did not terminate abnormally. Then did a restore from my previous 26.03.1 backup, that worked so I am at that version, but cannot update to 26.07.

      How to get this missing file back? Help...

      Netgate 1100 and Netgate 2100, latest pfsense+ version

      SteveITSS 1 Reply Last reply Reply Quote 0
      • SteveITSS Offline
        SteveITS Rebel Alliance @beerguzzle
        last edited by

        @beerguzzle first check for space:
        https://docs.netgate.com/pfsense/en/latest/troubleshooting/filesystem-shrink.html

        Assuming youโ€™re using ZFS you can also revert to the last BE.

        To upgrade, select your branch in System/Update/Update Settings. When upgrading, allow 10-15 minutes to reboot, or more depending on packages, CPU, and/or disk speed.
        Only install packages for your version of pfSense.
        Upvote ๐Ÿ‘ helpful posts!

        beerguzzleB 1 Reply Last reply Reply Quote 0
        • beerguzzleB Offline
          beerguzzle @SteveITS
          last edited by

          @SteveITS The only boot environment listed is 26.03.1, which it is running.

          I have managed to get myself to the state of :

          pfSense-upgrade -d -c
          cp: /usr/local/etc/pkg/repos/pfSense.conf: No such file or directory
          ERROR: It was not possible to identify which pfSense meta package is installed

          Upgrading pkg...
          pkg-static: Setting ALTABI manually is no longer supported, set ABI and OSVERSION or ABI_FILE instead.
          pkg-static: Setting ABI requires setting OSVERSION, guessing the OSVERSION as: 1600000
          No repositories are enabled.

          Seriously messed up here...

          Netgate 1100 and Netgate 2100, latest pfsense+ version

          FamelazarF 1 Reply Last reply Reply Quote 0
          • stephenw10S Offline
            stephenw10 Netgate Administrator
            last edited by

            If you're only using the console you'll need to run: pfSense-repoc -N

            That will pull the repo data and repopulate that file.

            beerguzzleB 1 Reply Last reply Reply Quote 0
            • FamelazarF Offline
              Famelazar @beerguzzle
              last edited by

              @beerguzzle
              Hey there! I am facing the same problem after an update-attempt thru the Web-GUI + I got an Kernel-Exception during boot, which could be fixed by booting the old Kernel and creating/modify the "/boot/loader.conf.local" file as stated here in the forum and the 26.07 Kernel now boots OK:
              (echo 'hint.acpi_spmc.0.disabled=1' >> /boot/loader.conf.local )
              Nevertheless the file "/usr/local/etc/pkg/repos/pfSense.conf" is gone and is unfortunately NOT rebuild by using "pfSense-repoc -N".
              The WebGUI shows NO selectable Branches ...
              Hope there is a fix. Maybe w/ some "Magic" from Netgate ?? ๐Ÿ˜‰๐Ÿ™‚

              FamelazarF 1 Reply Last reply Reply Quote 0
              • FamelazarF Offline
                Famelazar @Famelazar
                last edited by Famelazar

                Addition
                Trying an update from the Console ! got this error after trying option 13 from the console.
                (While the Error statement shows 2 slashes "/", which is, as I suggest, only a display error and not caused by a wrong Path in the script) :
                _
                Enter an option: 13
                cp: /usr/local/etc/pkg/repos/pfSense.conf: No such file or directory
                ERROR: It was not possible to determine pkg remote version
                ERROR: It was not possible to determine pkg remote version
                Updating repositories metadata...
                pkg-static: Unable to open '/usr/local/etc/pkg/repos//pfSense.conf':No such file or directory
                No repositories are enabled.
                ERROR: It was not possible to determine pfSense-upgrade remote version
                Upgrading pfSense-upgrade...failed.

                FamelazarF 1 Reply Last reply Reply Quote 0
                • FamelazarF Offline
                  Famelazar @Famelazar
                  last edited by Famelazar

                  2nd addition
                  "pfSense-repoc -N" works and delivers the pfsense.conf at correct path (see below) BUT it vanishes after an update-check via the WebGUI or the Console as well as the "Available Package Information". I never checked that before, but I guess the pfSense.conf along with the other files should stay there... ๐Ÿ˜‰
                  _
                  FreeBSD: { enabled: no }

                  pfSense-core: {
                  url: "pkg+https://pfsense-plus-pkg.netgate.com/pfSense_plus-v26_07_amd64-core",
                  mirror_type: "srv",
                  signature_type: "fingerprints",
                  fingerprints: "/usr/local/share/pfSense/keys/pkg",
                  enabled: yes
                  }

                  pfSense: {
                  url: "pkg+https://pfsense-plus-pkg.netgate.com/pfSense_plus-v26_07_amd64-pfSense_plus_v26_07",
                  mirror_type: "srv",
                  signature_type: "fingerprints",
                  fingerprints: "/usr/local/share/pfSense/keys/pkg",
                  enabled: yes
                  }
                  _

                  1 Reply Last reply Reply Quote 0
                  • stephenw10S Offline
                    stephenw10 Netgate Administrator
                    last edited by

                    Since you are already on 26.07 try: pfSense-repoc -nZD

                    That's what it is running that seems to be failing and removing the repo data so I'd expect to see an error from it.

                    FamelazarF 1 Reply Last reply Reply Quote 0
                    • beerguzzleB Offline
                      beerguzzle @stephenw10
                      last edited by

                      @stephenw10 The command "pfSense-upgrade -d -c" wipes out the contents of /usr/local/etc/pfSense/pkg/repos on my box. See attached tarfile.
                      My sequence is: this directory is empty. Run "pfSense-repoc -N". The directory populates with a bunch of files. Run "pfSense-upgrade -d -c". The contents of this directory are wiped out, with the message:

                      ERROR: It was not possible to identify which pfSense meta package is installed
                      Upgrading pkg...
                      pkg-static: Setting ALTABI manually is no longer supported, set ABI and OSVERSION or ABI_FILE instead.
                      pkg-static: Setting ABI requires setting OSVERSION, guessing the OSVERSION as: 1600000
                      pkg-static: Unable to open '/usr/local/etc/pkg/repos//pfSense.conf':No such file or directory
                      No repositories are enabled.

                      Rerun "pfSense-repoc -N" and the directory is repopulated. This looks like a bug, unless something else is missing somewhere. What is going wrong? How to fix? widget.tar

                      Netgate 1100 and Netgate 2100, latest pfsense+ version

                      beerguzzleB 1 Reply Last reply Reply Quote 0
                      • FamelazarF Offline
                        Famelazar @stephenw10
                        last edited by Famelazar

                        @stephenw10
                        Ok here we go ๐Ÿ˜ƒ A Summary

                        • executing a "pfSense-repoc -N" brings back these files in "/usr/local/etc/pfSense/pkg/repos"

                        pfSense-repo-0000-cert.pem
                        pfSense-repo-0000-key.pem
                        pfSense-repo-0000.abi
                        pfSense-repo-0000.altabi
                        pfSense-repo-0000.conf
                        pfSense-repo-0000.default
                        pfSense-repo-0000.descr
                        pfSense-repo-0000.name
                        pfSense-repo-0000.osversion
                        pfSense-repo-0000.release
                        pfSense-repo-0000.version

                        • check for updates (WebGUI/cli) or list of aivable packages in WebGUI let them vanish again...
                          Outpuft from "pfSense-repoc -nZD" delivers from my FW-Host:

                        pfSense-repoc -nZD
                        OS: FreeBSD
                        OS Version: 16.0-CURRENT
                        Platform: amd64
                        Product: Netgate pfSense Plus
                        Version: 26.07-RELEASE
                        FS type: ufs
                        Language: en_US
                        Model: unknown hardware
                        NDI: hidden
                        License Phrase: garlic-catch-purpose-pendant
                        Package prefix: pfSense-pkg-
                        Serial: (null)
                        Repo path: /usr/local/etc/pfSense
                        Request query: {"platform":"unknown hardware","os":"FreeBSD","osver":"16.0-CURRENT","prod":"Netgate pfSense Plus","ver":"26.07-RELEASE","ed":"Plus","fstype":"ufs","pkgs":"[{"name":"acme","ver":"1.3.2"},{"name":"Nexus","ver":"26.07"},{"name":"squid","ver":"0.5.11"},{"name":"Backup","ver":"0.7"},{"name":"Shellcmd","ver":"1.0.7"},{"name":"darkstat","ver":"3.1.6"},{"name":"Lightsquid","ver":"3.0.11"},{"name":"RRD_Summary","ver":"2.2.2"},{"name":"Service_Watchdog","ver":"1.8.7_7"},{"name":"Status_Traffic_Totals","ver":"2.3.5_3"},{"name":"openvpn-client-export","ver":"1.9.13"},{"name":"openvpn-client-import","ver":"1.2_4"}]"}
                        POST data: uid=hidden&language=en_US&serial=&version=%7B%22platform%22%3A%22unknown+hardware%22%2C%22os%22%3A%22FreeBSD%22%2C%22osver%22%3A%2216.0-CURRENT%22%2C%22prod%22%3A%22Netgate+pfSense+Plus%22%2C%22ver%22%3A%2226.07-RELEASE%22%2C%22ed%22%3A%22Plus%22%2C%22fstype%22%3A%22ufs%22%2C%22pkgs%22%3A%22%5B%7B%5C%22name%5C%22%3A%5C%22acme%5C%22%2C%5C%22ver%5C%22%3A%5C%221.3.2%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Nexus%5C%22%2C%5C%22ver%5C%22%3A%5C%2226.07%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22squid%5C%22%2C%5C%22ver%5C%22%3A%5C%220.5.11%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Backup%5C%22%2C%5C%22ver%5C%22%3A%5C%220.7%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Shellcmd%5C%22%2C%5C%22ver%5C%22%3A%5C%221.0.7%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22darkstat%5C%22%2C%5C%22ver%5C%22%3A%5C%223.1.6%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Lightsquid%5C%22%2C%5C%22ver%5C%22%3A%5C%223.0.11%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22RRD_Summary%5C%22%2C%5C%22ver%5C%22%3A%5C%222.2.2%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Service_Watchdog%5C%22%2C%5C%22ver%5C%22%3A%5C%221.8.7_7%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22Status_Traffic_Totals%5C%22%2C%5C%22ver%5C%22%3A%5C%222.3.5_3%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22openvpn-client-export%5C%22%2C%5C%22ver%5C%22%3A%5C%221.9.13%5C%22%7D%2C%7B%5C%22name%5C%22%3A%5C%22openvpn-client-import%5C%22%2C%5C%22ver%5C%22%3A%5C%221.2_4%5C%22%7D%5D%22%7D&arch=amd64

                        1 Reply Last reply Reply Quote 0
                        • stephenw10S Offline
                          stephenw10 Netgate Administrator
                          last edited by

                          @Famelazar said in 26.07 upgrade fails, pfSense.conf file missing:

                          garlic-catch-purpose-pendant

                          Hmm, seems like might be missing a feature for some reason. Digging....

                          FamelazarF 1 Reply Last reply Reply Quote 0
                          • Z Offline
                            Zermus
                            last edited by Zermus

                            This post is deleted!
                            1 Reply Last reply Reply Quote 0
                            • Z Zermus referenced this topic
                            • FamelazarF Offline
                              Famelazar @stephenw10
                              last edited by

                              @stephenw10
                              Thanks!

                              S 1 Reply Last reply Reply Quote 0
                              • S Offline
                                sgw @Famelazar
                                last edited by sgw

                                I join here because I seem to hit the same issue.

                                EDIT: SG1100, 26.07RC

                                I see the same loop of missing conf-file, repopulating by manually executing pfSense-repoc -N and pfSense-upgrade failing.

                                1 Reply Last reply Reply Quote 0
                                • beerguzzleB Offline
                                  beerguzzle @beerguzzle
                                  last edited by

                                  I'm dead in the water regarding upgrading to 26.07, due to this "setting ALTABI" stuff from pkg-static and the fact that my machine isn't smart enough to see that there are updates. What to do? Open a support ticket with TAC-lite?

                                  Attempting to reinstall the OS via img and bootable USB is unpalatable since I use modern Macs and they don't support /dev/cu.usbserial devices natively any more. I would have to buy the Serial app, or attempt with Coolterm. Any suggestions on these two apps? Really don't want to reinstall pfSense from scratch...

                                  Netgate 1100 and Netgate 2100, latest pfsense+ version

                                  1 Reply Last reply Reply Quote 0
                                  • stephenw10S Offline
                                    stephenw10 Netgate Administrator
                                    last edited by

                                    It's nothing to do with the altabi value. It's clearing the repo data for some reason.

                                    Can you send me your NDI in chat? I'll check what the backend is seeing.

                                    FamelazarF 1 Reply Last reply Reply Quote 0
                                    • FamelazarF Offline
                                      Famelazar @stephenw10
                                      last edited by Famelazar

                                      @stephenw10
                                      Nice! Some magic happened since yesterday.

                                      • Packages for 26.07are now listed.
                                      • branch shows up correct.
                                      • dashboard auto-update check is enabled.
                                        Many thanks to anyone who was working on that and fixed the issue!
                                      S 1 Reply Last reply Reply Quote 1
                                      • S Offline
                                        sgw @Famelazar
                                        last edited by

                                        @stephenw10

                                        I can also report a successful upgrade now. Thanks for the work on that release.

                                        1 Reply Last reply Reply Quote 1
                                        • stephenw10S Offline
                                          stephenw10 Netgate Administrator
                                          last edited by

                                          Nice I'll pass that to the devs who've been hammering on this. ๐Ÿ‘

                                          FamelazarF 1 Reply Last reply Reply Quote 1
                                          • FamelazarF Offline
                                            Famelazar @stephenw10
                                            last edited by

                                            @stephenw10 ๐Ÿ‘

                                            1 Reply Last reply Reply Quote 0
                                            • First post
                                              Last post
                                            Copyright 2026 Rubicon Communications LLC (Netgate). All rights reserved.
                                            Privacy Policy · Cookie Policy