Netgate Discussion Forum
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Search
    • Register
    • Login
    Introducing Netgate Nexus: Multi-Instance Management at Your Fingertips.

    Crash report

    Scheduled Pinned Locked Moved CE 2.9.0 Snapshots (Retired)
    10 Posts 3 Posters 402 Views 4 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • yon 0Y Offline
      yon 0
      last edited by

      Crash report begins. Anonymous machine information:

      amd64
      16.0-CURRENT
      FreeBSD 16.0-CURRENT #0 RELENG_2_9_0-n256132-d8e3138ecf52: Thu Aug 6 18:16:43 UTC 2026 root@pfsense-build-release-amd64-1.eng.atx.netgate.com:/var/jenkins/workspace/pfSense-CE-snapshots-2_9_0-main/obj/amd64/h1bjZuKg/var/jenkins/workspace/pfSense-CE-s

      Crash report details:

      PHP Errors:
      [19-Aug-2026 03:03:12 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:03:21 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:22:31 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:23:08 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:28:31 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:35:52 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:36:25 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:37:17 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:38:14 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843
      [19-Aug-2026 03:41:47 Asia/Shanghai] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, false given in /etc/inc/filter.inc:3843
      Stack trace:
      #0 /etc/inc/filter.inc(3843): fwrite(false, 'service 19000-t...')
      #1 /etc/inc/filter.inc(938): filter_nat_rules_generate()
      #2 /etc/rc.filter_configure_sync(32): filter_configure_sync()
      #3 {main}
      thrown in /etc/inc/filter.inc on line 3843

      patient0P 1 Reply Last reply Reply Quote 0
      • patient0P Offline
        patient0 @yon 0
        last edited by

        @yon-0 did that happen by any chance when you use AmneziaWG?

        yon 0Y 1 Reply Last reply Reply Quote 0
        • yon 0Y Offline
          yon 0 @patient0
          last edited by

          @patient0 After installing AWG and running it for a while, the system automatically restarted without any warning. Then the system reverted to the old version 23.06.0. My system configuration data was also lost and restored to a configuration from a long time ago. Since my Plus subscription expired, I can no longer use the Plus version. I'm currently using CE 2.9, but it's getting a lot of errors, such as OpenVPN failing to start.

          patient0P 1 Reply Last reply Reply Quote 0
          • patient0P Offline
            patient0 @yon 0
            last edited by

            @yon-0 but now on CE 2.9 you are not using AWG anymore? Have you imported the config from Plus or set it up new?

            1 Reply Last reply Reply Quote 0
            • stephenw10S Offline
              stephenw10 Netgate Administrator
              last edited by

              So you were running AmneziaWG on a client behind pfSense 2.9.0 when the above errors happened?

              patient0P yon 0Y 2 Replies Last reply Reply Quote 0
              • patient0P Offline
                patient0 @stephenw10
                last edited by

                @stephenw10 said in Crash report:

                were running AmneziaWG on a client behind pfSense

                No, I assume he/she is using an unofficial pfSense plugin (https://forum.netgate.com/topic/201138/package-amneziawg-for-pfsense-wireguard-obfuscation-that-gets-a-tunnel-past-dpi).

                1 Reply Last reply Reply Quote 0
                • stephenw10S Offline
                  stephenw10 Netgate Administrator
                  last edited by

                  Oh fun*. Hmm, completely untested then!

                  patient0P 1 Reply Last reply Reply Quote 0
                  • patient0P Offline
                    patient0 @stephenw10
                    last edited by

                    @stephenw10 said in Crash report:

                    Hmm, completely untested then!

                    Yep, the fun of unofficial and probably AI-generated plugins.

                    1 Reply Last reply Reply Quote 0
                    • yon 0Y Offline
                      yon 0 @stephenw10
                      last edited by

                      @stephenw10 Both versions 23.06.1 and 2.9.0 experienced crashes. Today, with version 2.9, all DHCP services disappeared. I had to restart the server by pressing the power button.

                      1 Reply Last reply Reply Quote 0
                      • stephenw10S Offline
                        stephenw10 Netgate Administrator
                        last edited by

                        Both using the AmneziaWG pkg in pfSense directly?

                        Same errors? Crash report?

                        1 Reply Last reply Reply Quote 0
                        • First post
                          Last post
                        Copyright 2026 Rubicon Communications LLC (Netgate). All rights reserved.
                        Privacy Policy · Cookie Policy