26.07 Upgrade disaster - now this. pfSense-repoc: zuul_license_check: Failed to check the license
-
I have a Qotom 8 Port Intel(R) Core(TM) i3-8130U CPU @ 2.20GHz homelab
It was upgraded to plus years ago, when plus was free.
I was on 26.03.1 happily for 3mths without reboot (with netbird installed and running)
Prior to attempting to upgrade to 26.07, I installed the latest patch on 17.08 which included suricate, system patches, some other.
I tried to upgrade to 26.07 but it failed boot environment verification.
I removed the netbird and it upgraded successfully.System was mega unstable, rebooting frequently, particularly when saving a config change.
Stuck a screen and keyboard on, to discover the system was rebooting in a loop after loading the if_pppoe driver
changed to different boot environment, and slowly each one failed to verify and couldn't go back.I had to use the recovery console and manage to get it back up using an older boot environment.
Now I get the below error and can access any of the packages.
Is this deliberate blocking of non-netgate h/w? If so, surely courteous would be to warn us in advance.pfSense-repoc: zuul_license_check: Failed to check the license (1). pfSense-repoc: server returned error response: 400 Bad Request 10404 pfSense-repoc: zuul_license_fetch: Failed to check the license (1). pfSense-repoc: server returned error response: 400 Bad Request 10404 pfSense-repoc: zuul_repo_fetch: Failed to read the repository data (1). pfSense-repoc: server returned error response: 400 Bad Request 10416 -
@stephenw10
pfSense-repoc-20260827.172430
openssl verify -CAfile /etc/ssl/netgate-ca.pem /tmp/leaf.pem → OK
pkg update still: certificate verify failed on pfsense-plus-pkg01.atx.netgate.com
pfSense-repoc had 400 on zuul_license_checkenv SSL_CERT_FILE=/etc/ssl/netgate-ca.pem pkg update
Updating pfSense-core repository catalogue... pkg: Repository pfSense-core has a wrong packagesite, need to re-create database Certificate verification failed for /C=US/ST=Texas/L=Austin/O=Rubicon Communications, LLC (Netgate)/OU=pfSense Plus/CN=pfsense-plus-pkg00.atx.netgate.com 10B066FB77160000:error:0A000086:SSL routines:tls_post_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-Plus-snapshots-26_07-main/sources/FreeBSD-src-plus-RELENG_26_07/crypto/openssl/ssl/statem/statem_clnt.c:2125: Certificate verification failed for /C=US/ST=Texas/L=Austin/O=Rubicon Communications, LLC (Netgate)/OU=pfSense Plus/CN=pfsense-plus-pkg00.atx.netgate.com -
Send me your NDI in chat and I'll check it.
No idea about netbird though. I've never tried to install it.
Do you have any logs or console output from the reboot loop? Any errors?
-
FYI - It seems they have cut off the free plus subscriptions and reverted them to a paid model. Nice
https://forum.netgate.com/topic/201172/the-2022-limited-time-pfsense-plus-promotion
-
Not to Home or Lab Evaluation devices which yours is.
-
All resolved now. Maybe because my qotom device shows a netgate device id (not sure if that is unique to netgate hardware), but my device probably makes netgate think it is a netgate device, when in fact it is not - just a theory - thanks for the support Steve. They did refund the subscription. You guys, as always are awesome
p.s. the instability with the network interfaces, coincidentally occurred with the upgrade timing. In the end, status changes on the interface were triggering a dying PSU. It eventually carked it completely yesterday.
Privacy Policy · Cookie Policy