System Crash when Enable OPT1

  • Hi..

    I tried to install 2.0 beta version and all looking good. But when I Enable OPT1(PCI Wireless card: D-Link DWA-510). The system hang and crash… It's seem Driver issue. For you reference.!

  • Hi,

    I have the same problem, there is a console error:

    ral0: need multicast update callback
    rt2561fw: could not load firmware image…

    Do you found a solution?

  • I reinstalled and I have attached a screenshot of the error in console

  • Rebel Alliance Developer Netgate

    It may help to type "bt" at that prompt and get a backtrace as well.

  • BTW, is there a way to get the output in a file to send it after a reboot? Or only catch the output via serial? Its maybe off topic, but nice to know… Thanks

  • Rebel Alliance Developer Netgate

    Right now the only way is serial. I don't think anyone has gotten around to adding dumpdev/textdump support to 2.0 yet. I meant to a month or so ago but got sidetracked.

  • OK, now Im back home, resintall pfsense

    built on Thu Dec 31 08:54:26 EST 2009

    Enable Wifi on OPT1, crash again, and here are the screenshots

    I hope this could be useful


  • Rebel Alliance Developer Netgate

    Looks like something broken in the ral driver when interacting with your card/chipset.

    Does this same card work in pfSense 1.2.3?

    Unfortunately there isn't much that pfSense can do about driver issues, as the drivers are a part of FreeBSD.

  • Sounds like the same thing someone reported on the mailing list recently. I don't have any ral cards to try to see what might be triggering that, and report it upstream to get fixed. If someone would like to contribute a card to the cause, email me (cmb at pfsense dot org).

  • I'm sorry but I think  I'm a little far from you, I'm in Chile, so could be to expensive for me to send a card to you.

    I tried now with a Linksys PCI WiFi card, and it works, I set up it in AP mode, but it doesnt work as AP, its visible, I can conect to it, it provides IP via DHCP, but no routing and is not possible to connect to PFsense BOX by this interface, this is the configuration:

    • <opt1><descr>WiFi</descr>
    • <wireless><standard>11g</standard>
        <distance>- <wpa><macaddr_acl><auth_algs>1</auth_algs>
        <wpa_pairwise>CCMP TKIP</wpa_pairwise>


Log in to reply