Alix 2D3 Can't boot pfSense-1.2.3

  • Hi I just took my Alix 2D3 board and a new 8 GB CF card. It comes with the latest firmware v0.99h.

    I'm a mac user and I have one usb card reader connected to my mac.

    I use the command "dd if=pfSense-1.2.3-RELEASE-4g-nanobsd.img of=/dev/disk1 bs=16k"

    to write the image to the card.

    But it doesn't boot

    the output massage after powering up the alix is

    PC Engines ALIX.2 v0.99h
    640 KB Base Memory
    261120 KB Extended Memory

    01F0 Master 044A CF 8GB
    Phys C/H/S 15538/16/63 Log C/H/S 974/255/63 LBA

    and it stops there.

    Any ides ?

    p.s. I tried to download again the image and write it but I have the same problem.

  • Rebel Alliance Developer Netgate

    First, your serial port should be set for 9600. Go into the ALIX BIOS (press 's' during the memory test) and set the speed to 9600 and set your serial client to match. Try to boot again, if it's still not right, then something must be wrong with the CF or how it was written.

    You're sure you decompressed that image first before writing? And you're sure it's disk1?

    Usually the command looks more like:

    gzcat pfSense-1.2.3-RELEASE-4g-nanobsd.img.gz | dd of=/dev/disk3 bs=16k

    It's possible that the CF is defective, but unlikely. If even the first part of the CF was written correctly, you should have gotten the pfSense boot menu with an F1/F2 choice.

Log in to reply