Hard Drive Size Issue? BTX Halted

  • Hi All,

    I am trying to install PF Sense 1.0 on a new computer system.  Everything seems to install correctly from the Live cd but when I boot from the hard drive I get some flashing numbers/letters and the words btx halted.  I have a new160 Gig hard drive in this system.  I tried a new 100 Gig drive as well and got the same results.  I put an old 30 Gig in and installed the software and it worked fine.  Is there some issue with large hard drives?  Is there a work around?  Any suggestions?

    Your help is greatly appreciated.


  • here is hapenning the same, with 1.2-beta-1; my mobo doesnt have the possibilitie of using CHS; it has only LBA=AUTO, LBA=CDROM, LBA=DISABLE, LBA=AMRV; if I configure LBA=DISABLE then lba support is turned off; with AUTO it is ON, but still hapens the same, with some flashing numbers/letters and the words btx halted passing throught the screen; even when I disable "packet mode" this numbers/letters keeps there…

    My mobo vendor doesnt have bios updates in it's site I really dont know what to do... install on a IDE drive should fix this?? :(

    My system is a intel dual Pentium D 3.6
    HD Sata 80G WD
    1G RAM
    dual NIC

    I think I've done everything suggested in the above hoba help... is there something else??



  • 1.2b2 uses grub as its boot loader now, it shouldn't have this problem. Use it, we don't suggest deploying 1.0 on any new installs.

  • how about 1.2-beta1, does it uses grub?? this is what I've installed, I have not tested 1.2-b2 yet!



  • Nope, grub was added to Beta 2, so its recommended that you upgrade, especially given the problems you're having.

  • humm, this is fantastic!

    when I've got this problem, I had to install it anyway; so I picked out the sata drive and installed pfsense in a old 40gb IDE drive. It's running right now; Now maybe I wait some newer version, like beta 3 or some RC to upgrade, but certainlly I will place back up 80g sata drive and install pfsense on it!

    thanks a lot!

  • @cmb:

    1.2b2 uses grub as its boot loader now, it shouldn't have this problem. Use it, we don't suggest deploying 1.0 on any new installs.

    Sorry for the bad news, but at least for me the problem keeps the same; I tried to install 1.2rc2 today, and still have the same error :( (lots of flashing numbers/letters passing on screen)

    Tried to install with grub, did not check the packet mode, but still the same; I'm using an 80 gig sata harddrive; my bios doesnt have the option CHS; it has only LBA=AUTO or LBA=OFF. I tried with the this last, but still the same; then I ask, is there any way to edit ans solve this geometry in grub, before loading kernel??

    I needed to install this pfsense using this sata drive; my ide ones are olders and small

    Thanks a lot


  • hello guys

    I solved this install issue today; I booted the box with any linux livecd and used linux cfdisk or fdisk to take note of the correct harddisk geometry (heads, sectors and cylinders); then booted the rc2 install cd, and entered those information into the pfsense format hd section.

    worked 100%

    ;D ;D

    thanks a lot

  • I would like to sharing my exp.,
    I try to install pfsense (lots of vers) and got this same error messages,
    I try to find it out what's problem.

    I have tested , if a hard drive have installed any os other than freebsd at past,
    such as , not limited to linux , windows , if the hard drive is more than 60G ,
    and try to install pfsense after have installed other os ,
    will got this error after installation and rebooted.

    And I have test to replace a new hard drive on a same machine , same model ,
    the problem does not come .(the word new means , a hard drive just bought from vendor , never used)

    After that , I try to format the old hard drive ( using low level format tools , MHDD)
    and install pfsense again , the error has gone away.

    Just I think , the problem is ,
    pfsense ' s partition tools could not overwrite the hard drive 's boot record of MBR something .

    Since I am not a developer , I am not an expert , so I may be wrong ,
    but my exp. is , after cleaning a hard drive , the problem has gone away.

    Hope this help.

  • I strongly aggree with archy and his approach is approoved for my situation. Furthermore, as Holger Bauer stated in http://www.mail-archive.com/support@pfsense.com/msg03811.html, some bios tuning for disks` auto->lba conversion worked for me fine and then I cleared whole partition table with a Linux liveCD and used grub in pfSense installation, system booted normally. Conclusion :

    If you are having installation problems to disk ;

    1- Check your bios HD settings, change to LBA settings from Auto(or whatever) to LBA
    2- Clear the partition table with using your favorite bootCD (using fdisk or cfdisk or whatever)
    3- Install pfSense from LiveCD boot of pfSense (with option 99)
    4- Use grub as loader

    Thank you all…

  • still having the same problem here, even informing the linux reported hd geometry I got this BTX error; when I try to use grub, it gives me an 18 error message at boot (80gb hd)

    what can I do? I dont know what else to do…


Log in to reply