Vmware-tools Installed correctly?

  • Here is the output I get when verifying installation:

    $ ps ax|grep vmware
      921  ??  S      0:00.11 /usr/local/bin/vmtoolsd -c /usr/local/share/vmware-to
    1150  ??  S      0:00.00 sh -c ps ax|grep vmware
    1152  ??  R      0:00.00 sh -c ps ax|grep vmware

    Here is the suggested results if installed correctly:

    $ ps ax|grep vmware
    1026  ??  Ss    0:20.84 /usr/local/sbin/vmware-guestd –background /var/run/vmware_guestd.pid --halt-command /sbin/shutdown -p now
    19157  ??  SN    0:00.00 sh -c ps ax|grep vmware
    19159  ??  RN    0:00.00 grep vmware (sh)

  • fresh install pfsense and vmtools packages and same problem here

    $ ps ax|grep vmware
    1125  ??  I      0:02.05 /usr/local/bin/vmtoolsd -c /usr/local/share/vmware-to
    5856  ??  S      0:00.01 sh -c ps ax|grep vmware
    5858  ??  R      0:00.00 sh -c ps ax|grep vmware

    in the system logs is nothing about guestd

    shutdown in background is not working

    is broken the package?

  • Yes, I think its correctly installed. The suggested line is from an older version of pfsense/vmware tools (i think).

    When you boot pfSense, keep an eye on the boot-post. Right before the boot process is done and the "idle screen" will appear there should be a bolded  output like "wmvare memory tools successfully loaded" or something like that. Ill post a screenshot tomorrow.


  • Ok, I solved this, at least for myself.  I am running pfsense 1.2.3 on vmware ESXi 4.0u1.

    First, verify vmtoolsd is running, as described in the Open VM Tools Package home page
    Notice:  it says to look for vmware-guestd, which was probably true in old versions, but nowadays, look for vmtoolsd.  I can't seem to login to edit the OpenVMTools Package wiki and correct that…  Hopefully someone else can correct that page soon.

    Second, verify the scripts run at boot time, as described with a nice screen capture photo by w00t

    Third, you notice it still doesn't work.  This where I step in.  I noticed the vmtoolsd daemon was running with this command:
    /usr/local/bin/vmtoolsd -c /usr/local/share/vmware-tools/tools.conf -p /usr/local/lib/open-vm-tools/plugins/vmsvc

    I noticed the config file doesn't exist.  This was suspicious, but apparently not a problem.  I googled around and found how to create the config file, enable debug logging.  I found that when I click the "Shut down guest" button in VMWare, in fact vmtoolsd was receiving the signal, but then the system was failing to shutdown.  I found the default shutdown script /usr/local/share/vmware-tools/poweroff-vm-default and ran it.  Sure enough, it bombed out with some error message.  Instead of fixing it, I decided to replace it.

    Some day, somebody might come along and do this a little more pretty than what I did.  Like for example, figure out how to override the default shutdown script by using the config file.  But below is what I did, and it works.

    ssh into the pfsense box as root.

    cp -p /etc/rc.initial.halt /etc/rc.initial.halt.unconditional
            edit /etc/rc.initial.halt.unconditional
              Change this line:
                (line #48)        if (strcasecmp(chop(fgets($fp)), "y") == 0) {
              To this:
                (line #48)        if (1) {
            mv /usr/local/share/vmware-tools/poweroff-vm-default /usr/local/share/vmware-tools/poweroff-vm-default.orig
            ln -s /etc/rc.initial.halt.unconditional /usr/local/share/vmware-tools/poweroff-vm-default

    Now when I click "Shut Down Guest" in ESXi, the pfsense guest actually shuts down gracefully.

  • Wow, I decided to try installing this on a fresh 2.0 VM.  Same puzzling stuff you ran into.  Glad I checked here first.  Kinda surprised the package is marked as "stable" when the instructions in the help section are stale, and the package does not work at all :(

  • Rebel Alliance Developer Netgate

    I'm not sure if anyone else is having issues yet but I just installed it on a VMware VM and it installed without error, and loaded all of the kernel modules, and appears to be functioning.

    EDIT: And I presume that VMware picked it up right because the VM menu now shows "Reinstall VMware Tools" instead of "Install VMware Tools".

  • Is there any possible 32 vs 64 bit difference?  I think I tried the 64-bit…

  • Rebel Alliance Developer Netgate

    There could be, though I can't test 64-bit as easily, only my laptop supports 64-bit VMware VMs, my CPU on this box doesn't have VT and my larger box is running FreeBSD so I can only use VirtualBox.

    So if someone has some errors on 64-bit it would be nice to know exactly what they are right now.

  • Rebel Alliance Developer Netgate

    I just tried it on a 64-bit VM and it worked just as well.*

    • I cheated and committed some fixes to the 64-bit open-vm-tools package xml first. :-)

  • Well that is odd.  I just config'ed a 32-bit vmware appliance and installed the tools.  Voila, they are running.  Hmmm.  Well, I'm only going to be giving the VM 1GB or so, so 64-bit is not necessary…