Help with SquidGuard

  • Hi,

    I'm having an issue with a SquidGuard configuration. After installation, I was configuring the blacklist area, with the When I click save, I got the following message:

    "Warning: file_get_contents(/usr/local/etc/squidGuard/blacklist.files): failed to open stream: No such file or directory in /usr/local/pkg/ on line 585 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/pkg/ in /usr/local/www/pkg_edit.php on line 35"

    I also realized that the blacklist was not downloaded, and the Upload Url button has gone…

    I'm using pfsense 1.2.3-RELEASE  and squidGuard 1.3_1 pkg v.1.9.

    How should I proceed to correct this error and download the blacklist?


  • I have it working, granted on the beta 5 version, but I will list what I did.

    I used the wiki as a reference, though a bit dated information.

    On the Services > Proxy Filter > General Settings
    page, I went to the bottom and entered the url-addy under "Blacklist URL", clicked Save. (Is this where you got your error?)
    Then I went to the Black List tab, and clicked Download.

    I never saw an upload option the entire time, so maybe that was a fluke?

    Have you tried uninstalling and re-installing the package?

  • I have the same problem, new install of pfsense 1.23 and squidguard gives me the same error, also bandwithd gives me an error aswell 2 x fresh installs.  Yet these both work perfectly on my old pfsense box.

  • Enter from console

    touch /usr/local/etc/squidGuard/blacklist.files

Log in to reply