VLAN configuration problem (solved)

  • Hi,

    we just want to start with vlan on our pfSense 2.0-RC1. Our LAN interface is laag0 (two interfaces with LACP). We build a vlan interface (IP:; VLAN: 10) and configured the switch port (HP ProCurve 1800-24G) as a tagged port. The other side of the vlan is a Xen Server with a tagged switch port too. On that Xen Server we installed a VM with a vlan interface (IP:; VLAN: 10).
    If we try to send a ping from our pfSense to the VM it doesn´t work. But if we send the ping from the VM to the pfSense it works fine. After that, pfSense is able to ping the VM too. We think the pfSense has no path to the VM.

    So what could be wrong in our configuration?

    Thanks for your help!

  • Hi Maverick, Normally i don't create a vlan interface thru pfsense. For me it not always work. As long you do your VLAN on your switch properly it should work. Maybe you should try from the minimal first don't do Link Aggregate first, just try vlan port to vlan port with tagged. If it work then the problem is likely on your LA. BTW why you need LA for your LAN? Do you need 2GBPS bandwidth ?

    I am begineer too, i just try to help. Sorry if i am wrong.

  • We tried it with a minimal configuration, but the effect is the same. The pfSense didn´t know how to reach the VM in the VLAN. After the VM starts the connection and there is a valid entry in the ARP Table everything works. So do we have to fill the ARP table manually?

  • We found the problem. It is a bug in the Citrix XenServer 5.6FP1 with some network adapters in combination with VALN tagging. :D

Log in to reply