Captive Portal to control time spent on the Internet

  • I have been reading through the forums about this captive portal (lots to read so I apologize in advance if this story sounds familiar) and decided to install it and try to use it as a way to limit the time my little ones spend on the computer. I fired it up today and created a few vouchers. I was able to log in and use the internet but it I sis not see a voucher in use. When I tried to "test" the voucher I used the roll number and it failed. I was also using this roll number as my voucher ID. I then ready this and found that I may be a little confused still. My voucher should look more cryptic like this kiViNq31p7b. From what I read.

    Anyway, Im thinking that I may be misunderstanding all together.

    End Game:

    I have 4 kids (wow thats a big number ;-)) and they use the internet from the same workstation. I also have another work station that they also use at times. So Id like to allow then use form either machine, yet allow them only say 45 min. When the time runs up and other child sits down id like to allow them access via another voucher.

    Is my thought process correct? Does it sound like something the captive portal can assist with? Know if any "dumbed down" instructions / write ups that may help?


  • I wanted to remove the vouchers I created and start from scratch. I cant seem to gain access to edit whats there anymore. I'm sure I'm missing something.

  • @shawngg:

    I cant seem to gain access to edit whats there anymore. I'm sure I'm missing something.

    You can't get past the captive portal authentication page? If that's not the access problem then what is?

    In relation to vouchers, they seem like an ideal solution. Once the voucher is used to login to the captive portal it allows access until it expires at time of first use + voucher time. Note the time specified at voucher creation is an elapsed time, not a connect time.

    Once you generate the vouchers you should download the voucher file (a .csv file) which contains the voucher codes (e.g. PP5mSVBe6dQ). The .csv file can be a database for word processors to print "labels" with the voucher codes. The "labels" can then be handed out to prospective users. I have an OpenOffice file I use to print 8 rows of 4 labels on an A4 sheet. I expect it would be fairly easy to setup something similar in Microsoft Word using its MailMerge function or something similar.

    The voucher .csv file can be downloaded from the pfSense web GUI by going to Services -> Captive Portal, click on the Vouchers tab then click on the blue disk containing a white i. The disk is in the Voucher Rolls section on the right hand side.

    If you are using captive portal you want to make sure you have left yourself a way in to the pfSense web GUI to generate more vouchers. If your captive portal authentication page allowed a username and password (not just a voucher code) then you should be able to login as admin using the "normal" pfSense admin password.

    Have you read the pages linked from

  • I cant seem to get to the first link. not sure if its just me or not.

    Anyway I have the portal working just fine. It allows me to log in and surf the web and even set up the bandwidth restrictions. Im going to explore what you said about the .csv file and see if that will work. I have been working hard to remove those vouchers and start from scratch I seem to have lost my "+" sign to add, the "X" to delete and the "E" to edit.

  • I spoke to soon. I just tok a look and currently the enable voucher option was removed. This is because I wanted to remove the vouchers and replace them. Now when I place in the check mark it tells me that all these fields are required.

    The following input errors were detected:

    The field 'charset' is required.
    The field 'rollbits' is required.
    The field 'ticketbits' is required.
    The field 'checksumbits' is required.
    The field 'publickey' is required.
    The field 'magic' is required.
    The field 'saveinterval' is required.

    I tried to fill them in and I can not type in the these fields.

  • @shawngg:

    I tried to fill them in and I can not type in the these fields.

    If I recall correctly, it is necessary to tick Enable vouchers, then Save, then you can fill in the parameters.

  • after logging into the admin interface I went to services -> captive portal -> Vouchers tab (Portal is already running) check off enable voucher and what you see on my last post is what I get.

    The very first time i turned it on what you explained is just how it worked, in fact the fields were pre populated. All i had to do was click on save.  Now I'm stuck I cant do anything with the vouchers.  I even performed a reboot to see if that would help. no luck

  • Captive portal is enabled?

  • Yes It is. Im being forced to sign in before getting to the internet. I just can seem to remove the vouchers I created. I just want to start from scratch using what I have learned.

  • I'm unwilling to mess with my system to try to get it into the state you seem to have got your system into (whatever that might be). Can you post a screenshot of your Services -> Captive Portal -> Vouchers page?

    In the Voucher public key section, if you click on Generate in Generate new key does a key appear? Same for Voucher private key.

  • Yes. I can click on the generate link. When I do it creates this :

    –---BEGIN PUBLIC KEY-----
    -----END PUBLIC KEY-----

    -----END RSA PRIVATE KEY-----

    How ever they are grayed out and can not be changed. The remaining fields are still not allowing me to edit them. (check is in place at the top)

  • On my system using Captive Portal when Enable Vouchers is ticked the contents of the Voucher key boxes and other boxes are black. If the tick on Enable Vouchers is cleared the contents of those boxes turn grey. If Enable Vouchers is ticked again the contents of those boxes turn black again.

    I can't explain what you are reporting. Any chance you might have modified the pfSense configuration file or any of the .php or .inc files used by the pfSense web GUI, perhaps while looking at them in an editor?

  • I'm not sure. The only thing I did was place a tick on enable vouchers. I was then able to create vouchers and the rest of the data was pre populated. all I have to do was click on save at the bottom. At some point between now and then I lost the ability to edit remove or create vouchers i guess.

    Thanks for your time.

Log in to reply