Hard Drive Install on X-6000

  • WalleyBob,
    I have learned alot from this.  I still got a ways to go with linux.  So far it is working with the x-500.  I make the big change tonight with the x-6000.  That is my primary firewall.  I glad that it was simple.  I guess when you only work with ms products on a day end and out basis translation between O/S's gets difficult.

    Many Many thanks.

    From my experience this write on how to add a hard drive might be good to add in for manual for watchguard one of the users is writing.

    Again thank you.
    Ron Carter

  • Glad you got it working.


    I still got a ways to go with linux.

    To help avoid future unpleasant surprises: pfSense is built on the FreeBSD operating system, which is similar to Linux in many area (for example, it is possible to run quite a number of Linux programs on FreeBSD) but is quite different in other areas (device names, disk partitioning and more)

  • wallabybob,
    I been on vacation but still tinkering.  As far as the HD installation it has been a total bust.  I planning a second attempt next week.  What I found out so far is that you have to have a flash card in the x-6000.  It modifies the boot files and adds the HD as disk 5 in the boot order.

    So I trashed to HD in the process.  I have to format and remove all partitions and clean them up before I can do anything else.

    My last attempt end a complete disaster.  I learned a few tricks and I think I be able to complete my installation.  I keeping notes and should be able to post my results.

  • wallabybob,
    I have finally gotten around to trying to re-install a hard drive in my x-6000.  When PFSense boots it comes up with 1 - PFSENSE, 2 - PFSENSE, 5 - HD

    I select HD and it does not do anything except site there like a lump on a log.  I waited a full five minutes.  Do you have any Ideas what could be causeing this issue.  My we need to get a few active packages running.  My 13 year old got into some contect she she should not have by accident.  I need to install a few packages.

    ANy help would be benefitical.
    Ron Carter

  • Here is what I just completed, I took 2 ide laptop and loaded it with the base 2 pfsense beta 3.  I select disk5 to boot.  It just hanges and never even boots.

    I am have stuck, any thoughts??


  • The standard FreeBSD bootmanager lists the bootable drives and waits a few second for a response then boots the drive last booted if no response. From memory, it looks for a "Fn" key (e.g. F1, F2 etc) rather than a numeric key (1, 2 etc). I wonder if you are booting into the FreeBSD bootmanager.

    From the dmesg output you posted earlier I presume you are installing the embedded version of pfSense. (I didn't see a VGA device in the system startup output.)

    I'm not familiar with the peculiarities of the X-6000. It is not clear me what you have done (what you installed on the CF, what you installed on the hard drive and how you installed them) nor what version you want to run (full or embedded).

    What happens if you hit the F1 key as soon as that output appears? F2 key? F5 key?

  • Going from 2gb to full installation on a 40 hd.  I give the function key a try when I get home.

  • Netgate Administrator

    Sorry to see your still having trouble.  :(
    I only ever tried booting from HD on my X6000 as a test, I never did a full install. However if I remember correctly I had to have a CF card in the slot in order to boot from HD. Some bios bug perhaps.

    One other thing you might try is to load a CF card with a memstick install image, boot from that and then install to the HD from there. That would require serial console access from the memstick image though, I don't know if that's present.


  • I am working on my watchguard.  I have relized that you have to have a flash card in the slot.  Now I have 2 partions on the FC.  The HD is a full base build.  I going from embedded to Full installation.

    Is there a way bypass the auto startup and so that I can specify the volume that I want to boot from??

  • Netgate Administrator

    You mean choose to boot from the CF or the HD?

  • If i select the hard drive it constanly tries to start.

    dev/da0s1a is a USB connected drive (or a SCSI drive).

    But your boot drive is ad2 (a drive connected through an IDE controller) hence the startup should be showing

    Trying to mount root from ufs:/dev/ad2s1a

    When you see the prompt


    usf:/dev/ad2s1a and the boot should proceed. Then you will probably have to login and edit /etc/fstab to change da0 to ad2 on two lines

  • Since I know that the HD was formatted it comes up at da0 but once installed in the x-6000 it shows up as ad2s1a.  I trying to mount the disk so that I can modify the /etc/fstab and correct the name of the HD.  I can't get the mount command correct.

    Here is what I am using:
    mount -rw -t ufs -o /ad2s1a /mnt/tmp/

    With no luck.

  • @fastcon68:

    I can't get the mount command correct.

    Try mount -rw -t ufs -o /dev/ad2s1a /mnt/tmp/ and it it doesn't work report back with the mount command the system response.

  • Here you go:
    I had to run a disk check it just finished of the hard drive.
    results: 1
    [2.0-RC3][root@fw1.cartersweb.int]/(35): mount -rw -t ufs -o /dev/ad2s1a/mnt/tm
    [2.0-RC3][root@fw1.cartersweb.int]/(35): /tmp/md1 on /var ( ufs, local )
    [2.0-RC3][root@fw1.cartersweb.int]/(35): mount -rw -t ufs -o /dev/ad2s1a /mnt/tmp/
    usage: mount [-adflpruvw] [-F fstab] [-o options] [-t ufs | external_type]
          mount [-dfpruvw] special | node
          mount [-dfpruvw] [-o options] [-t ufs | external_type] special node

    results: 2
    [2.0-RC3][root@fw1.cartersweb.int]/root(26): cd /
    [2.0-RC3][root@fw1.cartersweb.int]/(27): mount -rw -t ufs -o /dev/ad2s1a/mnt/tmp
    /dev/ufs/pfsense0 on / (ufs, local, noatime, synchronous)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    /dev/ufs/cf on /cf (ufs, local, noatime, synchronous)

    Mount results
    [2.0-RC3][root@fw1.cartersweb.int]/(34): mount
    /dev/ufs/pfsense0 on / (ufs, local, noatime, synchronous)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    /dev/ufs/cf on /cf (ufs, local, noatime, synchronous)
    devfs on /var/dhcpd/dev (devfs, local)

    Any thoughts on a boot option that I can do that?  I really like to get the disk mounted so I could fix it.

  • I think this took care of it.  I was able to modify the fstab in the etc folder.  Once I get a change to reboot,  I need to set eveything back up.

    [2.0-RC3][root@fw1.cartersweb.int]/(44): mount -w -t ufs /dev/ad2s1a /tmp/mnt
    [2.0-RC3][root@fw1.cartersweb.int]/(45): mount
    /dev/ufs/pfsense0 on / (ufs, local, noatime, synchronous)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    /dev/ufs/cf on /cf (ufs, local, noatime, synchronous)
    devfs on /var/dhcpd/dev (devfs, local)
    /dev/ad2s1a on /tmp/mnt (ufs, local)
    [2.0-RC3][root@fw1.cartersweb.int]/(46): cd tmp
    [2.0-RC3][root@fw1.cartersweb.int]/tmp(47): cd mnt
    [2.0-RC3][root@fw1.cartersweb.int]/tmp/mnt(48): ls
    .rnd         boot         dev          lib          root         var
    .snap        cf           etc          libexec      sbin
    COPYRIGHT    conf         home         lost+found   tmp
    bin          conf.default kernels      mnt          usr

    I know this is a little off topic but can anyone recommed a good doc to set up ip 6.  I really want to try the connectivity.  I got a x-500 I am going to setup for my brother.  I like to run ip6 for the vpn/

  • Netgate Administrator

    In order to run IPv6 you need to be following the mainline development branch now that the new IPv6 code has been merged there. See:
    I'm not running IPv6 so I can't really help you. Clearly it's the future though and sooner or later we'll all be using it.
    Just when I though I had a grip on IPv4!  ::)


  • When booting I get the following message:
    1 pfsense
    2 pfsense
    5 Drive 1

    When I select 5 it just sit's there and cycles then I have to hit option 1 or to boot the from the flash card.
    Thoughts anyone?

  • Netgate Administrator

    Have you tried booting with a CF card that's empty?
    Have you selected serial port console in your HD installation? By default a full install won't send anything to the serial console.


  • I have been testing tonight.  no luck with hd.  On the x-6000 it seems to be a issue.

    I am trying to figure out why I am having trying so much trouble ???.  I wish there was a easy answer for this one.

    I tried to take the flash drive out it will not boot.  I wonder what else I can try. Now on the x-500, I got it to boot after changeing the fstab in the etc directory.  with the flash drive on it.

    Now I wish I could just modify the flash drive and have the mapping point to the hard drive.  This would be totally custom, but I know it might have a chance to work.

    Right now I even download a disk image if somebody had a working one.

    Suggestion are avaiable?

  • Netgate Administrator

    Hmm, so you've verified that the HD will boot in the X500?

    How are you viewing the output from the X6000? Just from the serial port?

    Did you try with a blank CF card?


  • I took a flashcard fdisk and removed all partitions from it and it still would not boot from the hard drive.

  • Hello,

    I have the exact same issue, It is happening with three different Toshiba drives that I got.
    I guess there is some problem somewhere with these HD.

    The issue is described more precisely here : http://forum.pfsense.org/index.php/topic,41127.0.html

    This is really weired. Because using another HD from another brand, I don't seem to have this problem.

    Have you finally been able to move on with your install ?
    Keep me updated.


Log in to reply