Installation problems - system freezes on install reboot

  • Hi I am new to pfsense and bsd for that matter (experiance in linux). I am trying to install pfsense(pfSense-2.0-RC3-i386-20110621-1650.iso.gz/pfSense-1.2.3-RELEASE-LiveCD-Installer.iso.gz respectively) on this system:

    Intel D875PBZ
    Intel Pentium 4 3.4GHz
    1G Mushkin RAM
    Maxtor 200g ATA133 HD
    Onboard Intel 1000gb LAN
    D-Link PCI 1000gb LAN Card

    I have tried to install 2.0 RC3 and 1.2.3 with the same results. Seems like it installs correctly then it goes to reboot but when it does the screen goes black and the HD light stays lite up and it sits there (basically frozen). I wanted to make sure nothing was going on so I let it sit for an hour and it was still like this. If I turn the system completely off then back on it gives this:

    F1 FreeBSD

    Boot:    F1


    F1 pfsense

    F2  PXE
    Boot:    F1

    It hangs after this but the system isnt frozen, it just sits there. I can ctrl alt delete and num lock still responds.

    I dont feel the system is defective as I can install ipcop 1.4.20 or 1.9.19 on it and it works fine. I just was looking at pfsense and feel that it is worked on more, has a more active community, and has more options I really want to give it a try.

    If anyone can help me that would be great!

    Thanks for reading.

  • It is some years since I did an install from CD so I could well be a bit rusty concerning some of the details.

    On first activations it might be necessary to type the key "F1" to get the boot loader to proceed. If the F1 key doesn't get results (some further output in less than 10 seconds) then does typing the "ENTER" key get a result? My pfSense system normally pauses for a few seconds after displaying something similar to what you have shown. Typing F1 or ENTER reduces the waiting time but isn't necessary because it automatically proceeds after a short timeout.

    There is a pfSense embedded version. (Don't know if that can be installed from CD.) This version doesn't have a video driver so startup output switches to serial port very early in the process. If you have this version you should still be able to configure within 5 minutes of booting by connecting another computer to the pfSense LAN network interface, configuring that computer to have an IP address in the subnet (but not, pointing a web browser to and logging in with username admin and password pfsense.

  • Any combination of enter or hitting F1 it gives a _ then a second later goes to / and never advances. Thats with either build. I did notice the embedded version as an option so if you think that might work I will give that a go to see if it works.

    I noticed you mentioned you dont use the cd install. Is it better to go get a cheap thumbdrive and install it that way?

  • I mentioned the embedded version only as a possible explanation for what you were seeing. PERHAPS you were booting the embedded version and you weren't seeing more on the console because the startup output was going over the serial port.

    I haven't done a CD install for years because I use the firmware upgrade over the net. I download the new firmware version to my netbook, verify the md5sum, then upload it to my pfSense and install.

    There have been lots of reports of people having trouble with first installs. Suggestion: In your BIOS make sure the disk controller is not in RAID mode or AHCI mode or SATA mode or advanced or … Go for LEGACY IDE (or as close to "old fashioned hard drive" as you can. I don't know what options your BIOS offers). Maybe the disk controller mode will make a difference.

  • Netgate Administrator

    It looks like you have a bios that isn't playing nicely with FreeBSD. There are ways around that though.
    The fact that it didn't reboot correctly may mean that acpi is broken so I'd turn that off in the bios. For that matter I'd go through the bios and disable everything you don't need, on board sound, modems firewire etc.
    Then take a look at this:
    There's a good chance that your bios is reporting the disk geometry incorrectly or, as Wallabybob suggested, the disk controller is in the wrong mode.
    Are you on the latest bios version?


  • @wally

    I installed the Single Processor version every time not the embedded.

    This suggestion was perfect, I changed it from Advanced to Legacy IDE and when pfsense finishes installing it reboots the system without a problem. So this was the fix for that. Thanks!


    I went ahead and downloaded and installed the latest BIOS for my board, I was not on the newest. I did as wally suggested and chose Legacy IDE and that fixed the rebooting problem after install.

    Unfortunately upon reboot the system still hangs at exactly the same spot. I noticed you said you think my system has a problem with BSD so I went and got a beta copy of m0n0wall to see if it was the same story with a different FreeBSD distro and it installed fine and is running right now. So I would think that would mean FreeBSD works fine on my system?

    Anything else I could possibly try?

    Again thank you for tkaing the time to read my posts and give me suggestions for trying to get pfsense working.

  • Netgate Administrator

    It's been a while but I believe the current stable version of m0n0wall is based on FreeBSD 6.2 where as pfSense 2.0 is based on FreeBSD 8.1 (1.2.3 was  based on 7.2) so they are different.
    It's a bit tedious just to prove a point but you could try installing FreeBSD 8.1 just to check.

    So it's still hanging at the spinner, / ?
    Did you try the suggestions in the boot wiki page?
    I have seen this problem solved by using a smaller partition.
    Some others have successfully used a different boot loader.
    Personally I would try setting the harddrive values manually in the bios. This problem is probably caused by the bios passing the wrong values to the bootloader.


Log in to reply