CARP Master failed, reinstalled & restored from backup, port forward broke

  • I wasn't really sure where to put this because I've no idea what is actually broken.

    So a couple days ago I had the drive in my CARP master fail.  This was no particular issue since I have a working secondary & a config backup of the master.  This morning I reinstalled 1.2.3, reinstalled the packages I had, and then restored the config backup.  What I found when it came back up was that the port forward I had on port 1433 (restricted to a single IP in a remote data center with the firewall rules) was no longer working.  I rebooted the master and found that the port forward worked when the secondary box was in charge.  As soon as the master came back up, the port forward died again.

    Anyone have any ideas on how to troubleshoot this?  I tried enabling logging on the firewall rule for passing the traffic but nothing was logged.  Is there something that is NOT part of the config backup that I could have possibly changed on the original install that wouldn't have carried over?

    Right now I've got the primary system turned off because I haven't figured out how to keep it online without it taking the carp addresses back.

Log in to reply