Ajuda com portal



  • @veniciopika:

    mas não consigo acessar de dentro da minha rede

    Oras… mas o acesso de dentro da sua rede não passa pelo firewall, correto? Suas estações estão no mesmo segmento de rede do teu servidor, não é mesmo?

    O que provavelmente você está querendo fazer é acessar seu site pelo IP público. Se for isso, esta não é a forma natural/ideal de fazer o acesso. Use um DNS ou o recurso de DNS Forwarder do pfSense para acessar o site pelo domínio/nome da máquina!

    ;)

    Abraços!
    Jack



  • @JackL:

    @veniciopika:

    mas não consigo acessar de dentro da minha rede

    Oras… mas o acesso de dentro da sua rede não passa pelo firewall, correto? Suas estações estão no mesmo segmento de rede do teu servidor, não é mesmo?

    O que provavelmente você está querendo fazer é acessar seu site pelo IP público. Se for isso, esta não é a forma natural/ideal de fazer o acesso. Use um DNS ou o recurso de DNS Forwarder do pfSense para acessar o site pelo domínio/nome da máquina!

    ;)

    Abraços!
    Jack

    em vc teria um tutorial para me enviar, em me tira uma duvida essa nat que eu criei está correta de fora eu conseguirei fazer o acesso ao meu portal usando meu ip publico



  • @veniciopika:

    @JackL:

    @veniciopika:

    mas não consigo acessar de dentro da minha rede

    Oras… mas o acesso de dentro da sua rede não passa pelo firewall, correto? Suas estações estão no mesmo segmento de rede do teu servidor, não é mesmo?

    O que provavelmente você está querendo fazer é acessar seu site pelo IP público. Se for isso, esta não é a forma natural/ideal de fazer o acesso. Use um DNS ou o recurso de DNS Forwarder do pfSense para acessar o site pelo domínio/nome da máquina!

    ;)

    Abraços!
    Jack

    em vc teria um tutorial para me enviar, em me tira uma duvida essa nat que eu criei está correta de fora eu conseguirei fazer o acesso ao meu portal usando meu ip publico

    minha nat está correta



  • Sim, o nat está ok.

    Quem é o servidor dns da sua rede? o proprio pfsense?



  • @marcelloc:

    Sim, o nat está ok.

    Quem é o servidor dns da sua rede? o proprio pfsense?

    não é meu AD



  • @veniciopika:

    não é meu AD

    Então… sugestivamente, crie uma nova entrada do tipo "A RECORD" (ou nova zona, se for necessário) no DNS Server do seu AD apontando para o respectivo webserver:

    www.meudominio.com.br -> 192.168.50.4

    Assim, tuas estações da LAN vão poder acessar normalmente o teu site! ;-)

    Abraços!
    Jack



  • @JackL:

    @veniciopika:

    não é meu AD

    Então… sugestivamente, crie uma nova entrada do tipo "A RECORD" (ou nova zona, se for necessário) no DNS Server do seu AD apontando para o respectivo webserver:

    www.meudominio.com.br -> 192.168.50.4

    Assim, tuas estações da LAN vão poder acessar normalmente o teu site! ;-)

    Abraços!
    Jack

    quando digito meu ip publico no navegado abre a pagina do pf sense não meu portal como faço?



  • Amigo,

    Crie uma entrada no seu DNS interno apontando para o IP do servidor local (conforme já mencionado logo acima).

    É normal você acessar a página do pfSense quando digita seu IP público… já que ele é quem está respondendo por este IP!



  • De fora acontece isso também?

    Você ja mudou a porta da interface gráfica do pfsense para não dar conflito com seu nat?



  • @marcelloc:

    De fora acontece isso também?

    Você ja mudou a porta da interface gráfica do pfsense para não dar conflito com seu nat?

    como assim não entendi



  • De fora acontece isso também?

    Voce tentou acessar o servidor via internet e via rede local?

    Você ja mudou a porta da interface gráfica do pfsense para não dar conflito com seu nat?

    system -> advanced

    • Protocol(mude para https)

    • TCP port(mude para por exemplo 8443)

    • WebGUI redirect(marque Disable webConfigurator redirect rule)



  • @marcelloc:

    De fora acontece isso também?

    Você ja mudou a porta da interface gráfica do pfsense para não dar conflito com seu nat?

    como assim não entendi,



  • Explica melhor a sua duvida, refiz a minha pergunta no post anterior.



  • @marcelloc:

    Explica melhor a sua duvida, refiz a minha pergunta no post anterior.

    temho um portal que esta no meu servidor ad cujo ip é 192.168.50.4, tenho um firewall isa cujo ip valido é 186.xxx.xxx.x39 e um firewall pf sense 186.xxx.xxx.x40, quando dgito no meu navegador o ip 186.xxx.xxx.x39 funcioa abre meu portal, quando digito 186.xxx.xxx.x40 não funciona com acesso externo, mas dentro da minha rede se eu digito esse ip funciona mas só em maquina que não esta ligada no pf sense.



  • Provavelmente o problema esta no default gateway do seu servidor web, o pacote chega pelo ip 40 e tenta voltar pelo 39.

    Você consegue contornar isso fazendo um outbound nat (source nat) na lan do pfsense.

    firewall -> nat -> outbound
    mude o nat de automático para manual.
    cire uma regra com:

    interface lan
    source any
    destination: ip_servidor web
    translate interface address.

    att,
    Marcello Coutinho



  • @marcelloc:

    Provavelmente o problema esta no default gateway do seu servidor web, o pacote chega pelo ip 40 e tenta voltar pelo 39.

    Você consegue contornar isso fazendo um outbound nat (source nat) na lan do pfsense.

    firewall -> nat -> outbound
    mude o nat de automático para manual.
    cire uma regra com:

    interface lan
    source any
    destination: ip_servidor web
    translate interface address.

    att,
    Marcello Coutinho

    ainda não funcionou



  • Você vai precisar usar o tcpdump para ver onde os pacotes estão parando.

    Na console do pfsense(ou via web gui), capture os pacotes com destino a seu servidor web/load balance/nat.



  • @marcelloc:

    Você vai precisar usar o tcpdump para ver onde os pacotes estão parando.

    Na console do pfsense(ou via web gui), capture os pacotes com destino a seu servidor web/load balance/nat.

    como faço isso?



  • Da uma olhada nos tutoriais aqui do forum, lá explica como fazer isso.

    Uma pesquisa no forum ajuda também.



  • @marcelloc:

    Da uma olhada nos tutoriais aqui do forum, lá explica como fazer isso.

    Uma pesquisa no forum ajuda também.

    ok consegui


Log in to reply