• Good Afternoon

    Ive recently purchased 4 DSL connections from my ISP and need to statically configure the primary IP to my wan connection. Now before everyone says that the ISP will give me the IP needed. This ISP does not do this and I need to Statically assign the IP.

    Is there a way to do this in PFSense or do I need to go with a different router software


  • Just go to Interfaces->WAN, select Type = Static, put in the IP address/mask and add the ISP gateway in the "Gateway" field.
    In System->General Setup, make sure to enter at least one DNS server address, because with static IP on the WAN you won't be handed a DNS server address automatically from the ISP.


  • @phil.davis:

    Just go to Interfaces->WAN, select Type = Static, put in the IP address/mask and add the ISP gateway in the "Gateway" field.
    In System->General Setup, make sure to enter at least one DNS server address, because with static IP on the WAN you won't be handed a DNS server address automatically from the ISP.

    It is not clear to me how these instructions enable PPPoE on the interface. (The title suggests PPPoE is required.)

    Maybe there is a modem involved that talks PPPoE (or similar) to the ISP and standard Ethernet to customer equipment but the original poster doesn't give any hint of that.


  • Apologies, I didn't read the title closely and answered a simple question instead of the OP's question!
    A combination of the info in these 2 posts should work:
    http://forum.pfsense.org/index.php?topic=32601.0 (look at gnhb post with the quote of mpd5 docs)
    http://forum.pfsense.org/index.php/topic,29660.0.html (look at gnhb post at #14)

    This functionality is in /etc/inc/interfaces.inc script in 2.0.n - so it should work;

    a) In the Interfaces GUI, setup PPPoE on your WAN without any IP addresses (because you can't do it in the GUI) and save. This makes a mpd_wan.conf
    b) From the console;

    cp /var/etc/mpd_wan.conf /conf
    c) In the GUI, Diagnostics->Edit File, load /conf/mpd_wan.conf
    d) In the pppoeclient: section, add the line
      set iface addrs !111.112.113.2 !111.112.113.1
    (substituting your local static ip and ISPs IP in order above)
    e) Save the file
    f) Do something to restart the interface - e.g. hit save on Interfaces->WAN or even reboot, the conf will be preserved across reboots.
    g) From the console, you can verify that /var/etc/mpd_wan.conf is now a link (optional):
    ls -l /var/etc/mpd_wan.conf
    lrwxr-xr-x  1 root  wheel  18 Mar 19 16:17 /var/etc/mpd_wan.conf -> /conf/mpd_wan.conf

    The doc for mpd5 is at http://mpd.sourceforge.net/doc5/mpd.html and the "set iface" options are on page http://mpd.sourceforge.net/doc5/mpd28.html#28

    Let us know if this works.


  • phil

    thanks for the reply

    Next question. I have 4 DSL Connections for MLPPP. How do I configure the WAN Iface for MLPPP plus the static IP?


  • I have just tried this and It works, thanks to everyone who contributed.

    I set this up on my BT UK service. I have a business account and have used the supplied username and password they email when you sign up. I think the following is default for domestic installs on BT, homehub@btinternet.com as the username and no password (set to 1234).

    I should add this is a FTTC install and I replaced the BThub3 with my pfsense box