Transparent firewall works perfectly on ESXi 4 and 5



  • Hello,

    I believe it will be interesting that you know I have been able to succesfully run PfSense 2.0 in ESXi 5 in transparent mode (Layer 2 firewall) and it works perfectly and it is completely reliable.
    In order for this setup to work you have to enable promiscuous mode for specific vSwitchs on your VMWARE host.
    ESXi Configuration -> Networking -> vswitch Properties -> vSwitch (Edit) -> Security -> Policy Exception -> Promiscuous mode -> Accept
    This is disabled by default because it generates a more CPU load on the host (it depends on the volume of host networking traffic).
    The other two options on this screen should be in Accept mode also.

    Joaquim
    http://www.opttic.com


Log in to reply