HAVP on 4G NanoBSD

  • Hi guys,

    is there any way to run HAVP on 2G/4G NanoBSD-platform from USB-stick? The installed package runs only till first reboot of pfS. After reboot ClamAV / HAVP won't start anymore…

    I know about limited write cycles on flash devices.


    Greetings from Germany

  • No ideas?

  • I'm having the same issue here.

    We'll they told me that HAVP requires the full installation and not on a embedded platform.

    I tried to make the partition writable but still no success.

    HAVP requires a lot of read and write access to the disk IMO and the nanobsd platform is not the ideal choice.

    I hope this helps.

  • rw cycles in a memory stick is limited, so it is not ideal to run a bunch of packages on top of barebone pfSense, imho.

    The only thing that you can do to make it run is to create a separate slice or zpool to mount /usr/local and other subdirectories onto them. This may work.

  • I know this is an old thread but I though this would be a good topic to bring back from the dead since it is the first result in Google.  Could we use something similar to what is suggested at http://www.zeroshell.org/forum/viewtopic.php?t=1916.  This is the pertinent part:

    Step 0 - Disable your HAVP proxy using the GUI, in the case it is currently enabled.
    Step 1 - (Ignore)
    Step 2 - The following command have to be both executed in the Zeroshell's shell AND added to your pre-boot scripts (through the Zeroshell's GUI):
        > mount -omand,noatime,uid=havp,gid=havp,size=50m -ttmpfs none /Database/var/register/system/havp/tmp
    Step 3 - Re-enable your HAVP proxy using the GUI.

Log in to reply