Bypass on same interface [RESOLVED]



  • Dear folks, I have a problem with a feature that has always worked so far on other PFSense machines for me.
    I'll delve right in:

    PFSense GW: 10.0.0.1/24
    VPN GW: 10.0.0.2/24
    MachineA: 10.0.0.10/24
    MachineB: 172.16.15.1/24

    Now, on the PFSense gateway, I have created a rule on LAN to allow any to any (for now).
    I have also enabled "Bypass traffic on the same interface" on the advanced systems page.

    Now, when MachineB tries to access port 80 on MachineA, the PFSense GW blocks the Syn/Ack packet (because the Syn goes directly from VPN GW to Machine A, but Machine A replies via PFSense GW because it's the default GW).
    In the past, enabling "Bypass traffic on the same interface" has always worked.
    I have also tried to enable sloppy or none state, but it didn't help!

    Please, do you have any idea why this shouldn't work?



  • I apologize, but after4 hours of pulling my hairs out I have double checked page by page with a working configuration.
    Problem was that the VPN GW was defined to sit on the WAN interface, not LAN.
    So obviously it was an egregious mistake on my part, but hard to find.
    Either way, I hope this helps someone else solve a problem in the future!


Locked