• Is the column labeled wcpu under system performance the cpu usage. Because I run d525 and all 4 threads are at 100% and I'm not really sure why this is. I have a 75/35 connection and I don't run any packages I have a vpn set up but I'm not using it while seeing this usage.

  • Netgate Administrator

    You mean in Diagnostics: System Activity: ?
    I can't think where else you would see a 'wcpu' column. If so that is the output of the 'top' command.

    WCPU,  when  displayed, is the weighted  cpu percentage

    I would expect the 4 threads to be mostly idle. If they really are showing 100% used all the time the most common cause of that is having enabled device polling. That is the expected behaviour with device polling.


  • Yes to everything and I checked device polling and it is not enabled as far as I can tell. But all 4 threads are pegged at 100% this is probably why my VPN is so slow when I do try to use it. Any ideas

  • Need more information. Please provide output of pfSense shell command```
    top -S -H -d1

  • I can do that but I just want to check the process. Diagnostics/Command Prompt then enter top -S -H -d1 in the command field. Also when I am on the main page of my router the visual bar graph represeting CPU use says 0-2% but I still get the 100.00% wcpu value for all 4 threads in the system activity under Diagnostics. Thanks for the help. I'm trying not to be such a noob.

  • @suicidegybe:

    Diagnostics/Command Prompt then enter top -S -H -d1 in the command field.

    That should do it. OR you can use the ssh shell command on a Linux/Unix system or the Putty programon Windows to open an interactive shell on your pfSense box, login, select option 8 (Shell)  then type the command.

    Putty is a free download.

  • Netgate Administrator

    Are you sure it's not showing 100% idle?
    The idle process uses up whatever cpu cycles are not being used by anything useful and is shown by 'top -SH' and opn the System Activity page. E.g.:

    [2.0.2-RELEASE][root@pfsense.fire.box]/root(2): top -SH
    last pid: 58916;  load averages:  0.22,  0.08,  0.02    up 2+13:37:03  12:05:18
    101 processes: 2 running, 83 sleeping, 16 waiting
    CPU:  0.0% user,  0.0% nice,  0.0% system,  0.0% interrupt,  100% idle
    Mem: 45M Active, 15M Inact, 66M Wired, 1064K Cache, 59M Buf, 359M Free
       10 root     171 ki31     0K     8K RUN     59.5H 98.00% idle
      262 root      76   20  3408K  1224K kqread   9:36  0.00% check_reload_status
       11 root     -32    -     0K   128K WAIT     8:01  0.00% {swi4: clock}
       11 root     -68    -     0K   128K WAIT     4:15  0.00% {irq18: em0 ath0+}

    A copy of your output will clear this up in seconds.


Log in to reply