VPN pass through Firewall



  • Hi All,

    Hoping someone here can help with the following problem.

    We have two Datacentre locations. In each one there is a draytek vigor 2950 wich is ussed for VPN IPSEC connections.
    IN each location there is also a server running PFSense.

    Location one has version  2.0
    Location two has version 2.0.1
    Both are in transparent mode so the have external adresses. All my devices behind it also have external adresses. As soon as the Tunnels are build up I route traffic based on internal subnets.

    Between the two locations there is a VPN and it is working fine.
    On both locations there is a VPN connection to our office. Now here is the problem:

    Location one works fine. Location two builds up the tunnel without a problem but there is no traffic going over it. As soon as I disabble the pfsense firewall it works fine. I disabled it in the advanced menu. Strange thing is that the PFSense should not filter this traffic going over the VPN tunnel as it is a private range and it has nothing to do with the VPN itself as this is being handled by the Vigor Draytek units
    I have allready tried disabling all the rules so that no traffic is being blocked but than it still doesnt work. I have also tried applying a new rule (first in the rule order) that allows any traffic on any port with any protocol from any ip to any destenation. Also no go.

    I have no idea where to look. I am very sure this is not a problem with the rules. I have compared PFsense with the one in location one and the only difference I see is the version.

    Any help or ideas is greatly appreciated.

    Regards, Gideon



Locked