Squid not working in Transparent mode on pfsense configured in a bridge mode



  • I have recently deployed pfsense 2.0.2 in a transparent firewall/bridge mode. My network configuration is this:

    Modem –----Mikrotik Router---------pfSense (transparent firewall/bridge mode) ----------------switch--------clients

    Without squid proxy, clients can have access to the internet. After installing squid and configuring it in transparent mode so that i will not configure each client browser (we have more than 100 clients), the clients cannot access the internet. But if i configure squid in NON-TRANSPARENT mode i.e. uncheck the Transparent proxy box, the clients will have access to the Internet. If i revert back to transparent mode i.e. check the Transparent proxy box on the pfsense, and leaving the proxy setting of the browsers, then the clients can access the internet. But once i remove the proxy settings on the browser while squid is in transparent mode, the clients will not have access to the internet.

    Http packets did NOT get to the WAN interface of the pfsense when I used pfsense Packet Capture to capture packets going through the WAN interface of the pfsense when squid is configured in transparent mode.

    I have searched for any helpful information to make squid work in transparent mode on pfsense configured as a transparent firewall/bridge but have so far found NO useful information.

    Please any help will be appreciated. I need to get squid working because thats one of the reasons i setup the pfsense box.

    Thank you.


Log in to reply