Patch captive portal

  • Hi Patch captive portal not working in 2.1-RC0.
    have some tip for this issue?

  • Banned

    You mean package instead of patch? You need to describe your issue first. "Not working" is useless.

  • Ops.. sorry.

    Squid 3.1.20 pkg 2.0.6

    Is a patch to block acess to squid port until user authenticate

    PFsesne 3.1RC0 Built On: Wed Jul 17 22:13:42 EDT 2013

  • Banned

    I still do not see what "patch". Plus, again - what is "not working"? What did you do, what was the expected result and what happened instead?

  • See Attach.
    This patch have one propose, dont leave user acess squid port until authenticate. If I say "Not Working" this means "Users can access squid port without authenticate".

  • Banned

    Wonderful. So, you checked the checkbox… Did you re-apply the captive portal config after doing so, as instructed? If you did, what's not working? People are not redirected to the CP? Or something else? Please, be a bit verbose finally! We are not supposed to pray repeatedly for information to provide help! If you don't speak English, kindly post to International Support section.

  • I re-apply captive portal settings again, reboot, pray, cry, reinstall package and nothing change!

    OBS: I use wpad.

  • Banned

    I give up. Please, post in your native language elsewhere (i.e., the International Support subforums). You STILL have not answered the very basic question, despite being asked three times already to give a detail description of the problem…  >:(


  • Hi,

    as I read above, if I not misunderstood, he meaning to user can access direct to the internet with out any authorize form captive portal page, so he did not know what a exactly to proved it. so not working maybe he mean to cative portal. ok let you do as my trick.

    1. turn off squid first
    2. reconfig cative portal as usual and test. is it working normal?, I mean to when you open any website like http://bla bla bla… you will redirect to captive page. that mean to all working fine.
    3. turn off captive portal, then turn squid on, check it is working..?
    4 turn both on again. and test as no2.

    ** I not sure about proxy config on web browser setting, should you check and empty or off it also to make a problem narrow to prove.

    Hope it work.

  • Tnks abiatiya, I will try and come back to update.

    If user set proxy in Browser, he can access internet without autentication. If not set he is redirect to captive portal logon page.

    In Pfsense 2.0.3, "captive portal" patch from squid3 work very well!

Log in to reply