SOLVED - Problem with PFsense and Lync 2013 web meetings



  • Hello,

    I have a wierd problem med PFsense and Lync 2013 web meetings.

    Internally everything works, both when connecting directly to meeting server.

    When connecting throug the firewall on a public IP (1-1 NAT) then I get page cannot be loaded if I enter correct meeting ID, but if I enter a wrong ID then I get a answer from the meeting server that it is a wrong meeting ID.

    The RIGHT meeting (result: No answer, page cannot be loaded)

    https://server.domain/person/meetingid

    Thw WRONG meeting ID (result: Answer, meeting server tell me wrong meeting ID)

    https://server.domain/person/wrongid

    I have tried to disable PFsense scrubbing, but that does not solve the problem.


  • Banned

    Well… not sure what to say, the first link works for me... fires up Lync client, waiting for invitation.



  • Wonder what this mean:

    Server not found

    Firefox can't find the server at lyncpool.eucl.dk.

    Check the address for typing errors such as
        ww.example.com instead of
        www.example.com
      If you are unable to load any pages, check your computer's network
        connection.
      If your computer or network is protected by a firewall or proxy, make sure
        that Firefox is permitted to access the Web.



  • Chrome gives me an even better reply:

    Unable to resolve the server's DNS address.


  • Banned

    Afraid this M$ beep basically only works properly in IE.



  • So - I wonder if everyone from here to Timbuktu (no offence meant to people from Timbuktu) trying to connect may have them blocking us now?



  • OK - Yeah…  Well test away.  I am definitely NOT going to enter any links from random people in a forum on my oh-so-delicate Windows VM.

    No, no way, uh-uh, forget it


  • Banned

    Well, I cannot test too much further, I'm afraid. Would have to nuke the Lync client I'm afraid, so that the thing would run in a browser. Much better taken to Technet forums, I'd say.



  • @doktornotor:

    Well… not sure what to say, the first link works for me... fires up Lync client, waiting for invitation.

    It work when I have a Lync client.

    But if there is no Lync client installed, you should get the web version - and there I get not page load, if it is called through PFsense.



  • @kejianshi:

    Wonder what this mean:

    Server not found
           
              Firefox can't find the server at lyncpool

    Thank you… That part should not been in external dns, so we tracked down a DNS configuration error.

    With that fixed and a little tweak on the Lync RP it now works  :D



  • I'm glad to have accidentally helped.  If I can be of any further accidental assistance le me know.

    (I was clueless why it was failing)  :P