Bandwidthd after upgrade from 2.0.3 to 2.1

  • I just upgraded from 2.0.3 to 2.1 and noticed that when I tried to run bandwidthd I was getting the error "Please start bandwidthd to populate this directory" I tried to un-install and reinstall with no luck. I was browsing the directories looking for the log files and found where the error was located.

    the file link /usr/local/www/bandwidthd
    was pointing to /usr/pbi/bandwidthd-i386/bandwidthd/htdocs

    All the bandwidthd files were located in /usr/local/bandwidthd/htdocs

    So i changed the file link /usr/local/www/bandwidthd to point to the new location

    I was wondering if this will cause problems when i upgrade again?

    Its all working fine now so I'm not worried at the moment.

    Also wanted to inform anyone else that has the problem, how i fixed it.


  • I was having the same error (new 2.1 installation - firefox browser, with IE everything was fine… go figure) see this discussion as well,49165.msg367262.html#msg367262

    Anyway for me the solution was this:

    I noticed that everything was linking to /usr/pbi/bandwidth-amd64/bandwitdth with the exception of /usr/local/bandwidth/etc and /usr/local/bandwidth/htdocs

    so I made softlinks from those to the relatives under /usr/pbi/bandwidth-amd64/bandwidth and now everything works ok.

    /usr/local/bandwidth/bandwidth was already a symlink to /usr/pbi/bandwidth-amd64/bandwidth/bandwidth so I have just completed the set  :D

    mmmh... maybe I was not clear, If anyone wants help just reply to this.