Troubles with squid and https

  • Hi there,

    I've rode many posts on squid and https.. tried many things but didnt solve my problem.. :/

    I've recently installed squid and i can't reach any https websites. I rode that squid3 may be able to do the job for http and https but it seems we can't use it as upstream proxy..

    Any ideas?

    Secure Connection Failed

    An error occurred during a connection to SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

    This is what i get when i actually try to reach https website.. grr

    Thanks for advices! :)

  • Try squid3-dev package.

    Download it, enable ipv6 and fetch missing libs.

    This error looks like a https connections forwarded to a http.

  • Hi Marcelloc,

    Thanks for your answer, should I uninstall the squid package before? Cause I tried squid3-dev and cannot found the upstream option.. :) I'm on the way to try it!


    This error looks like a https connections forwarded to a http.

    Yes that's it! :) You're right! :p

    i tried to add "https_port transparent" in manual config, but it doesn't work.. will try squid3-dev.. :/

  • Wow wow! Breaking my mind  :o!

    FYI I didn't try squid3-dev yet, was doing some tests with actual squid…

    Figure out that I can actually reach make search but can reach gmail or I think my squid is possessed and making fun of me.

Log in to reply