XBox Netflix not working on pfsense firewall



  • this is a firewall at an appartment complex, and it needs to allow for multiple xboxs to use netflix.

    2.0.1-RELEASE (i386)
    built on Mon Dec 12 19:00:03 EST 2011
    FreeBSD 8.1-RELEASE-p6

    on Cox communications, with a modem connected directly to the wan port, nothing else filtering.

    I have tried configuring a lan net to all with all protocols allowed, enabled upnp,  Automatic outbound NAT rule generation, etc.

    What do i need to do to fix this.



  • I had mysterious unexplained failure of netflix last fall without me making any changes. The users were grumpy. I didn't find a solution last fall. Evidently, neither did you.

    Today, I was once again (at user behest) trying to sort out the mysterious oddball "partial load of a movie and then fail" issue and tripped across a bizarre and nonsensical change that seems to fix it - I cleaared the default "Block private networks" setting on the WAN. I can't see why this makes ANY sense (my WAN is not a private address once the cable modem connects) but with that switch set, the site loads, the movies load for a few sconds, and a fail box comes up - with it cleared, the movies load and play.



  • Block private networks has nothing to do with it. When you save and apply changes on WAN (with or without changing anything), it re-initializes your WAN interface. With DHCP, that's kicking off dhclient again and pulling a new IP, or renewing the existing, among other things. If it were anything other than coincidence that saving and applying changes on WAN fixed it, the reason it did is because of the forced WAN renewal or something related to that. The system log may have something telling.



  • The system logs were telling me nothing useful, which is why I'd resorted to poking random things.

    I'll re-verify tomorrow morning, but checking the box => error, unchecking the box => no error, in several tries. That's a whole lot of coin flips lining up if your theory is correct…

    I should note (for any future readers) the at the device I'm specifically messing with is an LG TV, not an Xbox, though the netflix failure has been pretty general. I will update in the morning, I'm not adequately gung ho to put off going to bed right now.