Win2003/pfSense DNS not resolving

  • I have been using pfSense for several years without any issues, I have it running at three different offices connected by ipsec vpn, and up until yesterday everything was running smoothly, uptime of almost 6 months… 
    Yesterday I was troubleshooting a voip phone that did not want to pick up the configuration from the provisioning server at a colo, I installed darkstat to try and figure out what traffic was coming from the phone. A couple of small changes (enable tftp proxy helper), etc and I notice that all my voip phones are down.

    An idea of my setup
    WAN at fixed ip, direct to fiber connection
    LAN1 at computers on port em2
    LAN2 at voip phones on port em0
    LAN3 at wifi devices on port em1

    In trying to troubleshoot just now I tried to restore the configuration to a backup done in November (no major changes since then) and now my computers cannot resolve DNS either. the pfsense box is resolving addresses just fine. Outside access is fine (matter of fact I am accessing the network via ovpn at the moment).

    The windows 2003 domain controller is assigning dhcp and performing dns to the subnet , the pfsense box is performing dhcp for the subnet; DNS forwarder is enabled.

    Please any ideas are welcome!!! Thank you in advance!

    EDIT: Also to note that the settings provided by DHCP servers (Windows AD controller and pfsense) to both computers and phones are showing up correctly, IP, Gateway, mask and DNS are correct, so I am really at a loss as to why I would not have any DNS resolution.

    EDIT2: I just tried pining form the Windows DNS server and that is also not resolving properly.

Log in to reply