• Couple of things, remember that most pcs don't deal with tagged traffic. The port going to Pfsense should be tagged with all your vlans. The port going to your mac should be untagged. Some switches due it with the pvid setting others when you assign a vlan to a port make sure its untagged. Lastly I would remind you to make sure you configure dhcp for that vlan.


  • The VLAN'd port is facing the ISP.  The WAN port has to be tagged on VLAN 2 in order for traffic to pass.

    Outgoing traffic to the ISP also needs to have the .1p tags in order to not get dumped into a low speed queue.

    When I talk about testing with my Mac, I'm putting a VLAN on the Thunderbolt GigE interface and plugging it directly into their ONT.


  • I fixed the VLAN and I'm getting out just fine.  I'm pulling ~400 down to Softlayer in Dallas, but uploads are still stuck at 10.

    What's worse is the TV system is not working. The guide is showing, but that could just be cached.  I get a black screen on every channel I try.

    I set up outbound rules from the WAN interface to 'any' to try to apply the tags as provided in the first post.  Nothing seems to help so far.

    I'm starting to wonder if the original info was deleted simply because it was wrong or incomplete, and not because it's some conspiracy to keep 3rd party routers off the network.


  • Still no joy on the uploads.

    I do have some possible insight into the problem with the TV, though I'm no closer to fixing it.  Atlantisman, let me know if you're a TV subscriber or if you're internet-only.  I won't clutter up the thread with TV service details if I'm the only one using it right now.


  • I am also a TV subscriber, and i did notice that if i put the TV equipment behind a different router other than their own that it would just give me black screens. Even if i did this Fiber jack –-> Their router ---> pfsense ---> tv box.


  • I noticed the TV boxes and the storage box send a UDP IPv6 packet to  ff02::1 approximately once per minute.  This is roughly equivalent to IPv4 multicast on 224.0.0.1?  I'm still really green on IPv6.

    Even though my pfSense install had a permit any <> any rule for IPv6, it was still blocking these multicast messages.  I put in a pass rule using the auto-generate tool in the logs.  That let the traffic out, but no replies were coming in.  It seems there's a lot that needs fixing.  This will really test the patience of my wife  ;D


  • Can you guys tunnel your TV service through a vlan on your network keeping the isp router, but then have it supply a public IP to Pfsense so you can use it as your edge router? I think this will give you control over the internet which is what you want and also allow your TV service to work undisturbed. What service are you guys using that you get 400 Mbps down? That is amazing!


  • 400 is slow.  It's supposed to be a gig both directions ;)  Unfortunately, I think my old Watchguard box will be hardware-limited to ~400.  As long as I can fix the upload speeds and get the TV working, I don't really care.  Even 400 is faster than pretty much anything else I can connect to.

    That's not a bad idea on segregating the ISP router. I'm not yet convinced that it's necessary though.  It looks like the TV devices just need to pass certain kinds of IPv6 traffic which pfSense seems to block by default.

    Later this week I'll see about borrowing some hardware from work so I can set up a Wireshark tap between the ONT and router. Then we'll see exactly what's going over the wire.

    I'm also going to set up one of my Adtran routers to do some testing.  I've got a much better understanding of those, and I've got a much easier interface to mess with the .1p tags.


  • You're getting better results than i am without the .1p settings, max i have seen is 85/10, and i know my pfsense build can support the whole gig.

  • Netgate Administrator

    @Jeff:

    Unfortunately, I think my old Watchguard box will be hardware-limited to ~400.

    Are you still running the 2.8GHz P4? My X6000 passes ~365Mbps but it's running at 1.2GHz. I would expect yours to pass well over 400Mbps.

    Steve


  • @stephenw10:

    Are you still running the 2.8GHz P4?

    Yeah.  I haven't done anything to the CPU.  I stuck more RAM in it because it was sitting in a box doing nothing.  But that's the only performance chance I made.  I had to replace the PSU and every capacitor on the motherboard though.  That was not fun.

    I haven't done any throughput testing on it.  The reduced speeds could be due to the .1p situation.  My outbound requests for data are going into the 'best effort' bin, which has the default effect of slowing down a server's response to me.


  • I haven't had a lot of time to do much testing as of now. I have just been trying to research a way of either doing the .1p settings in pfsense or possibly on a switch level before it gets to my pfsense machine.


  • I've made a bit of progress.  It's not strictly pfSense related, but I'm hoping we can use this to bridge the gap.

    I borrowed an Adtran Netvanta 1335 from work.  It's basically a router with some Layer 3 switching capabilities.  There's 24 10/100 ports and 2 gig ports.

    Right off the bat, this old POS looks to be hardware limited to ~120 Mbit/sec even on the gig ports.  I knew they were running out of gas (which is why we're replacing them at work) but I thought it was a CPU/ # of firewall sessions problem.  I guess it's all of the above.

    Also, I have no IPv6 enabled.  I'm not even sure it's supported on this platform.  No IPv6 = IPTV on this system.

    Anyway, I fixed the upload problem. Once I got basic connectivity established, I was pulling 120 down, and only 10 up.  Which is what Atlantis and I were seeing on pfSense.

    After I got a QoS policy in place, upload improved to match the download rates.  I was getting 120 both ways.   I did verify that the gig ports were auto-negotiating at the correct rate and not accumulating errors.

    So here's what I'm hoping for.  Adtran configs are very similar to Cisco.  It's my hope that some of the more knowledgeable folks will read what I did with this Adtran, and then chime in with how we might be able to implement a similar config on pfSense.

    I'll explain the relevant parts of the config, and I'll upload the entire thing as an attachment.  The only changes I've made is to remove the password hashes.  Everything else is line for line identical to my running config.  Please don't critique it too hard.  It's just something I banged together in a few minutes for testing purposes.

    So, to get this working:

    Create interface VLAN 2, and set it to DHCP.
    *Put interface gigabit-switchport 0/1 into VLAN trunking mode.  Verify that VLAN 2 obtains an IP address and you can ping out.
    *Turn up interface gigabit-switchport 0/2 and let it go on the default VLAN.  Add the necessary policies to allow outbound NAT. Verify access.

    Create access list GF-dhcp
    *Set the ACL to match both TCP and UDP port 67.  Probably only needs UDP.  Whatever.

    Create access list GF-default
    *Set this as a permit IP any <-> any

    Create QoS policy GF-QoS

    • On the first policy term, match against the GF-dhcp ACL
    • When packets match the ACL, set the VLAN priority / 802.1p / CoS bit 2
    • On the second policy term, match against GF-default
    • This is the catch-all rule, which applies VLAN priority / 802.1p / CoS bit 3
    • I wanted to do a ACL and QoS term for IGMP, but I couldn't figure out how to enable that.  Maybe later.

    Apply the QoS policy in the outbound direction on VLAN 2.

    All traffic exiting VLAN 2 towards the internet will have the .1p / CoS bits set, and upload speeds should see a dramatic improvement.

    Anyone want to take a crack at interpreting this into a pfSense config?

    GF-NV1335-noPW.txt


  • I was just able to get it working, but the QoS part is done through my switch (two ports are vlan'd off, one for the fiber jack, and one for pfsense). The switch strips off the QoS then passing the clean packets to pfsense. No TV as of now, as i probably need to upgrade to pfsense 2.1 to get full IPv6 support.

    I have a Zyxel GS1910 switch, and i wasn't sure which bit was for IGMP and which was for DHCP (they all just have a number code on my switch) so i set them all to 3.

    The result is a clean 930 down and 934 up.

    UPDATE

    Upgraded to pfsense 2.1 and set allow all IP6 traffic outbound, still no TV service, i get the guide, On-Demand, and DVR functionality, but no live TV.

    UPDATE 2

    The TV service not functioning does not appear to be caused by the firewall, it could be that the TV equipment somehow pairs to the router so you can't just take the TV box over to a buddies house and get the service from it. You'd think that they'd accomplish this task by only allowing IPs from their subnets on their IPTV servers, but who knows.


  • Have you read up on IGMP at all?  I've seen people in other threads about IPTV systems mentioning that they had to run some kind of IGMP proxy in order to get TV working.    I haven't dug too deep into it myself since my focus until now has been getting the data working correctly.

    I really hope it's possible to get the .1p stuff working in pfSense.  I've got a really nice gig switch, but I'd rather not have it managing both internal and external traffic, mainly from a simplicity standpoint. That was a big part of my reason for buying the Watchguard.


  • I haven't really looked at IGMP, i am going to investigate that more tonight when i have some time.


  • I was able to get my TV service working again, but with a cludge-y work-around. I just added another port on my switch to vlan 2, plugged the network box into that, and plugged the TV into the network box. ISP will give you more than one public IP (I have three from them at the moment, running 2 pfsense machines for fun, and 1 for their network box), so one for pfsense for your data network, and one for the their router and their TV equipment. I am still going to be tinkering around with the TV service though to see if i can get anything to work through pfsense entirely.

    Not exactly ideal, as now i cannot use the android app to control the tv equipment (unless i re-activate wireless on the NB and switch wireless networks whenever i want to, which would be stupid.). At least it's working though.

    I also contacted them to see if using our own routers was against their ToS in anyway, and i was assured it wasn't, just that their support will not assist us in getting this to work.


  • I was just able to get the TV equipment to work through my own router as well. Remember i am still doing the QoS at a switch level though, i am going to tinker around with QoS on pfsense though and see if i can get everything working 100% through pfsense.

    Until then my speedtests are right where they should be at about 930mbps download and 930 mbps upload. The IPTV service is also working completely through pfsense, and the TV app is also working great. Life is good.


  • Cool! If you have PfSense do the QoS aren't you taking clocks away from PfSense that could be used for other things that the switch has custom asics just for that purpose? For knowledge sake I say go for it, and please document how you got everything to work. 930 Mbps is awesome, I'm really jealous right now!


  • That is spectacular.  If the occasion ever arises, I'll buy you a beer or two :)

    Can you post the config details that get the TV going?


  • Yes, i am in the process of prepping a full write up/guide. I will post it in a bit.


  • I have completed the guide. Here it is:

    https://www.dropbox.com/s/zg9ju9373t0fnpu/GoogleFiberRouterGuide.pdf

    Have fun!

  • Netgate Administrator

    Ah, Google fibre. I was wondering what provider was giving you such huge bandwidth. Nice.  :)

    Reading through your guide (which I'll never be able to actually use  :() this part seems potentially confusing:

    Access your pfsense’s machine webgui and navigate to Interfaces -> Assign -> VLANs and add
    VLAN 2 to your WAN interface, as shown below:

    At this point, you should now be able to access the internet, though the upload speed will be limited
    to about 10mbps.

    Presumably at that point you actually have to assign the new interface, em1_VLAN2 in your example, as WAN?

    Steve


  • @stephenw10:

    Ah, Google fibre. I was wondering what provider was giving you such huge bandwidth. Nice.  :)

    Steve

    Yeah, the only remotely bad thing about it was the inability to use whatever router you chose. I assume they give you a router and do this to reduce the volume of technical support calls. Otherwise most of their calls would be regarding slow internet speeds, since most routers wouldn't have the ability to support such high bandwidth.

    em1 is my WAN interface (the interfaced directly plugged into port 2 on the switch mentioned earlier in the guide). You would need to tag that interface with VLAN 2.

  • Netgate Administrator

    Right so after you've added the new VLAN interface, em1_VLAN2, you have to re-assign WAN to use the new interface rather than using em1 directly which would still be sending untagged traffic.
    It's just that reading your document it could easily be interpreted as simply adding the VLAN to em1 is sufficient. Now it's highly unlikely that anyone who didn't understand this would be reading the document in the first place.  ;)

    Steve


  • AH, right, thanks for catching that. i will edit the document to explain that. I have actually determinded that the whole vlan step within pfsense is not needed, as the vlans are being set at the switch level. I will modify the document to reflect it.

    EDIT

    i am having a strange problem with this step though, maybe someone can help me figure it out.

    "To complete your IGMP configuration navigate to Firewall -> Rules -> LAN, edit your default
    allow any rule on your LAN network, scroll down to Advanced Features -> Advanced Options
    and check the first box., It should read, “This allows packets with OP options to pass. Otherwise
    they are blocked by default. This is usually only seen with multicast traffic.” Save the rule and
    apply your firewall settings."

    After activating this, it seems like DHCP goes crazy and does assign IP addresses so new clients (mostly wireless) are not able to connect to the network. This seems to be an intermittent issue, but its extremely annoying.


  • The netgear GS108Tv2 switch came today.  Holy number of settings, Batman.  I can't really be sure if I got them right or not, I was a little bit guessing having never really dug into Layer 2 like this.  I ended up pulling the switch entirely out of the picture, but the pfSense box still wasn't able to pick up an IP address via DHCP when plugged into the OTN.  I might be completely wrong, but I thought that was supposed to work - albeit with severely degraded bandwidth.

    Prior to that, at one point I had things all messed up, and the pfSense WAN picked up an IP address from its LAN - I think that was because I had the VLAN mappings in the switch goofed.  At least it tells me the WAN interface is capable of accepting and processing DHCP traffic, acting as a dhcp client.

    The only things I changed on the pfsense were the settings in the doc, mostly the stuff around the IGMP traffic.  The GFNB was able to talk to the OTN immediately through the same port on the patch panel.  I might try a simpler off-the-shelf netgear router tomorrow, just to see what happens.

    I posted a few screenshots of what the switch configuration looks like based on Atlantisman's document: https://www.dropbox.com/sh/ug31k8t6n9618ni/ligIuMmIiQ/gs108t_screenshots?lst.  There is no way to delete or rename the first three VLANs.  I really don't know what impact VLAN 2 being "Voice VLAN" has.  I can disable "Voice VLAN" in another screen, or try to move it to VLAN 3, but it doesn't change anything as far as I can tell.

    edit: corrected bad syntax. sorry, long day.


  • @rhornsby:

    The netgear GS108Tv2 switch came today.  Holy number of settings, Batman.  I can't really be sure if I got them right or not, I was a little bit guessing having never really dug into Layer 2 like this.  I ended up pulling the switch entirely out of the picture, but the pfSense box still wasn't able to pick up an IP address via DHCP when plugged into the OTN.  I might be completely wrong, but I thought that was supposed to work - albeit with severely degraded bandwidth.

    Prior to that, at one point I had things all messed up, and the pfSense WAN picked up an IP address from its LAN - I think that was because I had the VLAN mappings in the switch goofed.  At least it tells me the WAN interface is capable of accepting and processing DHCP traffic, acting as a dhcp client.

    The only things I changed on the pfsense were the settings in the doc, mostly the stuff around the IGMP traffic.  The GFNB was able to talk to the OTN immediately through the same port on the patch panel.  I might try a simpler off-the-shelf netgear router tomorrow, just to see what happens.

    I posted a few screenshots of what the switch configuration looks like based on Atlantisman's document: https://www.dropbox.com/sh/ug31k8t6n9618ni/ligIuMmIiQ/gs108t_screenshots?lst.  There is no way to delete or rename the first three VLANs.  I really don't know what impact VLAN 2 being "Voice VLAN" has.  I can disable "Voice VLAN" in another screen, or try to move it to VLAN 3, but it doesn't change anything as far as I can tell.

    edit: corrected bad syntax. sorry, long day.

    1. Yes it should work without the QoS settings, just highly reduced bandwidth (mine did, at about 930/10).

    2. Are you plugging anything else into the other ports on the switch? Or just pfsense and the OTN?

    3. Are you running pfsense in a VM or anything like that? If so you'd have to configure vlans on the virtual switch in esxi/hyper-v.

    4. It shouldn't matter that it is labelled voice vlan. Port one and two do need to be on VLAN 2 no matter what though.

    5. Some switches come with two different vlan options (private and normal), make sure you are not configuring a private vlan, otherwise the OTN won't send you packets.

    Those screenshots look right to me, though i am not too familiar with that particular switch.


  • Thanks for the info.

    @Atlantisman:

    1. Yes it should work without the QoS settings, just highly reduced bandwidth (mine did, at about 930/10).

    2. Are you plugging anything else into the other ports on the switch? Or just pfsense and the OTN?

    I tried setting up ports 1 (OTN), 2 (pfSense WAN) on VLAN 2 and the rest on VLAN 1 to isolate them.  No luck.  I also just plugged in the OTN and pfSense to the switch (everything else removed), and wiring my laptop into the pfSense LAN port to monitor the pfSense, no luck there either.

    @Atlantisman:

    3. Are you running pfsense in a VM or anything like that? If so you'd have to configure vlans on the virtual switch in esxi/hyper-v.

    No, it is running on metal.  I'm starting to wonder if having switch port 2 tagged is causing an issue.  I think the pfSense WAN interface MTU is 1492 but I'll have to check.

    Would it be appropriate to set switch port 1 to tagged and port 2 to untagged?  Both members of VLAN 2 as your point #4 states, yes.

    @Atlantisman:

    5. Some switches come with two different vlan options (private and normal), make sure you are not configuring a private vlan, otherwise the OTN won't send you packets.

    I don't see any options like those, but I'll keep looking.


  • @rhornsby:

    Thanks for the info.

    @Atlantisman:

    1. Yes it should work without the QoS settings, just highly reduced bandwidth (mine did, at about 930/10).

    2. Are you plugging anything else into the other ports on the switch? Or just pfsense and the OTN?

    I tried setting up ports 1 (OTN), 2 (pfSense WAN) on VLAN 2 and the rest on VLAN 1 to isolate them.  No luck.  I also just plugged in the OTN and pfSense to the switch (everything else removed), and wiring my laptop into the pfSense LAN port to monitor the pfSense, no luck there either.

    @Atlantisman:

    3. Are you running pfsense in a VM or anything like that? If so you'd have to configure vlans on the virtual switch in esxi/hyper-v.

    No, it is running on metal.  I'm starting to wonder if having switch port 2 tagged is causing an issue.  I think the pfSense WAN interface MTU is 1492 but I'll have to check.

    Would it be appropriate to set switch port 1 to tagged and port 2 to untagged?  Both members of VLAN 2 as your point #4 states, yes.

    @Atlantisman:

    5. Some switches come with two different vlan options (private and normal), make sure you are not configuring a private vlan, otherwise the OTN won't send you packets.

    I don't see any options like those, but I'll keep looking.

    I would setup the switch with a different port (3-8). After the switch is setup unplug everything but the OTN and the pfsense box.

    You may also need to setup vlans in pfsense, though i didn't have to. There is no reason why this wouldn't work.


  • @Atlantisman:

    I would setup the switch with a different port (3-8). After the switch is setup unplug everything but the OTN and the pfsense box.

    You may also need to setup vlans in pfsense, though i didn't have to. There is no reason why this wouldn't work.

    Switch or no switch, nothing except the GFNB so far seems to be able to be plugged into the OTN.  Tried putting the TimeCapsule in DHCP+NAT mode (normally I just have it in bridge mode), WAN port plugged into the OTN and just like the pfsense box, it was unable to obtain a WAN DHCP address.

    From everything I understand, this should be working but unfortunately I'm unable to make any progress until I can sort out why the traffic isn't making it past the OTN unless it sees a GFNB.  (That's probably not the correct description of the relationship.)

    Putting a laptop directly on the OTN and there was network traffic, but no response to DHCP client requests.

    Edit: No luck spoofing the GFNB's MAC address on the laptop, and no luck manually configuring the IPv4 settings (with the spoofed MAC address).

    ![Screen Shot 2014-02-16 at 19.44.09 .png](/public/imported_attachments/1/Screen Shot 2014-02-16 at 19.44.09 .png)
    ![Screen Shot 2014-02-16 at 19.44.09 .png_thumb](/public/imported_attachments/1/Screen Shot 2014-02-16 at 19.44.09 .png_thumb)


  • Score.

    I don't have time tonight to mess with it anymore, but on a hunch, I figured out that I could create a VLAN virtual interface on my macbook.  I gave it VLAN ID 2, plugged it into the OTN and immediately got a reply from the WAN DHCP server.  So my problem is likely an issue where I'm going to have to either figure out what I'm doing wrong with the switch and/or get pfSense to use a virtual interface on VLAN 2 for the WAN side.


  • @rhornsby:

    Score.

    I don't have time tonight to mess with it anymore, but on a hunch, I figured out that I could create a VLAN virtual interface on my macbook.  I gave it VLAN ID 2, plugged it into the OTN and immediately got a reply from the WAN DHCP server.  So my problem is likely an issue where I'm going to have to either figure out what I'm doing wrong with the switch and/or get pfSense to use a virtual interface on VLAN 2 for the WAN side.

    I had an issue where the DHCP on the WAN side would only assign a total of 2-3 Public IP addresses. So you could have the same issue with the DHCP servers holding your reservations, that's why it worked when you plugged the macbook in. So you might try spoofing the macbook's mac address to your pfsense machine and it might work.

    EDIT: Also, i did some reading on that switch and it does have two different types of VLANs, port based (or private), and 802.1Q (the one you need). Be sure you're using the proper VLANs on the switch.


  • @Atlantisman:

    I had an issue where the DHCP on the WAN side would only assign a total of 2-3 Public IP addresses. So you could have the same issue with the DHCP servers holding your reservations, that's why it worked when you plugged the macbook in. So you might try spoofing the macbook's mac address to your pfsense machine and it might work.

    EDIT: Also, i did some reading on that switch and it does have two different types of VLANs, port based (or private), and 802.1Q (the one you need). Be sure you're using the proper VLANs on the switch.

    I finally did get things working partially.  I could get the WAN interface up properly using DHCP as I said before.  I was also able to get DNS queries to return correctly.  However, I was not able to get any other traffic to the internet until I discovered that pfSense has a really strange way of coming up with the routing table:

    Internet:
    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            192.168.2.1        UGS        0    8226  nfe1
    8.8.8.8            00:04:4b:02:4c:92  UHS        0      124  nfe0
    10.16.0.0/16      192.168.2.1        US          0        0  nfe1
    10.30.0.0/16      192.168.2.1        US          0        0  nfe1
    23.255.128.0/19    link#3            U          0      376  nfe0
    23.255.146.22      link#3            UHS        0        0    lo0
    127.0.0.1          link#7            UH          0      32    lo0
    192.119.23.198    00:04:4b:02:4c:92  UHS        0      124  nfe0
    192.168.2.0/24    link#4            U          0      630  nfe1
    192.168.2.1        link#4            UHS        0      752    lo0

    The default route is completely wrong.  I used a route command to fix that and set the ISP gateway properly.  I also used a route command to delete the route to the 8.8.8.8 DNS server (again, no idea where these are coming from).  I'm looking at the pfSense web ui and the Status > Gateways has the correct information (even before I manually fixed the routing table).  Somehow that isn't translating into a correct routing table.  Outside of the adjustments described here, the only configuration change I've made to the routing are the two static routes for the TV.

    Fixing the gateway allowed traffic to the internet (ie I can telnet to an smtp server from the pfsense box).  However, I'm now very suspicious of the rest of the routing table because I still can't get traffic from the LAN to the Internet.  I'm able to write this post because I have an ssh tunnel to the pfSense box from my laptop.  I left the NAT settings alone, but something could be wrong there?

    I'm pretty confident the switch isn't the issue at this point.  I'm accessing the pfSense box over a wireless AP that is plugged into the switch, on the same VLAN (1) as the pfSense LAN interface.  The OTN and the pfSense WAN link are on the same VLAN 2.  It seems like both VLANs are behaving properly.  pfSense seems like the issue but I'm confused as to how it is coming up with some of its configuration so it is unclear where to look.

    Edit: I should clarify - nfe0 is the WAN interface, and nfe1 is the LAN.  The corrected routing table has this entry for the gateway:

    default            23.255.128.1      UGS        0      463  nfe0


  • Just in case it matters and I've messed up the switch config to somehow cause the weird behavior - screenshots of the VLAN configuration in the switch.  Port 1 is the OTN, port 2 is the pfSense WAN; port 7 is the wireless access point, port 8 is the pfSense LAN.

    https://www.dropbox.com/sh/ug31k8t6n9618ni/ligIuMmIiQ/gs108t_screenshots

  • Netgate Administrator

    It looks like you may have fallen into the trap of adding a gateway to the LAN interface which, since it's done after WAN, then becomes the default. You shouldn't have a gateway on LAN at all. A lot of people seem to be doing that recently for some reason.
    The correct place to set the default gateway (and remove any spurious ones) is System: Routing: Gateway:

    Steve


  • @stephenw10:

    It looks like you may have fallen into the trap of adding a gateway to the LAN interface which, since it's done after WAN, then becomes the default. You shouldn't have a gateway on LAN at all. A lot of people seem to be doing that recently for some reason.
    The correct place to set the default gateway (and remove any spurious ones) is System: Routing: Gateway:

    Steve

    I didn't intentionally or explicitly add a gateway to the LAN interface that I can recall.  You're right, it doesn't make sense for the LAN interface to have a gateway.  I saw under System > Routing > Gateway that there is one for the LAN, and one for the WAN.  I thought it was a little odd, but figured it must be the way pfSense is presenting the configuration in the UI.

    The only possible time I can think when I might have done something to cause this LAN GW to end up in the routing table is setting up the LAN DHCP server.  It is possible there was a question during that portion of the initial setup I should have left blank - probably thinking the question was asking what GW should the DHCP clients use.

  • Netgate Administrator

    Like you say it should be blank. If you change the LAN subnet at the initial console setup it asks you questions in order (IP address, subnet mask etc) and one of those is the gateway. It's hard to just return through it when it's explicitly asking you for the gateway.
    The wording there especially could be changed to prevent this.

    https://forum.pfsense.org/index.php/topic,72694.0.html

    If you have entered a gateway on LAN remove it from Interfaces: LAN: and then go to System: Routing: Gateways: and remove it there too making sure the WAN gateway is set as default.

    Steve


  • @stephenw10:

    You shouldn't have a gateway on LAN at all. A lot of people seem to be doing that recently for some reason

    Btw. this happened to me when I set up pfSense from the serial console (on an ALIX board if that matters). I'm absolutely sure that I did not create a gateway, I logged every single step of my setup.

    -flo-


  • @Atlantisman:

    I had an issue where the DHCP on the WAN side would only assign a total of 2-3 Public IP addresses. So you could have the same issue with the DHCP servers holding your reservations, that's why it worked when you plugged the macbook in. So you might try spoofing the macbook's mac address to your pfsense machine and it might work.

    EDIT: Also, i did some reading on that switch and it does have two different types of VLANs, port based (or private), and 802.1Q (the one you need). Be sure you're using the proper VLANs on the switch.

    I finally got it working to the point where I could get everything on the Internet.  Thanks to Stephenw10 for the help on the routing table stuff.

    However, the best speed I'm able to get is 30/10, which tells me I haven't figured out the QoS stuff yet.  I apologize, I know the QoS stuff isn't strictly pfSense, but rather is configured in the switch.  I'm banging my head trying to figure it out.  The manual seems useless but maybe it will make sense to someone else?

    http://www.downloads.netgear.com/files/GS108Tv2/gs108tv2_gs110TP_usermanual.pdf

    There are two ways to configure QoS.  CoS seems to mostly appear to be hardware based QoS internal to the switch.  The DiffServ way seems to be what I need.  I'm digging around in the DiffServ and nothing I try is making any difference.  To make it simple, I'm trying to set everything to priority 3 and then once I figure that out try to handle DHCP, IGMP, and other separately.

    There appear to be three levels of configuration: Class, Policy, and Service.  The class looks like it is the filtering which matches the packet to be handled.  The only setting I have there is VLAN 2.  The service is where you map a policy to an interface.

    https://dl.dropboxusercontent.com/u/36902/gs108t_screenshots/Screen Shot 2014-02-21 at 22.22.43.png
    https://dl.dropboxusercontent.com/u/36902/gs108t_screenshots/Screen Shot 2014-02-21 at 22.23.04.png
    https://dl.dropboxusercontent.com/u/36902/gs108t_screenshots/Screen Shot 2014-02-21 at 22.23.13.png

    It looks like the policy is where the real work happens.  I've tried setting the policy COS to 3, the IP precedence to 3, and the IP DSCP to both cs3 and cs1, not really clear which one of these sets the correct bits.  Nada - same speed test result.  I'm running the test on ethernet through the tv box, but I fully expect from past tests to see something ~ 140/130.

    Sorry if I'm missing something obvious here, but any ideas?