PPPoE connection drops almost instantly

  • Hardware list:
    Alix 2d3
    PFSense 2.1 nanobsd 4g
    Draytek vigor 120 v2

    I've been running PFSense for 12-18 months now without issue. Today I power down my pfsense box in order todo some testing with a friends kit. When i plug my hardware back together, pfsense is now unable to keep a connection on the PPPoE side and drops almost immediately where the activity light will go off on both the pfsense and draytek vigor 120 when pfsense attempts to send PPPoA credentials.
    The connection will stay down for about 10seconds and then come back up which will then fail within 5seconds.

    so far, I’ve replaced network cables and factory reset both boxes. I've also tried moving WAN to vr2 incase one of my ports has failed on the Alix board; no difference.

    I've currently got back online with a netgear DG834, so i am confident the ISP side is working correctly.

    I don’t really know what else todo now - how do i test pfsense/vigor120 further to see where the fault is? I'm seeing only a few kb's transfer before PPPoE connection fails, so while this likely points towards MTU, I’ve let pfsense default to 1500 and also manually setting pfsense to 1492 - neither seem to improve the issue, so i'm now at a loose at what todo next.

    I've also tried a new CF card incase my original one is failing; no difference. my current setup is fresh-from-wizard pfsense 2.1 install; WAN PPPoE has been configured and thats about it.

  • Netgate Administrator

    Try using something else to create the PPPoE connection like a laptop or an other router (the DG834 maybe can do it) connected to the V120.

    The DG834 can probably operate as a PPPoE modem so perhaps try that instead of the V120.

    The V120 has a web interface that can give you some line stats etc but it also has a telnet interface that can tell much more once you've worked out how to use it.  ;)
    My V120 once partially forgot it's firmware. I could only get to parts of the webgui and the graphics were only half there etc. I reflashed it and it's been fine ever since. A user on another forum had a PSU go bad on his V120 and it behaved strangely.

    Try using the Alix as a router behind the DG834 (set it's WAN to DHCP). Does it stay up.


  • Thanks for the sugestions. I'm not sure how i missed it last night, but it appears to be any LAN use on the v120 causing issues.
    Connected to PFsense, I see 10mbit/half-duplex on the ifconfig interface (if get any connection - pfsense seems to be more fussy about link quality)
    Same thing happens when i connect to a laptop; lots of negotiation retries, but it does eventually connect.

    I've tried firmware reinstall on the v120 along with it's factory reset option. More cable changes too. Only thing i havent done is change the PSU. I've raised a call with Draytek to see if there is anything more i can do with it, before RMAing it.

  • Netgate Administrator

    Definitely try an alternate PSU then. Sounds like you've probably found your issue.


  • Figured i'd just update this to say it's resolved.
    New draytek v120 bought and installed - working perfectly again!

    also, I did try another PSU; no fix so definitely the v120 hardware itself.
    Annoyingly, the failed v120 was only 2 weeks out of warranty too :(

  • Netgate Administrator

    Ouch.  :(
    So just for reference the symptoms of the failure were:
    Unable to establish a connection
    Unable to negotiate an ethernet connection to the modem, falling back to 10Mb HD.

    But you were able to connect to it to flash it some how?
    Before powering it down for tests there were no symptoms?


  • Connection to a laptop seemed a bit more stable, but still something like a 1 in 20 chance of auto-neg and the link staying up - it could take 5 minutes or more for it to actually get a connection.
    PFsense just didnt want to stay connected; i guess it handles weak links differently than my laptop does.

    I don't remember anything obviously wrong with the v120 before it went pop. worked fine before flicking the switch, and then problems when powering it back up.
    touch annoying that it only lasted just over 12 months. hope this one lasts longer!

Log in to reply