Problem restoring image with different NIC arrangements - SOLVED

  • I am hoping someone can help me solve a problem with my new APU-1C system.

    I have been using an ALIX-2D13 for some time with no real issues, except overall performance under heavy load.

    Deciding to upgrade I went with the APU-1C - being virtually identical except able to work from SSD rather than small memory card and perform much better.

    Remembering previous issues I had with serial cable configuration I decided to go with a preconfigured system - from here:

    Started up - connected to LAN port - ran through wizard and had basic system up and working well - perfect!

    After checking to make sure all seemed to work ok I decided to save myself some time by simply restoring the latest backup from the old ALIX2D13 onto the APU-1C.  Same version of pfs (2.1) but full version rather than nanobsd.

    Seemed to load the file ok - final screen showed Interface configuration - clicked ok and waited for restart. I think I may have missed a warning - Interface mismatch on that final screen. This seems most likely to be the problem as I gather the NIC's are in a different order on the APU-1C compared to the 2D13.

    Now I can no longer get access from the LAN - Tried all three NIC's in case one of them was incorrectly configured as LAN - but nothing.

    I guess now I have to start reading up on serial connection and reinstallation? Any other suggestions / ideas would be welcomed - otherwise I will start searching forum for more detailed instructions on setting up using serial cable.


  • Yes, the console will be patiently waiting for you to answer questions about interface assignment.
    I think you are going to need console access whatever you do from here, so get going with that serial cable  ;)

  • Netgate Administrator

    Alternatively you could manually edit the interface assignment in your backed up config file to match the NIC names in the APU before you restore it. I.e. change vr0-2 to re0-2.
    However you should really have a serial console cable anyway.  ;)


  • All done - just needed to change interfaces using serial and now all working well - and MUCH faster than the old Alix.  No actual measurement of speed - but seems much more responsive.

    Only strange thing - 9600 gave garbage, 38400 gave garbage, 115200 worked perfectly - watched all boios boot, then pfs starting, changed interface - loaded into pfs opening menu - all working fine.  Can't understand why 115200 - the backup config loaded from old Alix was 9600.

    Presume (?) that APU-1C must run at 115200 by default?

    In any case this might help someone with similar problem - although I still think it should have been 9600!

    Thanks for suggestions.

Log in to reply