[solved] 2.1.1 -> 2.1.2 Upgrade Issue - stuck at package updates (pfblocker)

  • i have an update issue while upgrading from 2.1.1 to 2.1.2

    the recently upgraded from 2.0.? to 2.1.1 whithout a problem, everything worked fine afterwards. two days ago i updated from 2.1.1 to 2.1.2, the upgrade worked so far (Upload Log) but after the reboot the following screen appears:

    Packages are currently being reinstalled in the background.
    Do not make changes in the GUI until this is complete.

    this screen haven't gone away since then.

    i run it on a cf card on an alix board (NanoBSD Image size 4G)

    the syslog shows the following error:

    Apr 16 12:30:44 	php: rc.update_urltables: /etc/rc.update_urltables: pfBlockerEurope does not need updating.
    Apr 16 12:30:44 	php: rc.update_urltables: /etc/rc.update_urltables: Starting URL table alias updates
    Apr 16 12:30:01 	php: rc.update_urltables: /etc/rc.update_urltables: Sleeping for 43 seconds.
    Apr 16 12:30:01 	php: rc.update_urltables: /etc/rc.update_urltables: Starting up.
    Apr 16 08:08:27 	php: rc.filter_configure_sync: The command '/usr/bin/fetch -T 5 -q -o '/var/db/aliastables/pfBlockerEurope.txt.tmp' ''' returned exit code '1', the output was 'fetch: Not Found'

    looks like this blocks finishing the complete update.

    is it save to reboot? will it help?
    how to uninstall/reinstall the package (not possible, because all the time the info message pops up)?

  • Diagnostics->Backup/Restore, Package Functions at the bottom. Clear the package lock. That will get rid of the "Packages are currently being installed" screen.
    Then you can go to System->Packages. Reinstall pfBlocker, install any other that are missing. If you are having a good day, you should be able to do that without rebooting, but a reboot won't hurt.

  • Is it a good idea to uninstall PFBlocker before upgrading pfsense, and then reinstall it after the upgrade to a newer version of pfsense?

  • The pfBlocker package code should reinstall cleanly automatically after an upgrade, and normally does.
    But note that pfBlocker "disables" itself after being installed/reinstalled/updated. It is "special" in this way (other packages just install and go if there are settings in the config file already). For pfBlocker, you have to go to its settings page and enable/save.

    But there is no harm in uninstalling first, then upgrade, then install again and enable. It just should not be needed.

Log in to reply