Rogers LTE rocket stick (Sierra Wireless U330) pfsense 2.1 release

  • Having problems getting this thing working.. the PFsense list of known working modems has this one listed ( but there isn't anything that indicates what kind of settings to use. Anyway, I created a ppp interface on /dev/cuaU0.0 using the pfsense suggested username/password etc, associated with my opt1 interface as suggested in this article:
    PS, from ssh the device shows: ( choose cuaU0.0 based on the device being 7.2.0)

    ugen7.2: <aircard 330u="" sierra="" wireless,="" incorporated="">at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
    ugen7.2.0: u3g0: <sierra 0="" 2="" wireless,="" incorporated="" aircard="" 330u,="" class="" 0,="" rev="" 2.00="" 0.06,="" addr="">ugen7.2.5: umass1: <sierra 0="" 2="" wireless,="" incorporated="" aircard="" 330u,="" class="" 0,="" rev="" 2.00="" 0.06,="" addr="">but in the status-interfaces  it shows 'up' but 'uptime' never increments. in the system logs-ppp it says:

    'The modem is not responding to "AT" at ModemCMD:Label

    This made me think maybe this device isn't a modem, but an ethernet device, so I started barking up the tree of using usb_modeswitch

    so I installed that and tried running:

    usb_modeswitch usb_modeswitch -v 1199 -p 68a3 -V 01199 -P 068a3 -M "55534243123456780000000000000a11062000000000000100000000000000" -W

    but it bags out with the error:

    Manufacturer: Sierra Wireless, Incorporated
        Product: AirCard 330U
      Serial No.: 359615040968879

    Cant't do driver detection and detaching on this platform.
    Setting up communication with interface 0
    Using endpoint 0x01 for message sending ...
    Trying to send message 1 to endpoint 0x01 ...
    OK, message successfully sent
    Reading the response to message 1 (CSW) ...
    Response reading got error -60
    Device is gone, skipping any further commands
    -> Run lsusb to note any changes. Bye.

    I looked up the 2nd line of the ugen7.2 line, where it shows the type of device (IE umass1) or in this case u3g0, and the results (from google) seem to indicate that this is the 'modem' device, not an ethernet device.. so anyway.. ideas?</sierra></sierra></aircard>

  • Netgate Administrator

    u3g is correctly detecting and switching the device so no need to use usbmodeswith.
    How many serial ports are created? Have you tried all of them?


  • Hi Steve,

    Thanks for replying. I'd have to check again but I believe there was 6 created, 0.0-0.5

    I didn't systematically test all of them, however. I'll work on that now. Access to this firewall is extremely slow at the moment so that will take a while ;)

  • Netgate Administrator

    It is usually 0.0 but worth trying the others. The 320U appears to use 0.3 for example.
    Can we see more of your ppp logs please.


  • Well. Long story short, the rogers guys focked up the initial set up. First off, they put the sim card in backwards, second off, the hardware apparently was defective. When I finally got my hands on it to test I found that it dropped connection every 10 seconds or so and rebooted.

    So I got the hardware replaced, got a static IP assigned to the connection and yes, as you mentioned, it uses U0.3 as the modem interface. After that, everything works like a dream. I set it up on a new pfsense and it worked perfectly within 5 minutes with the right settings.

    FYI, there is no information in pfsense for the static IP settings for rogers.. If anyone is searching for it, or if it needs to be added to a future rom:

    No username
    no password
    Phone number is the same at *99#
    the APN is:


    FYI I was under the gun to get this set up as the site had inadvertently cancelled their internet connection through telus with their phone lines as they had migrated to a voip solution.. and telus refused to reconnect it. ;)

  • Netgate Administrator


    …they put the sim card in backwards...

    Ha.  ::)
    Doesn't make it easier when you're dealing with that level of competence!


Log in to reply