LoadBalance e FailOver (Squid Não Transparente) Ajuda Por Favor



  • @LFCavalcanti:

    Depois crie regras de Firewall em LAN que utilizem a opção de Gateway apontando para esse grupo criado.

    Testado com PFSense 2.1.4 com Squid não transparente, versões 3, 3-Dev e 2.7 STABLE.

    LFCavalcanti, qual regra vc criou na LAN para permitir somente o squid acessar as portas 80 e 443? Se deixar
    TCP LAN net  * * * LOADBALANCE os usuários conseguirão acessar a Internet sem proxy.



  • Bom Dia a todos!

    Pessoal,

    Pesquisei em sites gringos e brasileiros e só vejo possíveis caminhos, dos quais não funcionam! Se houver algum caso que funcione (se eu estiver errado me corrijam) é gambiarrado, pois já consultei especialistas na ferramenta, foruns, materiais etc., e a informação que tenho é que a partir da versão 2.1.x não há nada especifico para que o FailOver funcione adequadamente com o Squid.

    Sinceramente, desisti de tentar fazer funcionar, até que saia algum recurso oficial e funcione. Resolvi tomar um caminho diferente, criei dois grupos de Gateway, no qual funciona como FailOver somente, sendo:

    -Grupo01 | GW1_Default e GW2_Backup
    -Grupo02 | GW2_Default e GW1_Backup

    O GW1 é o link principal, pois é mais estável e veloz;
    O GW2 é o link secundário, possui uma velocidade inferior e cai com certa frequência.

    Então segui o seguinte caminho, a navegação em sites e acesso ao sistema (que é em nuvem), ou seja, acessos que são visíveis aos usuários, deixei saindo pelo Grupo 01. Equanto que serviços como envio e recebimento de e-mail, deixei saindo pelo Grupo 02, pois uma vez que o usuário envia a mensagem, a mesma fica em segundo plano e o usuário não percebe tanto a performance como o abrir de uma pagina.

    Da forma que sigo no momento, me supre tranquilamente, porque distribui a carga e caso um link cai, o outro assumira normalmente.

    Se alguém tive alguma outra solução mais interessante, compartilhe conosco.

    Abraços,



  • Como vai wssilva, gostaria de saber se o failover Grupo01 funciona com o squid, antes eu utilizava Floating Rules e tcp_outgoing_address 127.0.0.1 mas agora não funciona mais com a 2.1.5, sem squid o balanceamento de carga e failover funcionam normalmente. Na sua configuração o squid passa a utilizar o GW2_Backup quando o GW1_Default cai automaticamente? Eu só consegui que funcione mudando o gateway default para o segundo link manualmente em Routing / Gateways.


Log in to reply