Open all ports to lan computers only?



  • Howdy might sound like an odd question here. But is there a way to make all lan computers open so they can talk to each other on any port but not to the internet?

    Can't seem to remote connect to my media server after using pf sense or even connect to all homegroup which was set up.



  • All clients on the same LAN segment should be able to talk to each other automatically.  The firewall only blocks traffic going between different interfaces.  Describe your configuration and the specific problem you're having.



  • @KOM:

    All clients on the same LAN segment should be able to talk to each other automatically.  The firewall only blocks traffic going between different interfaces.  Describe your configuration and the specific problem you're having.

    Hi again KOM and okay thanks for the info again.

    As for the problems im having Homegroups in windows 8 don't work at all. As my network is showing as public? should be home.
    Also Remote control desktop is not connecting.



  • Also sites like 4chan alot of image do not load.

    http://i.imgur.com/Z8m674W.jpg



  • Sounds more like Windows issues than pfSense.  Turn off your Windows firewalls and try again to rule those out.  Turn on Windows Network Discovery.  Can you ping the other systems?  As for 4chan, these are likely unrelated problems.  Are you running a web cache like Squid?  The missing images, what happens when you try to view the image directly through it's URL or try to save it to hard disk?  What I'm saying is, is the image really there or was it taken down by the host or somehow blocked beyond your control?



  • @KOM:

    Sounds more like Windows issues than pfSense.  Turn off your Windows firewalls and try again to rule those out.  Turn on Windows Network Discovery.  Can you ping the other systems?  As for 4chan, these are likely unrelated problems.  Are you running a web cache like Squid?  The missing images, what happens when you try to view the image directly through it's URL or try to save it to hard disk?  What I'm saying is, is the image really there or was it taken down by the host or somehow blocked beyond your control?

    Okay all the windows homegroup worked 110% before I swapped my router for this PFbox all firewalls are already off . Network discovery is on and somehow all set as public with no option to change to Home.

    Image work when opened just "some thumbs" not showing and this is all on the default new install pfsense (no addons yet)

    Not to be funny but everything worked back on my router so has to be pfsense?



  • The problem is the "Public" setting on your Windows boxes. I had that before, you have to play around a little with the networks to make it change to "Privat" again.

    Windows sucks when it comes to (new) networks.



  • @chemlud:

    The problem is the "Public" setting on your Windows boxes. I had that before, you have to play around a little with the networks to make it change to "Privat" again.

    Windows sucks when it comes to (new) networks.

    Hmm from what I've read there no way to change it back to "Home"



  • Okay all the windows homegroup worked 110% before I swapped my router for this PFbox all firewalls are already off .

    None of this was in your original post.  Without you specifically saying so, we don't know if any of your config ever worked before now, and we have to ask questions to determine the history.

    Default pfSense with no packages won't block your web images.  Only a network timeout will do that, or missing source file.

    I have pfSense acting as the firewall for my company, and we're all running Windows on the desktop without any problems going in, out or machine to machine.  Granted, we're in a domain environment and don't fiddle around with homegroups etc, but pfSense has no knowledge of these concepts and doesn't interact other than routing and managing packet traffic based on rules.



  • @KOM:

    Okay all the windows homegroup worked 110% before I swapped my router for this PFbox all firewalls are already off .

    None of this was in your original post.  Without you specifically saying so, we don't know if any of your config ever worked before now, and we have to ask questions to determine the history.

    Default pfSense with no packages won't block your web images.  Only a network timeout will do that, or missing source file.

    I have pfSense acting as the firewall for my company, and we're all running Windows on the desktop without any problems going in, out or machine to machine.  Granted, we're in a domain environment and don't fiddle around with homegroups etc, but pfSense has no knowledge of these concepts and doesn't interact other than routing and managing packet traffic based on rules.

    Sorry didn't mean it to sound like that. Should of added more details my bad.

    I do think it is to do with the network showing as "public" and not "Home"
    as for the images no clue just yet.



  • Check the URL to an image that repeatedly fails to display on your smartphone or other network to confirm if it's a local or global problem.  If you have or had Squid & SquidGuard running then it's possible that some images are being blocked due to filter rules blocking a domain for example.



  • @KOM:

    Check the URL to an image that repeatedly fails to display on your smartphone or other network to confirm if it's a local or global problem.  If you have or had Squid & SquidGuard running then it's possible that some images are being blocked due to filter rules blocking a domain for example.

    Duh sorry I opened the image as in right clicked it and open.
    Chrome reports this

    The server at 2.t.4cdn.org can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.
    Check your Internet connection
    Check any cables and reboot any routers, modems, or other network devices you may be using.
    Check your DNS settings
    Contact your network administrator if you're not sure what this means.
    Try disabling network prediction
    Go to the Chrome menu > Settings > Show advanced settings… and deselect "Predict network actions to improve page load performance." If this does not resolve the issue, we recommend selecting this option again for improved performance.
    Allow Chrome to access the network in your firewall or antivirus settings.
    If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
    If you use a proxy server...
    Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN".
    Error code: ERR_NAME_NOT_RESOLVED



  • @KOM:

    Check the URL to an image that repeatedly fails to display on your smartphone or other network to confirm if it's a local or global problem.  If you have or had Squid & SquidGuard running then it's possible that some images are being blocked due to filter rules blocking a domain for example.

    Hmm that said my dns is opendns (I block porn etc… from my lad) I'll turn all that off to see if this was the problem.



  • Heh, you didn't mention you were using a filtered DNS…

    I can't even resolve that host you listed, 2.t.4cdn.org.



  • @KOM:

    Heh, you didn't mention you were using a filtered DNS…

    Yes sorry forgot about that!
    @KOM:

    I can't even resolve that host you listed, 2.t.4cdn.org.

    http://boards.4chan.org/w/
    Can you see the thumbs on here? (Safe for work btw :)



  • @Wuebit:

    @chemlud:

    The problem is the "Public" setting on your Windows boxes. I had that before, you have to play around a little with the networks to make it change to "Privat" again.

    Windows sucks when it comes to (new) networks.

    Hmm from what I've read there no way to change it back to "Home"

    Nope, no problem, but I have no English version here, so I cannot guide you through the procedure. If you want to access resources on your LAN you have to change "Public" thing. Connect to your old router, delete the network for the pfSense, reconnect to the pfSense and directly after you got an IP from the router change to "Privat"



  • Yes, I can see every thumbnail, or at least there are no missing images tat jump out at me.



  • @chemlud:

    @Wuebit:

    @chemlud:

    The problem is the "Public" setting on your Windows boxes. I had that before, you have to play around a little with the networks to make it change to "Privat" again.

    Windows sucks when it comes to (new) networks.

    Hmm from what I've read there no way to change it back to "Home"

    Nope, no problem, but I have no English version here, so I cannot guide you through the procedure. If you want to access resources on your LAN you have to change "Public" thing. Connect to your old router, delete the network for the pfSense, reconnect to the pfSense and directly after you got an IP from the router change to "Privat"

    I don't have the old router anymore :(

    @KOM:

    Yes, I can see every thumbnail, or at least there are no missing images tat jump out at me.

    Very odd!



  • If you're using filtered DNS, then there is every chance that some (if not all) of these images are remotely hosted, and your filtered DNS is not resolving some of the hosts the images live on.

    Temporarily change your DNS to 8.8.8.8 and then see if those images reappear.


Log in to reply