Upgrade to 2.1.5 bricked my system

  • I work for a small Library, we run PfSense on a Supermicro 5015a appliance.  Runs excellent.  I attempted to invoke the autoupgrade to 2.1.5 last night, it went through the download and the "install" and then never rebooted.  I tried it again, same thing.  After that I figured I would do a reboot.  When it rebooted, it hung on the F1 prompt right before it boots the OS.  Sometimes it would randomly reboot on it's own.  Luckily I had a backup config, and could just reinstall, but wanted to understand what happen.  I took the time during the downtime to upgrade the firmware to 1.2b which is the latest.  I am curious if it just bricked the install, or did I do something wrong?  My system BEFORE reinstalling was:

    Supermicro appliance 5015a
    Intel Atom D525 1.8 Ghz processor
    4 gb DDR3 memory
    32 gb Sandisk Cruizer ultra small height flash drive as storage (sits inside appliance on motherboard usb port)

  • probably just a issue with the build see if a newer build fixes it our just wait for 2.1.6.

    chances are you did nothing wrong and its just the new version

    I may be wrong I just started using Pfsesne so im learning

  • Netgate Administrator

    Are you using a serial console? Are uou running the Nano version?
    Nothing after the bootloader (F1 prompt) is whay happens if the console switches to serial and you are using vga+keyboard.


  • If it's nano: forget about the UPDATE function, that didn't work for me since April, I make new CF cards every time for updating, it's not worth the hassle with the update button…

  • Netgate Administrator

    Worked fine for me once the correct images were in place. Worked fine before that if you specified the correct image at the cli. I haven't tried a nano+vga image personally though which the OP may well be running.


Log in to reply