Snort Missing from Services Menu after Upgrade to pkg v3.1.5

  • I was trying to upgrade to Snort pkg v3.1.3 this morning but it seems i took too long to upgrade to that version and a newer version was released (Snort pkg v3.1.5)

    After upgrading to Snort pkg v3.1.5 i cannot find snort in the services menu (see screen-shot). I have cleared my cache/browsing history/etc and i have tried both Chromium (37) and Firefox (34) and still nothing.

    I can however access snort from an OLD URL:, thats basically the only way i can get to snort at present. Anyone else having this issue?

    Any help appreciated thanks much.
    ![Screenshot from snort-misssing 2014-12-05 09:13:20.png](/public/imported_attachments/1/Screenshot from snort-misssing 2014-12-05 09:13:20.png)
    ![Screenshot from snort-misssing 2014-12-05 09:13:20.png_thumb](/public/imported_attachments/1/Screenshot from snort-misssing 2014-12-05 09:13:20.png_thumb)

  • Moderator

    Did you try to re-install a second time?

  • @BBcan177:

    Did you try to re-install a second time?

    No i haven't tried a reinstall yet.

    OK i will try a reinstall that later when there is less users are online

    Thanks for your input

  • Update:
    Just upgraded to Snort pkg v3.2.1 and that seems to fix my issue, snort is now back under the Services menu

  • see:

    …un-/re-install usually helps... ;-)

  • I think we finally tracked this issue down to some folks leaving the Package Install screen a little too quickly.  It can take Snort a long time to start up if lots of rules are enabled and/or the CPU is not super fast.  You will see a message in the install box that says something like "…package successfully installed..." when the install is actually finished.  Just because you see it say that it starting Snort, that does not mean the install is complete yet.  After Snort starts, control is returned to the pfSense package manager code, and that code does the final steps of the install which includes adding the menu links under SERVICES.  So if you exit the installer screen too early, the PHP process terminates and that final step performed by the package manager code never happens.  This leads to the Snort option missing under the SERVICES menu.