[Solved] Strange vailable memory indication

  • Hi @all

    Have a strange memory on my pfsense box running 2.1.5 RELEASE that the dashboard says that 92% of 104 GByte HDD
    are in use ( see attachment )

    I have read other post regarding this and tried the command```
    du -d 1 / | sort -n -r

    9998261 /
    2831344 /var
    921336 /usr
    86724 /kernels
    33988 /cf
    28852 /client-export
    28140 /boot
    18316 /etc
    14372 /lib
    5888 /sbin
    5356 /home
    3344 /tmp
    1716 /bin
    452 /libexec
    184 /root
    68 /dist
    40 /conf.default
    5 /dev
    4 /tank
    4 /scripts
    4 /rescue
    4 /proc
    4 /mnt
    4 /media
    4 /.snap
    This seems to be OK but why is the indication that different or do I have a serious HDD problem ?
    What could I do to troubleshoot this ?
    Thx in advance
  • Rebel Alliance Developer Netgate

    The attachment was missing. What is the exact error?

    Check the disk usage as mentioned here also:

  • Thx jimp

    I have read this thread and sorry for the missing attachment, it is on now. Problem is that there
    is a big difference in the available free space shown in the dashboard and in the commandline output
    I have posted.

    cheers thafener

  • Rebel Alliance Developer Netgate

    That is what the document I linked explains how to find. The space must be in use somewhere.  Check "df -hi" and "du -h" (don't sort the output)

    It's also possible that the filesystem is corrupt or needs a check.

    If you create an empty file /root/force_fsck and then reboot it will force a disk check during the boot process.

  • Happy New Year to you all

    The out put of df -hi shows this

    Filesystem     Size    Used   Avail Capacity iused ifree %iused  Mounted on
    /dev/ad0s1a    104G     91G    4.8G    95%     38k   14M    0%   /
    devfs          1.0k    1.0k      0B   100%       0     0  100%   /dev
    /dev/md0       3.6M     72k    3.3M     2%      39   727    5%   /var/run
    /dev/md10      488M    6.0k    449M     0%       3   64k    0%   /var/tmp/havpRAM
    devfs          1.0k    1.0k      0B   100%       0     0  100%   /var/dhcpd/dev

    The output of the second command shows nothing extraordinary big, output is too big
    to post here unfortunately.

    So I will do the Filesystem Check during one of the next nights an in case this
    does not work I am going to buy a new HDD.

    By the way I am using a Intel SSD, may this be a Issue ?

    Kind regards


  • Hi jimp

    Thank you very much for your help and the useful hint, the Filesystem Check did the trick.
    The filesystem shows 90% free again.

    Kind regards