APU1D with LTE Huawei ME909u-521

  • Hello Everyone,

    I'm in need of some help.

    I've been using the ALIX2D for a long time, with different setups, all with excellent results.
    Some of the setups have been including 3G internet via usb-modem, also working quite nicely, although not the most elegant of solutions…

    In order to improve on the 3G-usb setup, both optically and antenna-wise,  I've now bought the APU1D, of course including a miniPCIe SSD.
    The PFsense 2.1.5 install went like clockwork (as per usual), but I'm having great trouble getting an internetconnection with the miniPCIe modem, Huawei ME909u-521.

    As far as I can see, every possible hardware-issues should be taken care of, I've mounted the ME909 in the middle miniPCIe port of the ALIX2D, and inserted a SIM into the slot on the backside of the motherboard.
    Antennas have been connected, and there's plenty of LTE signal available where I am.

    There is no problem assigning the ME909 as an interface, eg. OPT2.
    I'm not getting any IP though, even with DHCP activated, and I'm not sure if I'm supposed to...?
    The way I'm used to set the PFsense up (ALIX2D) is though PPP, but there I'm not able to locate the ME909, only the two USB's (cuau0 and cuau1).

    What do I do ?

    Is this a Mission Impossible with the ME909 ? (maybe due to driver issues ?  Haven't been able to find any info on that)

    If so, what other miniPCIe 4G / LTE modem should I go for ?
    I need something that supports upto about 100Mbit DL, and will work with European mobile frequencies (I'm living in Denmark).

    Help please, anyone ?

    Happy New Year to you all !

  • I would stick with a Sierra card as I couldn't get anything else working. MC7700 is my LTE pick. The Novatel's show up as an USB Ethernet device and are unusable and Huweii as well. I was able to get the Option GTM661 half card going but it is only 3G.

  • Hello Phishfry,

    Thanks for your input.

    I was affraid of that  –

    But there's nothing for it, I'll just have to get my hands on a Sierra card instead.

    Thanks again

  • Netgate Administrator

    The two ports you listed, cuau0 and cuau1, are the on-board serial ports. USB connected serial devices appear as: cuaU*.

    Have you used this card with any other OS? How is it supposed to be setup?

    What sort of interface does it appear as?


  • Yea i jumped the gun and assumed it was the same as the Huawei i tested(earlier model). I would suggest you check your interfaces and see if you have an UE0  or similar. If you do you can forget it..Otherwise as steven says start picking different ports to check using prefixes cuaU0.xxx for use and reboot and check PPP log. I seriously doubt it. Check all the cuaU0.0 thru cuaU0.6 or whatever you have. The UGEN on bootup will tell you if it will work.

  • Also i live in North America and know the MC7700 works here(I see you are in Europe). There are different variants for GSM and CDMA so I was just throwing the recommendation out there as a know working modem..Pls check the specs.

    To see if your current modem is supported in pfSense look for something like this on bootup text:

    UGEN 1.3(Huweii Wireless) has found 6 ports

    If so you can try the all the cuaU0.0-cuaU0.6 ports -method. If you see only cuaU0 or cuaU1 and no suffix then it probably is not supported.

    For a while I thought that the Ugen(ie.1.3) numbers had a relationship to the CcuaU0.0 ports ie. cuaU0.3 for ugen1.3 but that was totally wrong. You just need to have a UGEN(modem maker)X.x in  your bootup text and start trying different cuaU0.x ports.

  • Hi guys

    Thanks for all your inputs. Highly appreciated.

    The only place I seem to find "huawei" is here :  ugen3.2: <huawei technology="">at usbus3
    But it doesn't look right, does it ?  No ports

    The card is brand new, newer used it before (on any other setup or OS)
    I didn't know the cuau0 & cuau1 were onboard serialports. Those are the only choice im given within ppp interface configuration :(

    Do I need ppp for 4G ? (I dont know if this works the same was as 3G)
    -  wouldn't I just want to assign the LTE / 4G hard directly as an Interface, eg. OPT2, without ppp ?

    With the Huawei card, im given an option within the Assing Interface,  called eu0 (and a mac address for Huawei) - is that the right way to configure the 4G connection ?

    Do I need to install special drivers for the Huawei ?  How do I go about that ?

    Meanwhile, I've (finally) got my hands on a Sierra card, the MC7710 (which should be the right model for local networks, as far as I can make out, studying the specs.)
    If I understood the situation correctly, I might stand better chances getting the Sierra up and running ?

    Best to you all,
    and a big Thanks for you help so far</huawei>

  • Netgate Administrator

    Is that a typo, do you mean ue0?


  • Hi Steve,

    Yeah, you are right, a typo. :-[
    -sorry about that.

    It should be ue0 (not eu0)


  • Ok well yours is the same as my older Huweii. No interface for 3G/4G connections with "ue0" interfaces. Nowhere to input APN. You can get it working with Ubuntu Network Manager. I did on mine.

    So on to MC7710 -if you did buy one there is two possible modes of firmwares. One for DirectIP mode and QMI mode. Most ship with QMI factory new(Proprietary driver mode(Windows). So you must flash it to directIP mode and then use pfSense-PPP connection- assigned to any interface you choose… If you have trouble finding the firmware leave a note here i will paste link.

    The MC7700 uses cuaU0.4 for setup reference.

    Regarding the MC7710 if it costs a great deal more than the MC7700 i would consider the MC7700. I am using the MC7700 on carrier T-Mobile but they specify the MC7710 for that carrier so it shouldn't work but it does.. What it boils down to is frequencies and bands. For instance here we use 700mhz and B17. Looking at you region it seems maybe 800mhz...

  • Thanks Phishfry,

    With your info, I have the feeling that the goal is not too far away anymore…

    I did get the MC7710, the price wasn't too bad. Bought it on Ebay from a seller in Germany.
    I haven't a clue on how to flash the MC7710 ?  Any help highly appreciated !

    Would I be able to flash the MC7710 by using the Mini PCIe slot in my old Compaq 2510p do you think ?  (its running Ubuntu 14.04 at the present, but if needed, that could be changed. Temporarily.  ;)

    Regarding frequencies :
    As far as I've been able to find out, my ISP uses three different frequencies for LTE / 4G : 800, 1800 and 2600 Mhz
    When it comes to 3G, they use 2100 Mhz and (rarely) 900 Mhz

  • Well the Sierra flasher requires Windows, but since you bought off ebay try it in your APU box first.
    Look for ugen 1.2 found(Sierra Wireless) 6 Ports. Or similar text. If you see similar text you are in DirectIP mode(DIP) and the device is recognized by pfSense. Assign it PPP(cuaU0.4 and you APN settings) and assign to an Interface, reboot and check system/ppp logs.

    If you device seems like its not being found by pfSense then you need to flash it to DIP. Myself being a newbie to Cell data stuff -I used Windows and Sierra Connection Manager to make sure all is good first, and your laptop will work fine for that, but sim slot may be an issue if your laptop is not a WWAN model…There are different Windows drivers for DIP or QMI modes. Different Sierra connection manager as well. So you can tell from there which mode it is in.
    There is actually a "mode switcher" Windows utility from Sierra as well. I usually flash to newest DIP-ROM for maximum compatibility.

    But if pfSense picks up your MC7710 than you really don't need to do this. It just works. Look for a IP in your dashboard to confirm working. Also you may need to use OpenDNS or similar depending on your local carrier. If you have an IP but can't pull up webpages try OpenDNS.

  • I've tried the Sierra-card in the APU1D,
    it gives me  ugen3.2: <sierra wireless,="" incorporated="">at usbus3

    With no ports mentioned at the end of the string, I guess I need to do the DIP flash, right ?

    Theres no new ports available for ppp signing, which I guess makes sense.</sierra>

  • Exactly as you predicted, the Compaq won't startup with the MC7710 inserted, due to the lack of WWLAN capability on this model. Sweet.

    hmm..  I've got an Intel Nuc, which of course also supports mini pcie, but I guess that will probably have the same wwlan issue…

  • Netgate Administrator

    I would expect the NUC to work. Laptops often have whitelists of devices their manufacturers have deemed to be suitable in the bios. No reason for the NUC to have that.


  • Another problem presented itself, there isn't enough physical free space to mount the MC7710 in the NUC… :(

  • Netgate Administrator

    You could get a USB-miniPCIe adapter such as the one referrenced here:


  • I am afraid the Sierra flasher and even the switcher utility require a SIM.  Maybe there is an Ubuntu tool for mode switching. QMI has only recently been integrated in their NetworkConnection Manager.  Just some thoughts…
    That or spring for a Sim adapter for your laptop. I have other threads here with details.
    Ebay guy has these nice ones back in stock, I used these on my Aopen DE5100  MIFI i built for our IT guy..

    You actually break the end off for a half to full slot.Wicked.

  • And steven is correct those USB-mPCI-e adapters will work as i mounted a MC7700 in a custom dongle I made for a usb only rig. You don't need antennas for flashing. Sierra picked it up fine in that device. I didn't flash any cards in it -but the connection manager works well and transparently. At $8 bucks ebay and more durable than $4 dollar sim adapter with 2 sided tape. I made a little box out of nylon and stuck the usb connector out the end. rp-sma for antenna jack. Cheezzy lid. Works.

  • Some more brain candy:

    So The Sierra MC7700 module eeprom has 15 slots for "profiles"

    Factory sealed Sierra Cards have no #1 profile, which once written cannot be removed. The other 14 slots can deleted and rearranged but #1 -once written- is permanent(even after rom upgrade). Is is written from the SIM card on first initialization of the Connection Manager and stores it on the Windows computer as well.. So for Instance you have an ATT SIM put in your new device with Sierra MC77xx module it will write the profile from the ATT SIM to slot #1 and it will always use this as default. So not quite carrier locked as you can use other slots but #1 always take precedence. I have also read that you can have both DIP and QMI profiles. So maybe the Seirra Windows Mode Switcher just sets the other profile active–That is just a guess-.

  • So here is the file for the Sierra MC7700 Mode Switcher Utility.
    search for:

    I am unsure if you can use this without flashing to DIP first.
    That is all i have ever done -Flashed new to DIP then switched back to QMI trying out Ubuntu.
    You may not need to to flash the ROM first to use Mode Switcher. Next new card i will try it.

    On windows I am using these DIP files

    Firmware: SWI9200M_3.5-Release5-SWI9200X_03.05.20.03
    Drivers Build 3795
    Watcher 3830

  • Thanks for all your help so far guys!  Highly appreciated !

    I've ordered a USB2miniPCIe adaptor right away !

    It will probably be some 10-20 days until it arrives (item is located in china, and delivery from that part of the world usually takes a while)

    Once received and the DIP flashing given a shot, I'll get back right away and let you know what happened.

    Have a nice sunday ! :)

  • Hi guys,

    I got my USB-2-miniPCIe adaptor by post today.
    The adaptor seems to work well, the Sierra MC7710 was recognized right away, and after finding the drivers for the MC7710 on a Fujitsu Siemens webpage, I was able to run the Mode Switcher program, and get a positive result on the switch to DIP.

    The adaptor offers room for the SIM aswell, and I had the SIM which I'm planning to use, inserted while switching to DIP. (hopefully this was a wise  thing to do?)

    So far, so good.

    Back in the APU1D, the Sierra MC7710 was now recognized with 6 ports, just like you predicted.
    And, within the PPP settings, I'm now able to choose between cuaU0.0 –> cuaU0.5.

    I've tried every single one of them, followed up with a reboot of the PF sense, but I doesn't seem to get any IP on the PPP assigned port (OPT2).

    I'm really not sure how to proceed from here  - - any suggestions guys ?
    Do I need to flash the MC7710 with new firmware ? ( haven't been able to find any )

    • or do I need to inject some driver or likewise into the PF sense installation ?

    Your help and input is highly appreciated !

    Have a nice weekend

  • No that should do it. You have it all good.

    I can say from here you can take several troubleshooting routes. This website has old information but it is relevant.


    If you have access to the console you can start here. The PPP stuff from command prompt is relevant.

    Do not be distracted by the "ppp.conf" section. PfSense no longer uses that. They now use MPD5.

    So also checkout your PPP log in system logs. Post it if unsure how to interpret.

  • A few things just to doublecheck. Did you use Windows sierra connection manager(Watcher) and make sure all is actually good with your SIM/Antenna/Connection.. Not actually needed but it helped me a great deal. Since you have all the goods -might as well make absolutely sure all good before diving into pfSense.

  • Part of that comes back to my previous post about profiles on the card. Did you buy a "New" card from known dealer? Some ebay cards sold as new have a profile already and card defaults to it. It may not be what you need for your cell network. Sierra Watcher allows you to pick profiles so if your carrier is not in the list make a new profile and connect with it. Something goes on in the background between the Sim and radio and it writes the profile to the card. SIM initialization is the text shown onscreen. Then it is usable on your network. Maybe profile 2 but it will work fine.

    If you fire up Sierra Watcher and it has no default profile it is truly new and you should write the default profile you prefer by connection with the carrier.

    And i would consider upgrading flashing to the latest firmware. I want maximum tower compatibility with my modules.

  • Hi Phishfry

    Thanks for all your help so far.

    I've put the MC7710 back in the adaptor, and installed the Sierra Watcher.
    It seems to work ok, it indicates that there is plenty of signal, and 3G service is detected. It also recognizes my ISP.
    This means the SIM and Antenna is ok, right ?

    When checking under profiles, there doesn't seem to be any (yet).  The card was sold as "new", and this seems to be the truth.

    I haven't put any profiles in yet though - I fear to do so (wrongly), since I've read somewhere that at least Profile 1 once made, can never be changed again.
    Is this true ?

    Is a profile needed for the MC7710 to work with PF sense ?
    Should I use the "Sierra Mode Switcher" to change back from DIP again, before making a profile ? Would it work in the Sierra Watcher if I left the card in DIP mode ?
    If I need to make a profile for the card to work with PF sense, I'm unsure about a few settings within the profile :

    Would it be right to se "Connection Type"  to Autoconnect?
    and  "PDP type" to PPP ?

    I see the profile needs to know the APN, but then shouldn't it know the dialnumber *99#  too then ? or is this controlled by the Pf Sense ?

  • well, I went on and created a profile called "0".

    With the PDP settings "IP" I was able to connect to the internet, via the USB adaptor and Windows7.

    • but the PF sense still refuses.

    I've tried changing the profile setting PDP to "PPP", with the result that neither Windows or PF sense can make connection.

    I've tried every single port out of 6 with both settings, without any luck. It just won't wash.

    The PPP Log comes out with the same result every time; and I guess it makes perfect sense that the connection doesn't work with the modem not responding to AT; but I can't really figure out why it doesn't respond.. ?

    Jan 25 12:38:09 ppp: [opt2_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
    Jan 25 12:38:09 ppp: [opt2_link0] MODEM: chat script failed
    Jan 25 12:38:09 ppp: [opt2_link0] Link: DOWN event
    Jan 25 12:38:09 ppp: [opt2_link0] LCP: Down event
    Jan 25 12:38:09 ppp: [opt2_link0] Link: reconnection attempt 3 in 3 seconds
    Jan 25 12:38:12 ppp: [opt2_link0] Link: reconnection attempt 3
    Jan 25 12:38:25 ppp: [opt2_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
    Jan 25 12:38:25 ppp: [opt2_link0] MODEM: chat script failed
    Jan 25 12:38:25 ppp: [opt2_link0] Link: DOWN event
    Jan 25 12:38:25 ppp: [opt2_link0] LCP: Down event
    Jan 25 12:38:25 ppp: [opt2_link0] Link: reconnection attempt 4 in 3 seconds
    Jan 25 12:38:28 ppp: [opt2_link0] Link: reconnection attempt 4
    Jan 25 12:38:42 ppp: [opt2_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
    Jan 25 12:38:42 ppp: [opt2_link0] MODEM: chat script failed
    Jan 25 12:38:42 ppp: [opt2_link0] Link: DOWN event
    Jan 25 12:38:42 ppp: [opt2_link0] LCP: Down event
    Jan 25 12:38:42 ppp: [opt2_link0] Link: reconnection attempt 5 in 3 seconds
    Jan 25 12:38:45 ppp: [opt2_link0] Link: reconnection attempt 5

    Where did I go wrong ? Might it be I need another firmware ?

    If another firmware might be needed, have you any hints where I might find such ?

    Have a nice sunday !

  • I think I may have found some firmware; at sources@sierrawireless.com

    There seems to be two available versions, the QMI and the DIP.

    MC7710 T-Mobile approved firmware SWI9200X_03.00.11.00 QMI

    MC7710 T-Mobile approved firmware SWI9200X_03.00.11.00 DIP

    Do you think I should try my luck with one of these ?

  • Well if you had it working in Windows i wouldn't worry about firmware for now. Let me digest your log. You are on cuaU0.4 for interface?
    Did you try any of the PPP things on that website from console? If you set it to the correct interface in PPP settings(cuaU0.4) -when you type PPP under shell what does it reply? Be advised PPP under console has Echo Off and you will not see what you type in PPP mode until the proper commands are sent(Echo on). Just pulling up console will tell you more. From your log it is does not look like the hardware is correct.

  • I will pull up my pfSense mifi and post some screen caps under my mifi thread. I have rethought the firmware flash and say flash it with the newest DIP mode(I am slight concerned about using the tmobile version). I am really in pretty deep here as I don't actually own MC7710 but do have MC7700 and MC7750 and they both use same toolset. Plus with us being in different continents!! Maybe out of my league here. I can tell you you are on the right path. Now it may take weeks of trying settings to truly master it…It took me a while to get it going. Short of a hardware incompatibility you are in the back strech. You are certain that the board you are using takes mini-pciE cards of the USB variety?? Aka an 3G/4G slot. With a sim onboard it has to have one. Make sure your in the correct slot for 3G/4G radios.
    Funky hardware issues i have encountered. USB weirdness. Watch your USB device assignment the Ugen. I had one machine that went 4G funky if i plugged the USB keyboard in on bootup. After bootup no problem. So there are some things to ponder as well.

    When in Windows you used the DIP mode drivers and watcher correct? Does your carrier require any login credentials/authentication or is it all handled by the SIM like here for GSM?

  • What worries me is I saw a wise pfMaster saying use a cheap laptop for pfSense and I went and bought any old laptop to build a mifi. A dell mini 10. I found it had 3G option so SIM slot and actual MiniPCIe slot. Plus it has wifi. Anyway i went to put a Sierra radio in it to upgrade the Dell DW5541(ericsson) and it wasn't recognized by Windows. Very odd. Come to find out the slot is miniPCIe but of the pure miniPCIe type with no USB interface. So the slot only works with the newer CDC style ethernet wireless cell modems in Windows (Ericsson,Novatel,Huawei) but no support in pfSense yet.

    Reason i bring that up is you have flashed the module and used it in one machine(good) but we don't know for sure its working in the APU1D. Specs for the board are vague.

    Expansion: 2 miniPCI express (one with SIM socket)

    That don't tell you if it supports both Pure and USB miniPCIe (As my Commell SBC computer does) Or one of each, or neither. You need to find out. It really matters. Sorry if I steered you in the wrong direction.

  • I read the PDF for your APU1D and it has the same spec for miniPCIe slots

    Expansion: 2 miniPCI express (one with SIM socket)

    But i do see that J16 is for 3G modem. That is the middle slot of the three.

  • After looking at some specifications i see that miniPCIe is really a mess
    Here is what wikipedia says.

    The host device supports both PCI Express and USB 2.0 connectivity, and each card may use either standard. Most laptop computers built after 2005 use PCI Express for expansion cards.

    I think that most machines that won't handle either types of mini-PCIe card are mainly notebook computers which are not made to be upgraded or bios whitelisted slots. Dell, IBM and HP come to mind.

    I see a Linux bios on the APU and the fact that its called a "3G" slot leads me to believe a USB variant mPCIe module will work. Most all 3G radios were USB/Serial at heart. With 4G we see Ethernet interfaces prevalent. The MC77xx is the exception.

  • And if you have the 6 ports found on bootup for the Sierra then all is good. Infact if you have PPP interfaces cuaU0.0 thru cuaU0.5 available then all is good. Really down to troubleshooting the software.

    If your comfortable with console this is a good start.

    remember my echo tip

  • I posted some screenshots in the wireless section for you to checkout. Maybe different setup then yours but my PPP log is there to checkout.

  • Quote:
    _With the PDP settings "IP" I was able to connect to the internet, via the USB adaptor and Windows7.

    • but the PF sense still refuses.

    I've tried changing the profile setting PDP to "PPP", with the result that neither Windows or PF sense can make connection._

    I am unsure what that is at all. I am guessing in the Windows Watcher? I don't remember changing anything more than profiles and networks settings and the nice diagnostic dumps. Also I go to Windows Device Manager and "query modem" and check output.

    One line in your PPP log that i am unfamilar with is the "link0" part of the OPT2 interface. Notice mine has nothing like that but [WAN]. Is this an alias or just renamed?

  • Be advised PPP under console has Echo Off

    Sorry. I was wrong about this. It is only when you run TERM under PPP that you need echo off. You get feedback right away from PPP and may not need to dive into TERM. There is a modem script that runs instead of ppp.conf just so you know. It sets the device as well.

  • Another annoying factoid: I don't know for sure yours has a DeviceID that is supported. Like the TechNotation writeup. Use his method and check. Maybe because the MC7710 is not widely in use. Just things to check.

  • So it looks like you may be in this boat. The APU1C had issues with MC7700….


    Although he never gives the Model Number??

    MC7700 I have had Working On pfSense 2.2 beta platforms

    Advantech Ark1388V
    Nexcom VTC6110
    Aopen DE5100
    Commell LS-574
    Habey BIS-6624
    Vyatta 600 aka Lanner FW7535

    I am also worried about APU1D and MC7700 comparability. I am guessing pcEngines don't have a supported 3G/4G module page?

Log in to reply