USB interfaces and altq, axe

  • I know that USB ethernet interfaces are not a preferred solution when using pfSense but I have found that stability is much improved in pfSense 2.2, which is based on FreeBSD 10.1.  I am running the NanoBSD version.

    I am using a cheap Trendnet TU2-ET100 (HW v.4.0R), and it has been perfect under 2.2, and is supported by the axe driver.  The interface is presented as ue0. There is one problem.  While the axe driver supports altq, the ue driver does not.

    I found a useful post on the pfSense mailing list which offers a partial solution:

    By editing /etc/inc/ and adding "ue" to the list of drivers supporting altq, the traffic shaper may be used with my USB NIC.  Unfortunately, this is an ephemeral change that will likely be overwritten when pfSense is upgraded.  If anyone is aware of a way to make this change stick through an upgrade, I would love to know.

    After the edit, the pertinent section will read as follows:

    function is_altq_capable($int) {
    /* Per:

    • Only the following drivers have ALTQ support
      $capable = array("ae", "age", "alc", "ale", "an", "ath", "aue", "axe", "awi", "bce",
      "bfe", "bge", "bridge", "cas", "dc", "de", "ed", "em", "ep", "epair", "et", "fxp", "gem",
      "hme", "hn", "igb", "ipw", "iwi", "ixgbe", "jme", "le", "lem", "msk", "mxge", "my", "nfe",
      "nge", "npe", "nve", "ral", "re", "rl", "rum", "run", "bwn", "sf", "sge", "sis", "sk",
      "ste", "stge", "ti", "txp", "udav", "ural", "vge", "vmx", "vr", "vte", "wi", "xl",
      "ndis", "tun", "ovpns", "ovpnc", "vlan", "pppoe", "pptp", "ng",
      "l2tp", "ppp", "vtnet", "ue");

    Hopefully this post will save other users some aggravation, as the information was not too easy to find.  I have tried to salt this post with enough search terms to lead an interested user to this solution.

  • Thanks for posting this!  It helped me out.

  • Thanks, it did work for me on the 2.3 alpha as well!

  • thanks this worked for me on 2.3.4. I saw on a few other threads that ue (USB interface) devices don't support altq, but I seems to be working fine for me. I've just set this up on one box, and another box has been running queueing on two ue devices for ~1yr.

    Is it just not that reliable? hence the default non-inclusion, or am I missing something?

Log in to reply