[RESOLVIDO] Captive Portal com Proxy Autenticado dando dor de cabeça!



  • Prezados,

    Estou fazendo testes com o Squid3-dev no modo proxy autenticado na porta 3128 e estou puxando autenticação do usuário através do Captive Portal.

    O problema é que no Firefox não configurei o proxy e isto me permitiu acessar a interface do Captive Portal para realizar a autenticação. Porém, não consigo navegar pelo Firefox. Então, configurei o proxy no navegador Chrome e por este consigo navegação na internet, mas, somente depois que autentico usuário no Firefox porque o Chrome com proxy não aciona o captive portal.

    Complicado isto né?



  • @Goncaze:

    Prezados,

    Estou fazendo testes com o Squid3-dev no modo proxy autenticado na porta 3128 e estou puxando autenticação do usuário através do Captive Portal.

    O problema é que no Firefox não configurei o proxy e isto me permitiu acessar a interface do Captive Portal para realizar a autenticação. Porém, não consigo navegar pelo Firefox. Então, configurei o proxy no navegador Chrome e por este consigo navegação na internet, mas, somente depois que autentico usuário no Firefox porque o Chrome com proxy não aciona o captive portal.

    Complicado isto né?

    Não entendi.  Você está utilizando proxy autenticado na porta 3128 ou via captive?  ???



  • Olha lá no http://sys-squad.com/sys/curso/48, tem uma aula disso.



  • Prezados,

    Consegui resolver o meu problema usando umas técnicas muito loucas!

    O captive portal autentica, porém, não encaminha para as portas liberadas do proxy. Então, segui o tutorial do RCBRASIL (http://www.rcbrasil.com.br/blog/?p=114) fazendo PortForward para as portas do squid.

    Ficou assim a minha autenticação: Squid autentica com -> Captive Portal que usa configurações Radius -> NPS do Server 2008R2.

    Mas, então, começou os problemas com certificados para sites SSL (443 - HTTPS). Então segui as orientações do João B.R. Neto (https://www.youtube.com/watch?v=neXcYtFDRLA) que também seguiu orientações de um tal marcelloc que dizem ser o ninja brasileiro do pfsense.

    Por enquanto, agora estou prosseguindo com tudo certo! Ops quase tudo certo porque o squid não faz cache dos arquivos de testes como os disponibilizados no http://arquivos.oi.com.br e como não está fazendo o cache, os arquivos são baixados novamente sem que o squid retorne o mesmo do HD.

    O outro problema é que nunca vi o LoadBalance funcionar corretamente, exceto, na vez em que de propósito desconectei um dos cabos de rede Wan e reconectei novamente. Mas, depois de um tempo a função de loadbalance parou.



  • @Goncaze:

    seguiu orientações de um tal marcelloc que dizem ser o ninja brasileiro do pfsense.

    O Marcello é quem compilou o squid3 para o pfSense e moderador deste fórum. As aulas que eu sugeri são dele, não creio que ele seja ninja mas ele é muito bom no que faz. :)



  • Ninja do pfsense!? :o

    Vou atualizar meu LinkedIn com essa nova capacitação :)