Disable TCP timestamp



  • Hello,

    Is there any way that we can disable the TCP timestamp on Pfsense? I am currently having the dropping or timeout issues from incoming traffic user that behind their proxy server/network.

    Base on the TCPdump result, it might related to the TCP timestamp http://serverfault.com/questions/235965/why-would-a-server-not-send-a-syn-ack-packet-in-response-to-a-syn-packet

    Thanks,
    Leap


  • LAYER 8 Global Moderator

    What??  Lets see this wireshark where your not sending synack to your ack.  You know what is more likely for a box to not answer - it didn't get the syn, it has a firewall on, its not even listening on that port.

    So you think pfsense is adding timestamps to packets it forwards.. And that is why your something is not working??  Really??  You do understand the sending OS of the traffic would put the tcp timestamps or not, pfsense is not going to add them to packets it forwards..  Is pfsense the one sending the syn to whatever it is that is not working?



  • Hello Jonhpoz,

    Thanks for your reply. I am quite new and I would love to hear the answer if problem is not causing by pfsense which easily for me to tell the client who has this problem to look at their settings.

    So you think pfsense is adding timestamps to packets it forwards.. And that is why your something is not working?

    ,
    I am not sure otherwise I won't raise this post in the forum.

    Thanks again.
    Leap


  • LAYER 8 Global Moderator

    Not saying the issue is not pfsense, but not really where I would first look..  And I would be betting a large sum of money that it has nothing to do with tcp timestamps that pfsense adding ;)

    Where is this tcpdump?  Taken where - at the server side where the traffic hits and you get no synack back?

    Pfsense is NOT going to be adding tcp timestamps to traffic it forwards that is for sure..


Log in to reply