RPM packages upgrade via YUM slow on LAN



  • Hello,

    I have the following configuration:

    Internet connection <–> WAN <--> pfSense <--> LAN <--> VM

    My pfSense is Out of the Box with no additional personal configuration.

    My VM is a CentOS on which I run a "yum upgrade".

    The problem is that RPM packages download but really slowly (some kB/s on a quick internet connection).

    I am not sure to understand why as I see a rule 'LAN net' source which is 'allowed to any rule' in the firewall rules.

    Did I miss something?

    Regards,
    Rudy



  • There is no magic.  Right out of the box, it's just a routing firewall.  If you had squid installed, then I would be suspicious.  Is this physical install or virtual?  PC or appliance?  Which version, 2.2.3?  Which hypervisor?  From here I would start by looking at your link stability.  Any packetloss on WAN or LAN?  Is it just updating packages or is everything slow?



  • Hi KOM and thank you for your quick feedback.

    • Everything is VM.
    • The hypervisor is a ESXi.
    • the LAN is in a specific VLAN and pfSense is its gateway.

    Yesterday after my post, I just have enabled the "Forwarding Mode" of the "DNS Resolver". I did it because there was no DNS server configured in the LAN part.
      Directly after that, I was able to resolve public hostnames but downloads were still slow.
      I also did ping tests and there was no packets loss.

    Since then, I didn't do anything.

    Today, I run a "yum upgrade" and downloads are quick.

    I still don't understand why?

    If you have an idea, it would be much appreciated.

    Anyway, what do you suggest regarding the title of this post? [SOLVED]?

    Regards,
    Rudy



  • I still don't understand why?

    Sometimes you won't.  Your problem might have been completely related to a slow package mirror for your distro.  That's why I asked if it was just updating that was slow or everything in general.  Glad to see you got it working.

    You don't have to change the subject since we didn't really solve anything.  The problem just went away on its own.



  • Sounds good.
    I will plan to take a training course for sure …


Log in to reply