USB NIC D-Link DUB-E100 USB 2.0 10/100Mbps does not work on 2.2.4 ?

  • I bought D-Link DUB-E100 because I found it here . When I connect  it to my box running pfsense 2.2.4 it is recognized as a nic. I configured it to LAN With DHCP server. When I connect my Laptop it gets an IP as suspected. My pfsense box are pingable. And my Laptop is pingable from my pfsense box. But I'm not able to Connect to the WebGUI.  :( I hope someone can help me with this!

  • :( No one? I am stucket and are struggeling with this. If you have tips ,  I will be gratefull!

  • I have tried i386 on another pc With same result. I have checked that the USB Nic works With Windows 7, What is happening?

    I hope someone can give me a tips!

  • I hope someone can give me a tips!

    Please have a look to your hardware, if this is 32Bit based hardware please usethe x_86 pfSense
    image and if this is 64Bit hardware please sue the 64Bit pfSense image.

    Connect the USB-LAN Adapter and do a full install to a medium such a SSD/HDD/mSATA
    and then reboot after installation. Then you would be seeing more detailed what is going
    on with this USB-LAN adapter.

  • Thank you for tips Frank!
    I tried to install on a 32 bit pc with x_86 image and on a 64bit with 64bit image. Same result. I installed FreeBSD 10.1 on my 64 bit machine. And here it worked! I was able to download software from internet.

    Here is the result for dmesg, same result on FreeBSD and PFSense:

    ugen4.2: <vendor 0x2001="">at usbus4
    axe0: <vendor 2="" 0x2001="" product="" 0x1a02,="" rev="" 2.00="" 0.02,="" addr="">on usbus4
    miibus1; <mii bus="">on axe0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 16 on miibus1
    ukphy0: none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX.FDX, auto, auto-flow
    ue0: <usb ethernet="">on axe0
    ue0: Ethernet address: 3c:1e:04:F3:B9:a0
    ue0: link state change to DOWN
    ueo: link state change to UP

    This seems to be OK?</usb></generic></mii></vendor></vendor>

  • That was the 8.1 Hardware list, 2.2.4 uses 10.1, it should work though.
    I suspect a configuration error. What interface do you have assigned to ue0, and what are the rules on that interface? If it's not the LAN interface, you need to allow access to the webgui.

  • Thank you for answer!  :) This is a fresh install out of the box. I get re0 for onboard nic that I want to use as WAN. I get ue0 for DUB-E100. Then I set ue0 for LAN and setting ip address to and activate DHCP. Then I connect a client to the DUB-ED100, get an ip adresse as suspected. I can ping pfsense, but not access webgui. I can not ping either. From the PFSense console I can ping I can ping my pc to. Even if I activate SSH on PFSense console, I'm not able to connect using putty. This is weird. What shall I configure? The configuration must be done from the console.

  • Banned

    Stick some FW rules on the new interface?

  • Hello doktornotr!
    I'm not quite sure how to do this from Console. Can you guide me? If I switch re0 and ue0 so that ee0 is LAN and ue0 is WAN, I'm able to access WebGUI. So there must be something with the USB NIC

  • Banned

    From console, you don't. This is completely unrelated to HW. There is default rule to allow outgoing traffic on LAN. There is no such rule on any other interfaces you add -> all traffic blocked.

  • I have onboard NIC as re0 and USB as ue0. I configured re0 for LAN and ue0 for WAN. Then WebGUI worked. But pinging from console did'nt work. So am'm back to that is an hw issue with DUB-E100 that I can't figure out. Do I have to set some parameters on the USB NIC?

  • Banned

    Dude I already explained above. ADD ALLOW RULES TO THE NEW INTERFACE!

  • Hello again! Can you please explain how I can set this rule without having access to WebGUI?

  • Banned

    Connect via the other one?

  • I have tried an other USB nic as LAN, and it worked! So I belive there must be something with HW settings on the D-Link. The USB I tried was bought on ebay for a few $. It is not very stable thow. The D-Link is more expensive and should be working.

Log in to reply