Slow connection with CAT6

  • Hi,

    Yesterday, I changed a CAT5e for a CAT6. I don't know why, but my connection now is stuck at 100mbps (with cat5e is 300mbps). So, instead of use my laptop, I did a test with another laptop and I got the 300mbps. In this moment I was thinking the problem is with my laptop, then I put cat 5e again in my laptop and the connection was 100mbps!. I reset pfsense and I have again 300mb wit CAT5e. So maybe the problem is with pfsense?.

    I know… I don't need a CAT6 cable, but I want to know what is going on!

  • My first instinct would be that there's something not right with that Cat6 cable.

    Where did you get it, do you have access to another one from a different source?

    On another note, Cat6 cabling gets you absolutely nothing unless all components in the cabling chain are rated for Cat6.

    Even then, unless you are trying to get into a 10GB LAN environment, you're not likely to see any performance improvements.

  • I know, I can use CAT5e cable and problem solved ;)

    But I want to know what is the problem because the CAT6 is working perfectly with other laptop!. And the weird thing is when I do this sequence: cat5e, cat6, cat5e. In this moment a I get 100mbps with cat5e! and I have to reset the pfsense for get 300mbps again.

  • LAYER 8 Global Moderator

    huh?  300mbps cat5e is more than cable of gig. That standard for gig is 5e will work.  I run it all over the place without any issues for gig.  Are you doing some speed test where you got that 300mbps number from vs what your interfaces are showing for connections.

    If your connected at 100 there is no way would actually see 100, it would be say mid to high 90s at best.  You can never actually see wire speed..

    So how exactly are you doing the testing or finding these numbers.

    If the cable passes specs then cat6 should be showing you what speed your connected at.  you can view the speed of pfsense connections with ifconfig or in the gui.

    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:50:56:00:00:02
            inet6 fe80::250:56ff:fe00:2%em1 prefixlen 64 scopeid 0x2
            inet netmask 0xffffff00 broadcast
            inet6 2001:snipped::1 prefixlen 64
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)</full-duplex>

    In windows you can look at status of your interface


  • If you have a managed switch, what speed/duplex is the port that the pfSense is plugged into set at? Some devices will default to the lowest common speed by default if the device and the port are both set to autonegotiate.

  • Ok, ifconfig with CAT5e:
    igb1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active

    Now, I change CAT5E for CAT6:     
    igb1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active

    So, that is the problem. If I force 1000baseTX with:
    ifconfig igb1 media 1000baseTX mediaopt full-duplex

    I get "status: no carrier" :(

    It is problem of my laptop, I'm going to update drivers and so on and buy a cat5e cable hahah.


  • Read up on auto detection protocols for 10/100/1000.  There are some differences in how the determines the speed based on pair connections etc.  I remember reading a little about it a while back but not enough to explain.

    On second thought it may have been PoE I was reading about.

  • LAYER 8 Global Moderator

    If your cable doesn't auto come up gig then you should never force it and expect it to work that is for sure!!

    Throw the cable out if its not coming up gig.. Do you have a cable tester?  Do you know anyone that has a cable tester..  Cables are pretty cheap, I would just throw it out and get new one from good source.  I like deepsurplus or monoprice never had any issues with their very reasonable priced cables.

  • I did a test with a Live Usb with Linux and the same, so maybe the cable has some issue…

    I don't have a cable tester, so I'm going to buy a new one as you told. Anyway this situation is curious.

    Thnaks guys!

  • I like to build my own cables.  A little tedious to put the connectors on, but if there is a problem, just cut off the connector and try again.

    If you don't have some place local to buy crimper, bulk cable and connectors.  Have a look at:

    That's where I buy from.

  • Back in the day I used to make my own cables, but it's such a hassle now and cables are cheap.  You forgot the cable tester in your list.  Making your own without a tester is setting you up to chase ghosts in the wire.

  • LAYER 8 Global Moderator

    yeah a cable tester is good tool for the belt for anyone that deals with cabling be it you make your own or buy predone, etc.

    Simple testers can be as cheap as <$50 for sure.. Now if you want a fancy specification validation tool you can get into the 1000's so kind of out of the realm of home user diyer ;)

    The cheap ones won't point out issues in quality of the cable but will real quick tell you if wiring is wrong, shorts/opens, etc.  So nice tool to check a cable before you put it into use, etc.  And that you crimped them correctly, etc.

Log in to reply