Exchange Issue



  • Guys; On Pfsense 2.2.4

    I can't connect to my Exchange Server via ActiveSync inside the LAN from DMZnet.  Outside the LAN I connect to my server an pull email successfully.  I created a rule  When I am home I pull a IP from my DMZnet where my AP is plugged into.

    I created a rule DMZ->(IP of Exchange Server which is on the LAN) port 443 and place it in the top position of my DMZ rules.  This used to work in version 2.2.1

    What am I missing to make this work?

    Thanks



  • First off, why have you got an internet-facing mail server operating on your LAN when it should be in the DMZ? You seem to be using your DMZ as your LAN and your LAN as a DMZ. Ideally, you should run your Exchange server from your DMZ from where it can serve ActiveSync requests from outside and from your LAN.

    Without seeing your rules, at a guess I'd say it might be a routing issue. Have you tried pinging the Exchange server? Or tried running a telnet session to the target port on your Exchange server to see if it's responding? And have you looked at your firewall logs to see if any traffic is getting through?

    As always seems to be the case, more information would be helpful. Screenshots of your rules and NAT for a start.



  • Okay I disagree with you on my setup.  It been configured like this for 10+ years without any issues until now.  I attached my DMZ rules & NAT rules





  • Banned

    @bigraz1968:

    I can't connect to my Exchange Server via ActiveSync inside the LAN from DMZnet.  Outside the LAN I connect to my server an pull email successfully.

    Yeah. Fix your internal DNS to point to where Exchange is. Not to your WAN.


Log in to reply