Apple TV Issues with Playing Content After Update

  • Hey Guys,

    I just updated my ATV3 to 7.2 a few days ago and for some reason I can't play content any longer. At first, I didn't even think of the firewall as I have the default LAN->ANY rules enabled.  Tried my ATV at the Apple store and everything worked.  So at home, I connected it to my 3G hotspot - everything worked. No changes had been made to the firewall for a few months before the 7.2 update.

    I've done the following with my 2.2.4 Pfsense Firewall:

    Disabled/Tested/Re-enabled all IPv6 (found some google searches on this topic)
    On the Apple TV - Disabled DHCP and assigned a static ip - forced DNS to and then (OpenDNS)
    Installed/Test/Uninstalled - Avahi
    Forced a DHCP update on the WAN interface to grab another Public IP

    I don't show any drops in the logs for the the Apple TV which makes me think it's not the firewall but it works elsewhere.

    Would anyone have any ideas on things I could test on the firewall to rule it out?

    In the meantime, I'll start isolating the ATV. First plugging it in directly to my cable modem, then plugging it in to the LAN interface on the firewall to rule out the switch.


  • Banned

  • Don't know what packages you are running but seeing similar things here.

    After recent updates, I too am having issues with ios devices not seeing NetFlix.  On iPhones and iPads, for now I'm assigning static addresses (via DHCP) and bypassing those addresses in the proxy (Squid 3).  However, the Apple TVs (also V3s) still fail on NetFlix even though every other App seems to stream just fine.  On the AppleTV it eventually throws a code  139:NFErr_MC_AuthFailure.    Otherwise, all the other devices in the house, PCs, Ubuntu, RoKu, DishNetwork and Smart TVs all stream NetFlix content with no issue.

    That said, I keep a plastic box linksys router with the latest DD-WRT beta loaded as a standby/backup.  If I revert to this solution, everything works.  So I know it's something in pfSense/pfBlockerNG/Squid3/Snort but I just haven't been able to pin it down yet and I'm not really seeing anything helpful in the logs.  I've been turning services off but still not seeing any positive results either.

    It all worked fine a month ago.

    And yes, doktornotor, I too called NetFlix AND just got off the phone with Apple too.
    This is not a real show stopper as I have alternative means for viewing the content…  It's just one of those issues that I'd like to fix.  And since the Linksys test seem to show this error resides within my pfSense box, I know neither NetFlix nor Apple have any interest in resolving it.

    Any Ideas, anyone??  (every time I ask that I have to fight off the urge to say "anyone?, anyone?, Buechler?, Buechler?).  OK, there it's out of my system.


  • "anyone?, anyone?, Buechler?, Buechler?"

    Except that Buechler is pronounced BEEK-ler, so it doesn't have that same ring to it.

    Best I can suggest is to capture the traffic when it's working versus when it's not and then deduce the problem from the traces.  I wonder if it might be a static port issue?

  • Banned

    I am extremely amused. Buying overpriced Bitten Fruit junk with non-existent support, non-existent compatibility with non-Apple HW and complaining that broken Apple update breaks things on pfSense forum. ROFL. Perhaps they could sell you some of their excellent 300% bugfree and supercompatible routers instead? Such as this:

  • @doktornotor:

    I am extremely amused.

    Glad to bring a smile to your world…. ;D  always seems a bit pithy in there.

    Who's to say if the bugginess lies with pfSense or bitten fruit...  I mean, it works fine under Seb's code.
    With the exception of my phone, I didn't buy any of the aforementioned items.  Got 'em free and made 'em work. (iFixit is your friend)

    Thanks to KOM and the constructive comments.  You nailed it.


  • Little bit of an update.

    If I plug the Apple TV directly into my firewall (ALIX board) - everything works. However, if it's plugged into a switch (tried 3 different brands) or uses Wifi from an AP that's plugged into the firewall, it fails. No errors appear on the interfaces.  I can also confirm the current version of DD-WRT on a linksys router does not produce this issue.

    Going to compare dumps from both scenarios tonight to see if anything sticks out.

Log in to reply