On WAN2 cant ping outside from pfsense itself. But LAN can reach "internet"

  • Hi,

    Seems that I have an issue when WAN1 (primary) goes down.

    If I connect via SSH to the pfsense I cant ping outside addresses like
    But if I reconnect the WAN1 I can ping from pfsense.

    The LAN is not affected by this problem, all the hosts can access anything like normal.

    When WAN1 is disconnected and we are running on WAN2

    [2.2.6-RELEASE][admin@xxxx]/home/admin: ping
    PING ( 56 data bytes
    --- ping statistics ---
    15 packets transmitted, 0 packets received, 100.0% packet loss

    When WAN1 is up I get this

    [2.2.6-RELEASE][admin@xxxx]/home/admin: ping
    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=45 time=36.921 ms
    64 bytes from icmp_seq=1 ttl=45 time=38.392 ms
    64 bytes from icmp_seq=2 ttl=45 time=44.726 ms
    --- ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 36.921/40.013/44.726/3.386 ms

    So what can make the LAN work flawless but the pfsense itself have problems.

    This problem makes it impossible to remote manage the pfsense.
    I can see in the firewall logs that my remote connection shows up ass PASSED on WAN2 interface if I try HTTPS to the pfsense. But from the remote client it show connection timeout in browser. So it feels like a routing issue from the pfsense itself.

    I notice that under Gateways, the gateway for WAN1 have (Default) next to it, even though I did not check the Default checkbox during the creation of the Gateway.

  • From diagnostics Ping, if I choose interface WAN2 I can Ping and from LAN, but not from localhost. But when WAN1 is connected, localhost also works

  • I guess for your LAN you have a gateway failover group attached to the firewall rules so you use WAN2 when WAN1 is down.

    The pfsense itself will always use the default gateway.
    You need to apply default gateway switching if you want this behavior.

  • Thank you l4k3k3m4n. I think this will fix it. Will enable it from System -> Advanced -> Miscellaneous -> Load Balancing. It where unchecked now. Will mark as solved after I have verified that it works.

    Thanks again

  • Worked perfect. Thanks again  :D

Log in to reply